aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2017-04-04 15:02:08 +0800
committerbapt <bapt@FreeBSD.org>2017-04-04 15:02:08 +0800
commitb5c12d9cf2e2e79e6544bbfd603db539e8234952 (patch)
tree638433a078292e07e638f97a1c3b33f0569eed3d
parentef03da6e11a7922d27905420995bce0caa76b4a7 (diff)
downloadfreebsd-ports-gnome-b5c12d9cf2e2e79e6544bbfd603db539e8234952.tar.gz
freebsd-ports-gnome-b5c12d9cf2e2e79e6544bbfd603db539e8234952.tar.zst
freebsd-ports-gnome-b5c12d9cf2e2e79e6544bbfd603db539e8234952.zip
Fix build with new sigc++20
-rw-r--r--games/gtkevemon/Makefile3
-rw-r--r--print/libgnomeprintmm/Makefile3
-rw-r--r--x11-toolkits/flowcanvas/Makefile3
-rw-r--r--x11-toolkits/libgnomeuimm26/Makefile4
4 files changed, 9 insertions, 4 deletions
diff --git a/games/gtkevemon/Makefile b/games/gtkevemon/Makefile
index 2be143c0530a..6228c6983dee 100644
--- a/games/gtkevemon/Makefile
+++ b/games/gtkevemon/Makefile
@@ -14,7 +14,8 @@ LIB_DEPENDS= libgtkmm-3.0.so:x11-toolkits/gtkmm30 \
USE_GITHUB= yes
GH_TAGNAME= ac2ca34
-USES= pkgconfig:both gmake ssl
+USES= compiler:c++11-lang pkgconfig:both gmake ssl
+USE_CXXSTD= c++11
USE_GNOME= gtk30 libxml2
.include <bsd.port.pre.mk>
diff --git a/print/libgnomeprintmm/Makefile b/print/libgnomeprintmm/Makefile
index 72bb6d7bdc9d..b8f5fe19c171 100644
--- a/print/libgnomeprintmm/Makefile
+++ b/print/libgnomeprintmm/Makefile
@@ -14,7 +14,8 @@ COMMENT= C++ bindings for the GNOME print support library
LIB_DEPENDS= libgtkmm-2.4.so:x11-toolkits/gtkmm24
BUILD_DEPENDS= gm4:devel/m4
-USES= gmake libtool pathfix pkgconfig tar:bzip2
+USES= compiler:c++11-lang gmake libtool pathfix pkgconfig tar:bzip2
+USE_CXXSTD= c++11
USE_GNOME= gnomeprefix libgnomeprint
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
diff --git a/x11-toolkits/flowcanvas/Makefile b/x11-toolkits/flowcanvas/Makefile
index 7b9d2f9cc636..29a28b64c4e4 100644
--- a/x11-toolkits/flowcanvas/Makefile
+++ b/x11-toolkits/flowcanvas/Makefile
@@ -18,7 +18,8 @@ LIB_DEPENDS= libboost_date_time.so:devel/boost-libs \
libgnomecanvasmm-2.6.so:graphics/libgnomecanvasmm26 \
libgtkmm-2.4.so:x11-toolkits/gtkmm24
-USES= pkgconfig tar:bzip2 waf
+USES= compiler:c++11-lang pkgconfig tar:bzip2 waf
+USE_CXXSTD= c++11
USE_LDCONFIG= yes
CFLAGS+= -I${LOCALBASE}/include
diff --git a/x11-toolkits/libgnomeuimm26/Makefile b/x11-toolkits/libgnomeuimm26/Makefile
index 8243dc40e7a3..f1e236ae9b05 100644
--- a/x11-toolkits/libgnomeuimm26/Makefile
+++ b/x11-toolkits/libgnomeuimm26/Makefile
@@ -19,7 +19,9 @@ LIB_DEPENDS= libgnomemm-2.6.so:x11/libgnomemm26 \
libgnomevfsmm-2.6.so:devel/gnome-vfsmm
BUILD_DEPENDS= gm4:devel/m4
-USES= gmake libtool:keepla pathfix pkgconfig tar:bzip2
+USES= compiler:c++11-lang gmake libtool:keepla pathfix pkgconfig \
+ tar:bzip2
+USE_CXXSTD= c++11
USE_XORG= x11
USE_GNOME= libgnomeui
GNU_CONFIGURE= yes