aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorohauer <ohauer@FreeBSD.org>2015-11-01 19:18:52 +0800
committerohauer <ohauer@FreeBSD.org>2015-11-01 19:18:52 +0800
commitb5f269faab004c1924696bad7c30846647c28a5a (patch)
treeaf1a419e9edc0d9e3b8f1209d11c2d9546323a8a
parent4f84defd38270d5d3301dc16424bc587798455d3 (diff)
downloadfreebsd-ports-gnome-b5f269faab004c1924696bad7c30846647c28a5a.tar.gz
freebsd-ports-gnome-b5f269faab004c1924696bad7c30846647c28a5a.tar.zst
freebsd-ports-gnome-b5f269faab004c1924696bad7c30846647c28a5a.zip
- update to 3.37
- change MASTER_SITE to GitHub - use autoreconf - adjust pkg-desc Changelog: 3.37: - print rtmetric and rtflow samples - include timestamp in grep-friendly (-g) output 3.36: - incorporate buffer-overrun protection suggestions from Andre Gruenenberg - incorporate portability changes from Rowan Thorpe - incorporate IPv6 forwarding changes from Rowan Thorpe - print IPID field from IPv4 sampled headers 3.35: - add Broadcom ASIC counters structure - add TCP/IP counters structure 3.34: - decode new counters in host cpu struct (steal, guest, and guest_nice) 3.33: - bugfix: app-sample status and duration_uS fields were reversed
-rw-r--r--net/sflowtool/Makefile14
-rw-r--r--net/sflowtool/distinfo4
-rw-r--r--net/sflowtool/files/patch-src__sflowtool.c33
-rw-r--r--net/sflowtool/pkg-descr7
4 files changed, 20 insertions, 38 deletions
diff --git a/net/sflowtool/Makefile b/net/sflowtool/Makefile
index d322ee6275cb..fe0dac407987 100644
--- a/net/sflowtool/Makefile
+++ b/net/sflowtool/Makefile
@@ -2,16 +2,22 @@
# $FreeBSD$
PORTNAME= sflowtool
-PORTVERSION= 3.32
+PORTVERSION= 3.37
CATEGORIES= net
-MASTER_SITES= http://www.inmon.com/bin/
+MASTER_SITES= GH
MAINTAINER= ohauer@FreeBSD.org
COMMENT= sFlow capture and sFlow-to-NetFlow conversion tool
+USES= autoreconf
GNU_CONFIGURE= yes
USE_RC_SUBR= ${PORTNAME}
+USE_GITHUB= yes
+GH_ACCOUNT= sflow
+GH_PROJECT= ${PORTNAME}
+GH_TAGNAME= 08a16d3
+
PLIST_FILES= bin/sflowtool
PORTDOCS= README
PORTEXAMPLES= README ipTopTalkers ipTrafficMatrix sflowRRDChart.cgi \
@@ -21,8 +27,8 @@ PORTEXAMPLES= README ipTopTalkers ipTrafficMatrix sflowRRDChart.cgi \
post-install:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
- @${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
@${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
- @${INSTALL_DATA} ${PORTEXAMPLES:S|^|${WRKSRC}/scripts/|} ${STAGEDIR}${EXAMPLESDIR}
+ ${INSTALL_DATA} ${PORTEXAMPLES:S|^|${WRKSRC}/scripts/|} ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>
diff --git a/net/sflowtool/distinfo b/net/sflowtool/distinfo
index 96f831fb562e..31fc02bb49d0 100644
--- a/net/sflowtool/distinfo
+++ b/net/sflowtool/distinfo
@@ -1,2 +1,2 @@
-SHA256 (sflowtool-3.32.tar.gz) = edb40902e76377b12a08a513bf49776e0a70e43c7f541f77de995cc23ccb7343
-SIZE (sflowtool-3.32.tar.gz) = 171316
+SHA256 (sflow-sflowtool-3.37-08a16d3_GH0.tar.gz) = fcd63581c84027660bd165068b0300b4c22ee7d5c1803e5bcd699ce95277ff61
+SIZE (sflow-sflowtool-3.37-08a16d3_GH0.tar.gz) = 74186
diff --git a/net/sflowtool/files/patch-src__sflowtool.c b/net/sflowtool/files/patch-src__sflowtool.c
index 16be85fb1f76..519b6b5793bf 100644
--- a/net/sflowtool/files/patch-src__sflowtool.c
+++ b/net/sflowtool/files/patch-src__sflowtool.c
@@ -1,33 +1,6 @@
---- ./src/sflowtool.c.orig 2014-05-27 21:09:17.000000000 +0200
-+++ ./src/sflowtool.c 2014-05-31 09:15:00.000000000 +0200
-@@ -442,7 +442,7 @@
- void *my_calloc(size_t bytes) {
- void *mem = calloc(1, bytes);
- if(mem == NULL) {
-- fprintf(ERROUT, "calloc(%u) failed: %s\n", bytes, strerror(errno));
-+ fprintf(ERROUT, "calloc(%zu) failed: %s\n", bytes, strerror(errno));
- exit(-1);
- }
- return mem;
-@@ -554,7 +554,7 @@
- register char c, *r = in, *w = out;
- int maxlen = (strlen(in) * 3) + 1;
- if(outlen < maxlen) return "URLEncode: not enough space";
-- while (c = *r++) {
-+ while ((c = *r++)) {
- if(isalnum(c)) *w++ = c;
- else if(isspace(c)) *w++ = '+';
- else {
-@@ -3075,7 +3075,7 @@
- uint8_t *uuid;
- char hostname[SFL_MAX_HOSTNAME_LEN+1];
- char os_release[SFL_MAX_OSRELEASE_LEN+1];
-- char uuidStr[100];
-+ u_char uuidStr[100];
- if(getString(sample, hostname, SFL_MAX_HOSTNAME_LEN) > 0) {
- sf_log(sample,"hostname %s\n", hostname);
- }
-@@ -3921,7 +3921,8 @@
+--- src/sflowtool.c.orig 2015-10-06 05:37:21 UTC
++++ src/sflowtool.c
+@@ -4308,7 +4308,8 @@ static int ipv4MappedAddress(SFLIPv6 *ip
static void readPacket(int soc)
{
struct sockaddr_in6 peer;
diff --git a/net/sflowtool/pkg-descr b/net/sflowtool/pkg-descr
index c51fee08cd76..631d1b15febf 100644
--- a/net/sflowtool/pkg-descr
+++ b/net/sflowtool/pkg-descr
@@ -1,6 +1,9 @@
+Print binary sFlow feed to ASCII, or forward it to other collectors.
+
This tool receives sFlow data, and generates either a simple-to-parse
tagged-ASCII output, or binary output in tcpdump(1) format. It can also
generate Cisco NetFlow version 5 datagrams and send them to a destination
-UDP host:port.
+UDP host:port, or forward the original sFlow feed to a number of
+additional collectors.
-WWW: http://www.inmon.com/technology/sflowTools.php
+WWW: https://github.com/sflow/sflowtool/