aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1999-10-12 16:09:46 +0800
committerasami <asami@FreeBSD.org>1999-10-12 16:09:46 +0800
commitb609d5cffefc0080118e6e40dd04e4842b468953 (patch)
tree4e6c866ccce1abbd4fa89c959c09160be46469c0
parent060ae997f3167ccbba5f646bf35b0a24165ec7c8 (diff)
downloadfreebsd-ports-gnome-b609d5cffefc0080118e6e40dd04e4842b468953.tar.gz
freebsd-ports-gnome-b609d5cffefc0080118e6e40dd04e4842b468953.tar.zst
freebsd-ports-gnome-b609d5cffefc0080118e6e40dd04e4842b468953.zip
This port uses X, define USE_XLIB. Create directory before installing.
Don't need to use += if variable is defined only once. Found by: bento-bako
-rw-r--r--www/flashplugin/Makefile4
1 files changed, 3 insertions, 1 deletions
diff --git a/www/flashplugin/Makefile b/www/flashplugin/Makefile
index 8641ee4b25cf..ee8036410b62 100644
--- a/www/flashplugin/Makefile
+++ b/www/flashplugin/Makefile
@@ -18,7 +18,8 @@ PATCHFILES= flash-0.4.3-fbsd-19990512.patch
MAINTAINER= knu@idaemons.org
-MAKE_ENV+= OBJFORMAT=aout LIBRARY_PATH=${PREFIX}/lib/aout
+USE_XLIB= yes
+MAKE_ENV= OBJFORMAT=aout LIBRARY_PATH=${PREFIX}/lib/aout
PORTOBJFORMAT= aout
ALL_TARGET= libswf.so
@@ -26,6 +27,7 @@ do-install:
.if !defined(PACKAGE_BUILDING)
@PKG_PREFIX=${PREFIX} ${SH} ${PKGREQ} ${PKGNAME} INSTALL
.endif
+ ${MKDIR} ${PREFIX}/lib/netscape/plugins
cd ${WRKSRC} && ${SETENV} OBJFORMAT=aout ${INSTALL_PROGRAM} libswf.so ${PREFIX}/lib/netscape/plugins
.include <bsd.port.mk>