aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorashish <ashish@FreeBSD.org>2011-10-30 06:17:12 +0800
committerashish <ashish@FreeBSD.org>2011-10-30 06:17:12 +0800
commitb61fe807a809d1263ebe0a6902bb51af247a1021 (patch)
tree98d272813f48070459fbafdab835ef6b55d88b7e
parent0a733d6cab1226f7b04054c4544a66d22b35ebff (diff)
downloadfreebsd-ports-gnome-b61fe807a809d1263ebe0a6902bb51af247a1021.tar.gz
freebsd-ports-gnome-b61fe807a809d1263ebe0a6902bb51af247a1021.tar.zst
freebsd-ports-gnome-b61fe807a809d1263ebe0a6902bb51af247a1021.zip
- Disable OPTIONS for editors/emacs-nox11 slave port
- Bump PORTREVISION of editors/emacs-nox11 Thanks to dougb, and eadler for showing the way Reported by: bz
-rw-r--r--editors/emacs-nox11/Makefile26
-rw-r--r--editors/emacs/Makefile8
-rw-r--r--editors/emacs23/Makefile8
3 files changed, 33 insertions, 9 deletions
diff --git a/editors/emacs-nox11/Makefile b/editors/emacs-nox11/Makefile
index 36bc31896eb5..70187b1e8d74 100644
--- a/editors/emacs-nox11/Makefile
+++ b/editors/emacs-nox11/Makefile
@@ -5,11 +5,31 @@
# $FreeBSD$
#
-_OPTIONS_OK= yes
-WITHOUT_DBUS= yes
-WITHOUT_X11= yes
+PORTREVISION= 7
PKGNAMESUFFIX= -nox11
+WITHOUT_CANNA= yes
+WITHOUT_DBUS= yes
+WITHOUT_GCONF= yes
+WITHOUT_GTK2= yes
+WITHOUT_JPEG= yes
+WITHOUT_M17N= yes
+WITHOUT_MOTIF= yes
+WITHOUT_OTF= yes
+WITHOUT_PNG= yes
+WITHOUT_SVG= yes
+WITHOUT_TIFF= yes
+WITHOUT_XAW= yes
+WITHOUT_XAW3D= yes
+WITHOUT_SYNC_INPUT= yes
+WITHOUT_SCROLLBARS= yes
+WITHOUT_X11= yes
+WITHOUT_XFT= yes
+WITHOUT_XIM= yes
+WITHOUT_XPM= yes
+
+EMACS_NO_X11_SLAVE= yes
+
MASTERDIR= ${.CURDIR}/../emacs
LATEST_LINK= emacs-nox11
diff --git a/editors/emacs/Makefile b/editors/emacs/Makefile
index 04d9736ec912..86a7097937b5 100644
--- a/editors/emacs/Makefile
+++ b/editors/emacs/Makefile
@@ -7,7 +7,7 @@
PORTNAME= emacs
PORTVERSION= ${EMACS_VER}
-PORTREVISION= 6
+PORTREVISION?= 6
PORTEPOCH= 2
CATEGORIES= editors ipv6
MASTER_SITES= ${MASTER_SITE_GNU}
@@ -24,8 +24,7 @@ MAKE_JOBS_UNSAFE= yes
CONFLICTS= emacs-19.* emacs-21.* emacs-22.* emacs-24.* \
xemacs-[0-9]* xemacs-devel-[0-9]* \
- xemacs-mule-[0-9]* xemacs-devel-mule-[0-9]* \
- emacs-nox11-[0-9]*
+ xemacs-mule-[0-9]* xemacs-devel-mule-[0-9]*
EMACS_VER= 23.3
GNU_CONFIGURE= yes
@@ -53,6 +52,8 @@ INFO= ada-mode auth autotype calc ccmode cl dbus dired-x \
org pcl-cvs pgg rcirc reftex remember sasl sc semantic ses sieve \
smtpmail speedbar tramp url vip viper widget woman
+.if !defined(EMACS_NO_X11_SLAVE)
+CONFLICTS+= emacs-nox11-[0-9]*
OPTIONS= CANNA "Canna support" OFF \
DBUS "DBus support" ON \
GCONF "GConf support" ON \
@@ -74,6 +75,7 @@ OPTIONS= CANNA "Canna support" OFF \
XFT "Freetype fonts support" ON \
XIM "X Input Method support" ON \
XPM "XPM images support" ON
+.endif
.include <bsd.port.options.mk>
diff --git a/editors/emacs23/Makefile b/editors/emacs23/Makefile
index 04d9736ec912..86a7097937b5 100644
--- a/editors/emacs23/Makefile
+++ b/editors/emacs23/Makefile
@@ -7,7 +7,7 @@
PORTNAME= emacs
PORTVERSION= ${EMACS_VER}
-PORTREVISION= 6
+PORTREVISION?= 6
PORTEPOCH= 2
CATEGORIES= editors ipv6
MASTER_SITES= ${MASTER_SITE_GNU}
@@ -24,8 +24,7 @@ MAKE_JOBS_UNSAFE= yes
CONFLICTS= emacs-19.* emacs-21.* emacs-22.* emacs-24.* \
xemacs-[0-9]* xemacs-devel-[0-9]* \
- xemacs-mule-[0-9]* xemacs-devel-mule-[0-9]* \
- emacs-nox11-[0-9]*
+ xemacs-mule-[0-9]* xemacs-devel-mule-[0-9]*
EMACS_VER= 23.3
GNU_CONFIGURE= yes
@@ -53,6 +52,8 @@ INFO= ada-mode auth autotype calc ccmode cl dbus dired-x \
org pcl-cvs pgg rcirc reftex remember sasl sc semantic ses sieve \
smtpmail speedbar tramp url vip viper widget woman
+.if !defined(EMACS_NO_X11_SLAVE)
+CONFLICTS+= emacs-nox11-[0-9]*
OPTIONS= CANNA "Canna support" OFF \
DBUS "DBus support" ON \
GCONF "GConf support" ON \
@@ -74,6 +75,7 @@ OPTIONS= CANNA "Canna support" OFF \
XFT "Freetype fonts support" ON \
XIM "X Input Method support" ON \
XPM "XPM images support" ON
+.endif
.include <bsd.port.options.mk>