aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortobez <tobez@FreeBSD.org>2008-02-25 20:31:25 +0800
committertobez <tobez@FreeBSD.org>2008-02-25 20:31:25 +0800
commitb686eb654bc777006b3e6d612d054dc0a39bc7bc (patch)
treeb28fec385e1739ebdbab57733c4701b67b337397
parent698e95c834d6e02fb24c6aa3a0554d0aa3cc38da (diff)
downloadfreebsd-ports-gnome-b686eb654bc777006b3e6d612d054dc0a39bc7bc.tar.gz
freebsd-ports-gnome-b686eb654bc777006b3e6d612d054dc0a39bc7bc.tar.zst
freebsd-ports-gnome-b686eb654bc777006b3e6d612d054dc0a39bc7bc.zip
Add devel/p5-Module-Util.
This module provides a few useful functions for manipulating module names. Its main aim is to centralise some of the functions commonly used by modules that manipulate other modules in some way, like converting module names to relative paths.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Module-Util/Makefile26
-rw-r--r--devel/p5-Module-Util/distinfo3
-rw-r--r--devel/p5-Module-Util/pkg-descr7
-rw-r--r--devel/p5-Module-Util/pkg-plist3
5 files changed, 40 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 1df1e66ded7d..f6fc05a96acc 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1411,6 +1411,7 @@
SUBDIR += p5-Module-ScanDeps
SUBDIR += p5-Module-Starter
SUBDIR += p5-Module-Starter-PBP
+ SUBDIR += p5-Module-Util
SUBDIR += p5-Module-Versions-Report
SUBDIR += p5-Moose
SUBDIR += p5-MooseX-IOC
diff --git a/devel/p5-Module-Util/Makefile b/devel/p5-Module-Util/Makefile
new file mode 100644
index 000000000000..c05384af91aa
--- /dev/null
+++ b/devel/p5-Module-Util/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: p5-Module-Util
+# Date created: 2008-02-25
+# Whom: Anton Berezin <tobez@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Module-Util
+PORTVERSION= 1.03
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= Module
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= tobez@FreeBSD.org
+COMMENT= Perl module name tools and transformations
+
+RUN_DEPENDS= p5-File-Find-Rule>0:${PORTSDIR}/devel/p5-File-Find-Rule
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_MODBUILD= YES
+
+MAN1= pm_which.1
+MAN3= Module::Util.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Module-Util/distinfo b/devel/p5-Module-Util/distinfo
new file mode 100644
index 000000000000..b08bf7c024e2
--- /dev/null
+++ b/devel/p5-Module-Util/distinfo
@@ -0,0 +1,3 @@
+MD5 (Module-Util-1.03.tar.gz) = 0cd676dcf9f84f185d0ada3642d87f60
+SHA256 (Module-Util-1.03.tar.gz) = b283be59b7d7433c85786e84b2b7a2ede568d078ec3535d74b62b85ac0a79c8d
+SIZE (Module-Util-1.03.tar.gz) = 9868
diff --git a/devel/p5-Module-Util/pkg-descr b/devel/p5-Module-Util/pkg-descr
new file mode 100644
index 000000000000..fd39c931e2b1
--- /dev/null
+++ b/devel/p5-Module-Util/pkg-descr
@@ -0,0 +1,7 @@
+This module provides a few useful functions for manipulating module
+names. Its main aim is to centralise some of the functions commonly used
+by modules that manipulate other modules in some way, like converting
+module names to relative paths.
+
+Author: Matt Lawrence <mattlaw@cpan.org>
+WWW: http://search.cpan.org/dist/Module-Util/
diff --git a/devel/p5-Module-Util/pkg-plist b/devel/p5-Module-Util/pkg-plist
new file mode 100644
index 000000000000..b6a559b28bad
--- /dev/null
+++ b/devel/p5-Module-Util/pkg-plist
@@ -0,0 +1,3 @@
+bin/pm_which
+%%SITE_PERL%%/Module/Util.pm
+@dirrmtry %%SITE_PERL%%/Module