aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authornox <nox@FreeBSD.org>2007-03-11 01:15:07 +0800
committernox <nox@FreeBSD.org>2007-03-11 01:15:07 +0800
commitb691c55a4605f8c26de7e2a897ed14a62d47e992 (patch)
treee4086db0ad817e299c908ebfe33c05aff8b79da5
parent4b97318f38b28e622e156218149de04ff5fe44ab (diff)
downloadfreebsd-ports-gnome-b691c55a4605f8c26de7e2a897ed14a62d47e992.tar.gz
freebsd-ports-gnome-b691c55a4605f8c26de7e2a897ed14a62d47e992.tar.zst
freebsd-ports-gnome-b691c55a4605f8c26de7e2a897ed14a62d47e992.zip
Update repocopied qemu-devel port to 2007-03-09 snapshot:
- reset rombios32 area - Support for more SPARC relocations, by Martin Bochnig. - Serial console improvements, by Stefan Weil. - Qemu support for S32 and U32 alsa output, by Vassili Karpov. - PS/2 interface - Allow custom IO ports + IRQ, by Herve Poussineau. - Add PS/2 keyboard to MIPS R4K, by Herve Poussineau. - Monitor multiplexing, by Jason Wessel. - -no-frame option for sdl, by Christian Laursen. - Don't require a disk image for network boot, by Ferenc Wagner. - Add -bootp option for slirp, by Anthony Liguori. - Add OACK support to slirp TFTP server, by Anthony Liguori. - Change -tftp option to take a root directory, by Anthony Liguori. - 2nd serial port for Malta, by Jason Wessel. - Increase the number of multiplexed monitor devices. - Allow arbitrary MIPS BIOS sizes between 0 and 4 MB, by Stefan Weil. - Allow gdbstub to connect over any serial device. - Basic USB device resume (root hub only), by Lonnie Mendez. - 24C01 / 24C02 EEPROM emulation for Malta, by Stefan Weil. - DS1225Y nvram device, by Herve Poussineau. - Make removing IOHandlers safe from within an IOHandler, by Anthony Liguori. - MIPS FPU dynamic activation, part 1, by Herve Poussineau. - MIPS Userland TLS register emulation, by Daniel Jacobowitz. - New -cpu options: choose CPU model for emulated target. Only relevant on PowerPC targets, for now. - Simple u-boot image loading support. - Great PowerPC emulation code resynchronisation and improvments: - Add status file to make regression tracking easier - Move all micro-operations helpers definitions into a separate header: should never be seen outside of op.c - Update copyrights - Add new / missing PowerPC CPU definitions - Add definitions for PowerPC BookE - Add support for PowerPC 6xx/7xx software driven TLBs Allow use of PowerPC 603 as an example - Add preliminary code for POWER, POWER2, PowerPC 403, 405, 440, 601, 602 and BookE support - Avoid compiling priviledged only resources support for user-mode emulation - Remove unused helpers / micro-ops / dead code - Add instructions usage statistics dump: useful to figure which instructions need strong optimizations. - Micro-operation fixes: * add missing RETURN in some micro-ops * fix prototypes * use softfloat routines for all floating-point operations * fix tlbie instruction * move some huge micro-operations into helpers - emulation fixes: * fix inverted opcodes for fcmpo / fcmpu * condition register update is always to be done after the whole instruction has completed * add missing NIP updates when calling helpers that may generate an exception - optimizations and improvments: * optimize very often used instructions (li, mr, rlwixx...) * remove specific micro-ops for rarely used instructions * add routines for addresses computations to avoid bugs due to multiple different implementations * fix TB linking: do not reset T0 at the end of every TB. - Implement --cpu for ARM. - And some bugfixes. Repocopy by: marcus Approved by: miwi (mentor, implicit)
-rw-r--r--emulators/qemu-devel/Makefile15
-rw-r--r--emulators/qemu-devel/distinfo9
-rw-r--r--emulators/qemu-devel/files/patch-Makefile12
-rw-r--r--emulators/qemu-devel/files/patch-bd18
-rw-r--r--emulators/qemu-devel/files/patch-fbsd10
-rw-r--r--emulators/qemu-devel/files/patch-vl.c8
-rw-r--r--emulators/qemu-devel/files/patch-vl.c-nographic4
7 files changed, 37 insertions, 39 deletions
diff --git a/emulators/qemu-devel/Makefile b/emulators/qemu-devel/Makefile
index 49edba1caaa2..1c6c72b148ce 100644
--- a/emulators/qemu-devel/Makefile
+++ b/emulators/qemu-devel/Makefile
@@ -6,24 +6,25 @@
#
PORTNAME= qemu
-PORTVERSION= 0.9.0
+PORTVERSION= 0.9.0s.20070309
CATEGORIES= emulators
MASTER_SITES= http://qemu.org/:release \
http://qemu-forum.ipi.fi/qemu-snapshots/:snapshot \
http://people.fruitsalad.org/nox/qemu/:snapshot \
http://www.volny.cz/xnavara/qemu/:snapshot \
http://people.brandeis.edu/~jcoiner/qemu_idedma/:idedma \
- http://people.freebsd.org/~maho/qemu/:misc \
- http://people.freebsd.org/~jkim/:bios
-DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:release \
- qemu-bios.bin:bios
+ http://people.freebsd.org/~maho/qemu/:misc
+DISTNAME= ${PORTNAME}-snapshot-2007-03-09_05
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX}:snapshot
DIST_SUBDIR= qemu
EXTRACT_ONLY= ${DISTNAME}${EXTRACT_SUFX}
+PKGNAMESUFFIX= -devel
MAINTAINER= nox@FreeBSD.org
-COMMENT= QEMU CPU Emulator
+COMMENT= QEMU CPU Emulator - development snapshot
HAS_CONFIGURE= yes
+USE_BZIP2= yes
USE_GMAKE= yes
USE_GETOPT_LONG= yes
USE_PERL5= yes
@@ -33,6 +34,7 @@ CONFIGURE_ARGS+= --prefix=${PREFIX} --cc=${CC}
MAKE_ENV+= BSD_MAKE="${MAKE}" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
MAN1= qemu.1 qemu-img.1
ONLY_FOR_ARCHS= amd64 i386
+CONFLICTS= qemu-[0-9]*
OPTIONS= KQEMU "Build with (alpha!) accelerator module" Off \
HACKS_CIRRUS "Large display speedup (buggy!)" Off \
@@ -80,7 +82,6 @@ post-extract:
@${MKDIR} ${WRKSRC}/kqemu
@${TOUCH} ${WRKSRC}/kqemu/Makefile
@${ECHO} all: > ${WRKSRC}/kqemu/Makefile.freebsd
- @${CP} -p ${_DISTDIR}/qemu-bios.bin ${WRKSRC}/pc-bios/bios.bin
pre-patch:
@for A in ${ONLY_FOR_ARCHS}; do \
diff --git a/emulators/qemu-devel/distinfo b/emulators/qemu-devel/distinfo
index c0f25c774916..20a397b7cab3 100644
--- a/emulators/qemu-devel/distinfo
+++ b/emulators/qemu-devel/distinfo
@@ -1,9 +1,6 @@
-MD5 (qemu/qemu-0.9.0.tar.gz) = ab11a03ba30cf4a70641f0f170473d69
-SHA256 (qemu/qemu-0.9.0.tar.gz) = 491facf9335654967ee53d8fb3540a274bfcbdcc225506bd38c4ee8e9ab405c1
-SIZE (qemu/qemu-0.9.0.tar.gz) = 1901741
-MD5 (qemu/qemu-bios.bin) = 173e256f17b4ac1f6e3249c83071e8f5
-SHA256 (qemu/qemu-bios.bin) = 452d863ec8ac9e2246950ac204410e847cdeba880d7bec2aeb79c4f2fbb0ad17
-SIZE (qemu/qemu-bios.bin) = 131072
+MD5 (qemu/qemu-snapshot-2007-03-09_05.tar.bz2) = e3899581b8628a6eeb1ba33e18aab632
+SHA256 (qemu/qemu-snapshot-2007-03-09_05.tar.bz2) = bb8cf3e70492fce405074436a3001f06e6193d58c313862b4c5d165c2beace74
+SIZE (qemu/qemu-snapshot-2007-03-09_05.tar.bz2) = 1667747
MD5 (qemu/patch3_cirrus) = ebe7ed9fce804c49e024bc93bfdfc810
SHA256 (qemu/patch3_cirrus) = e862371834b7d895a896fbdb84fd9f70d17b5729a6f6789a48a61504fc941e11
SIZE (qemu/patch3_cirrus) = 8817
diff --git a/emulators/qemu-devel/files/patch-Makefile b/emulators/qemu-devel/files/patch-Makefile
index 58defdea2eac..1dc9c0b94f2d 100644
--- a/emulators/qemu-devel/files/patch-Makefile
+++ b/emulators/qemu-devel/files/patch-Makefile
@@ -1,6 +1,6 @@
Index: qemu/Makefile
-@@ -20,6 +20,10 @@
- LDFLAGS+=-static
+@@ -19,14 +19,19 @@
+ BASE_LDFLAGS += -static
endif
ifdef BUILD_DOCS
+ifdef NOPORTDOCS
@@ -10,17 +10,17 @@ Index: qemu/Makefile
+endif
else
DOCS=
-@@ -28,7 +28,8 @@
+ endif
+
ifndef CONFIG_DARWIN
ifndef CONFIG_WIN32
- ifndef CONFIG_SOLARIS
-LIBS+=-lrt
+# XXX need ifndef CONFIG_BSD
+# LIBS+=-lrt
endif
endif
- endif
-@@ -72,8 +75,10 @@
+
+@@ -64,8 +69,10 @@
common de-ch es fo fr-ca hu ja mk nl-be pt sl tr
install-doc: $(DOCS)
diff --git a/emulators/qemu-devel/files/patch-bd b/emulators/qemu-devel/files/patch-bd
index 3f85d63c03a1..b8b49a136432 100644
--- a/emulators/qemu-devel/files/patch-bd
+++ b/emulators/qemu-devel/files/patch-bd
@@ -1,10 +1,10 @@
Index: qemu/configure
-@@ -286,7 +286,7 @@
- if test -z "$prefix" ; then
- prefix="/usr/local"
- fi
--mandir="$prefix/share/man"
-+mandir="$prefix/man"
- datadir="$prefix/share/qemu"
- docdir="$prefix/share/doc/qemu"
- bindir="$prefix/bin"
+@@ -570,7 +570,7 @@
+ if test -z "$prefix" ; then
+ prefix="/usr/local"
+ fi
+- mansuffix="/share/man"
++ mansuffix="/man"
+ datasuffix="/share/qemu"
+ docsuffix="/share/doc/qemu"
+ binsuffix="/bin"
diff --git a/emulators/qemu-devel/files/patch-fbsd b/emulators/qemu-devel/files/patch-fbsd
index 7195d62837b8..1fccf8b7cfe7 100644
--- a/emulators/qemu-devel/files/patch-fbsd
+++ b/emulators/qemu-devel/files/patch-fbsd
@@ -20,17 +20,17 @@ Index: qemu/Makefile
rm -f *.o *.a $(TOOLS) dyngen$(EXESUF) TAGS *.pod *~ */*~
$(MAKE) -C tests clean
Index: qemu/Makefile.target
-@@ -391,8 +391,8 @@
- VL_LDFLAGS+=-Wl,-G0 -Wl,-T,$(SRC_PATH)/ia64.ld
+@@ -465,8 +465,8 @@
+ SDL_LIBS := $(filter-out -mwindows, $(SDL_LIBS)) -mconsole
endif
-$(QEMU_SYSTEM): $(VL_OBJS) libqemu.a
-- $(CC) $(VL_LDFLAGS) -o $@ $^ $(LIBS) $(SDL_LIBS) $(COCOA_LIBS) $(VL_LIBS)
+- $(CC) $(VL_LDFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS) $(SDL_LIBS) $(COCOA_LIBS) $(VL_LIBS)
+$(QEMU_SYSTEM): $(VL_OBJS) libqemu.a ../bsd/libmath.a
-+ $(CC) $(VL_LDFLAGS) -o $@ $^ $(LIBS) $(SDL_LIBS) $(COCOA_LIBS) $(VL_LIBS) ../bsd/libmath.a
++ $(CC) $(VL_LDFLAGS) $(LDFLAGS) -o $@ $^ $(LIBS) $(SDL_LIBS) $(COCOA_LIBS) $(VL_LIBS) ../bsd/libmath.a
cocoa.o: cocoa.m
- $(CC) $(CFLAGS) $(DEFINES) -c -o $@ $<
+ $(CC) $(CFLAGS) $(CPPFLAGS) $(BASE_CFLAGS) -c -o $@ $<
Index: qemu/fpu/softfloat-native.c
@@ -2,11 +2,16 @@
context is supported */
diff --git a/emulators/qemu-devel/files/patch-vl.c b/emulators/qemu-devel/files/patch-vl.c
index 437dafe471b2..44c3c64cb468 100644
--- a/emulators/qemu-devel/files/patch-vl.c
+++ b/emulators/qemu-devel/files/patch-vl.c
@@ -8,14 +8,14 @@ Index: qemu/vl.c
static CharDriverState *qemu_chr_open_pty(void)
{
struct termios tty;
-@@ -1665,6 +1665,7 @@
+@@ -1904,6 +1907,7 @@
return chr;
}
+#if defined(__linux__)
- static int pp_ioctl(CharDriverState *chr, int cmd, void *arg)
- {
- int fd = (int)chr->opaque;
+ typedef struct {
+ int fd;
+ int mode;
@@ -1727,6 +1728,7 @@
chr->chr_ioctl = pp_ioctl;
return chr;
diff --git a/emulators/qemu-devel/files/patch-vl.c-nographic b/emulators/qemu-devel/files/patch-vl.c-nographic
index be2f002c4920..eafbd45705af 100644
--- a/emulators/qemu-devel/files/patch-vl.c-nographic
+++ b/emulators/qemu-devel/files/patch-vl.c-nographic
@@ -1,8 +1,8 @@
Index: qemu/vl.c
-@@ -4668,6 +4668,7 @@
+@@ -7131,6 +7131,7 @@
case QEMU_OPTION_nographic:
- pstrcpy(monitor_device, sizeof(monitor_device), "stdio");
pstrcpy(serial_devices[0], sizeof(serial_devices[0]), "stdio");
+ pstrcpy(monitor_device, sizeof(monitor_device), "stdio");
+ pstrcpy(parallel_devices[0], sizeof(parallel_devices[0]), "null");
nographic = 1;
break;