aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormakc <makc@FreeBSD.org>2011-03-13 22:53:21 +0800
committermakc <makc@FreeBSD.org>2011-03-13 22:53:21 +0800
commitb7c433aa97c234553f7009bd1a3e271b80e8e097 (patch)
tree35aed65efb1206167da1ca63891ee6a872e46b1d
parentb640da41b950087babaa8c9752f04df13c210b32 (diff)
downloadfreebsd-ports-gnome-b7c433aa97c234553f7009bd1a3e271b80e8e097.tar.gz
freebsd-ports-gnome-b7c433aa97c234553f7009bd1a3e271b80e8e097.tar.zst
freebsd-ports-gnome-b7c433aa97c234553f7009bd1a3e271b80e8e097.zip
- fix with non-standard PREFIX/LOCALBASE
- fix error with undefined variables on some services. This is upstream ticket #2: http://sourceforge.net/apps/trac/ddclient/ticket/2 PR: ports/155486 Submitted by: Rob Farmer (maintainer)
-rw-r--r--dns/ddclient/Makefile8
-rw-r--r--dns/ddclient/files/patch-ticket221
2 files changed, 26 insertions, 3 deletions
diff --git a/dns/ddclient/Makefile b/dns/ddclient/Makefile
index fee63c436422..9e6ac186af44 100644
--- a/dns/ddclient/Makefile
+++ b/dns/ddclient/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ddclient
PORTVERSION= 3.8.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= dns
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -35,11 +35,13 @@ PORTDOCS= COPYING COPYRIGHT Changelog README README.cisco README.ssl \
post-patch:
@${GREP} -lr '/usr' ${WRKSRC} | ${XARGS} ${REINPLACE_CMD} -e 's|/usr|${PREFIX}|g'
@${REINPLACE_CMD} \
- -e 's|/etc/ddclient|${PREFIX}/etc|' \
-e 's|/tmp|/var/tmp|' \
-e 's|/var/cache/ddclient|/var/tmp|' \
-e '/PATH/s|/etc:/usr/local/lib:||' \
- -e 's|/usr.*perl|${PERL}|g' ${WRKSRC}/ddclient
+ -e 's|/usr.*perl|${PERL}|g' \
+ -e 's|/usr/local|${LOCALBASE}|g' \
+ -e 's|/etc/ddclient|${PREFIX}/etc|' \
+ ${WRKSRC}/ddclient
do-install:
@${INSTALL_DATA} ${WRKSRC}/sample-etc_ddclient.conf ${PREFIX}/etc/ddclient.conf.sample
diff --git a/dns/ddclient/files/patch-ticket2 b/dns/ddclient/files/patch-ticket2
new file mode 100644
index 000000000000..ac4d331ff93d
--- /dev/null
+++ b/dns/ddclient/files/patch-ticket2
@@ -0,0 +1,21 @@
+--- ddclient.orig 2011-03-11 00:00:19.394750047 -0800
++++ ddclient 2011-03-11 00:04:28.967751644 -0800
+@@ -2094,10 +2094,14 @@
+ } elsif (defined($sub) && &$sub($host)) {
+ $update = 1;
+
+- } elsif (($cache{$host}{'static'} ne $config{$host}{'static'}) ||
+- ($cache{$host}{'wildcard'} ne $config{$host}{'wildcard'}) ||
+- ($cache{$host}{'mx'} ne $config{$host}{'mx'}) ||
+- ($cache{$host}{'backupmx'} ne $config{$host}{'backupmx'})) {
++ } elsif ((defined($cache{$host}{'static'}) && defined($config{$host}{'static'}) &&
++ ($cache{$host}{'static'} ne $config{$host}{'static'})) ||
++ (defined($cache{$host}{'wildcard'}) && defined($config{$host}{'wildcard'}) &&
++ ($cache{$host}{'wildcard'} ne $config{$host}{'wildcard'})) ||
++ (defined($cache{$host}{'mx'}) && defined($config{$host}{'mx'}) &&
++ ($cache{$host}{'mx'} ne $config{$host}{'mx'})) ||
++ (defined($cache{$host}{'backupmx'}) && defined($config{$host}{'backupmx'}) &&
++ ($cache{$host}{'backupmx'} ne $config{$host}{'backupmx'})) ) {
+ info("updating %s because host settings have been changed.", $host);
+ $update = 1;
+