aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2006-06-12 12:58:43 +0800
committermezz <mezz@FreeBSD.org>2006-06-12 12:58:43 +0800
commitb86cc8d4c3812f7f58f2621fdb68c89ce44b1365 (patch)
treef9d882c6238664cc6cb4f6fbae4e5bdb2e1364ee
parent73e90e9463c57f1bcaa52ced2bda3fd8af02b294 (diff)
downloadfreebsd-ports-gnome-b86cc8d4c3812f7f58f2621fdb68c89ce44b1365.tar.gz
freebsd-ports-gnome-b86cc8d4c3812f7f58f2621fdb68c89ce44b1365.tar.zst
freebsd-ports-gnome-b86cc8d4c3812f7f58f2621fdb68c89ce44b1365.zip
Use the correct mtree when you change the prefix, for example:
Incorrect: (before) ================================ # cd /usr/ports/x11-toolkits/pango # make -V MTREE_FILE /etc/mtree/BSD.x11-4.dist # make PREFIX=/tmp/foo -V MTREE_FILE /etc/mtree/BSD.local.dist <-- Here... ================================ Correct: (after) ================================ # cd /usr/ports/x11-toolkits/pango # make -V MTREE_FILE /etc/mtree/BSD.x11-4.dist # make PREFIX=/tmp/foo -V MTREE_FILE /etc/mtree/BSD.x11-4.dist <-- Here... ================================
-rw-r--r--lang/librep/Makefile6
-rw-r--r--sysutils/system-tools-backends/Makefile6
-rw-r--r--textproc/gnome-doc-utils/Makefile10
-rw-r--r--textproc/scrollkeeper/Makefile10
-rw-r--r--x11-fonts/bitstream-vera/Makefile6
-rw-r--r--x11-fonts/fontconfig/Makefile6
-rw-r--r--x11-toolkits/pango/Makefile10
7 files changed, 51 insertions, 3 deletions
diff --git a/lang/librep/Makefile b/lang/librep/Makefile
index 212f722585ce..b6b982dcea0e 100644
--- a/lang/librep/Makefile
+++ b/lang/librep/Makefile
@@ -50,6 +50,12 @@ LIB_DEPENDS+= gmp.7:${PORTSDIR}/math/libgmp4
EXTRA_PATCHES+= ${FILESDIR}/stable-patch-src_numbers.c
.endif
+.if ${X_WINDOW_SYSTEM:L} == xfree86-3
+MTREE_FILE= /etc/mtree/BSD.x11.dist
+.else
+MTREE_FILE= /etc/mtree/BSD.x11-4.dist
+.endif
+
post-extract:
@${RM} ${WRKSRC}/test
diff --git a/sysutils/system-tools-backends/Makefile b/sysutils/system-tools-backends/Makefile
index e00e9f461568..c2eafe8a0ef1 100644
--- a/sysutils/system-tools-backends/Makefile
+++ b/sysutils/system-tools-backends/Makefile
@@ -32,6 +32,12 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
RUN_DEPENDS+= ${SITE_PERL}/File/Temp.pm:${PORTSDIR}/devel/p5-File-Temp
.endif
+.if ${X_WINDOW_SYSTEM:L} == xfree86-3
+MTREE_FILE= /etc/mtree/BSD.x11.dist
+.else
+MTREE_FILE= /etc/mtree/BSD.x11-4.dist
+.endif
+
.if ${PERL_LEVEL} < 500600
post-configure:
@${FIND} ${WRKSRC} \( -name "*.pl" -or -name "*-conf" \) | \
diff --git a/textproc/gnome-doc-utils/Makefile b/textproc/gnome-doc-utils/Makefile
index 9b323ad676b4..df5e4f00f5fb 100644
--- a/textproc/gnome-doc-utils/Makefile
+++ b/textproc/gnome-doc-utils/Makefile
@@ -36,7 +36,15 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= xml2po.1
+.include <bsd.port.pre.mk>
+
+.if ${X_WINDOW_SYSTEM:L} == xfree86-3
+MTREE_FILE= /etc/mtree/BSD.x11.dist
+.else
+MTREE_FILE= /etc/mtree/BSD.x11-4.dist
+.endif
+
post-install:
@${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py -l ${PREFIX}/share/xml2po
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/textproc/scrollkeeper/Makefile b/textproc/scrollkeeper/Makefile
index 67183ca6a217..83c25f91bbf9 100644
--- a/textproc/scrollkeeper/Makefile
+++ b/textproc/scrollkeeper/Makefile
@@ -53,6 +53,14 @@ MAN7= scrollkeeper.7
MAN8= scrollkeeper-preinstall.8 scrollkeeper-rebuilddb.8 \
scrollkeeper-update.8
+.include <bsd.port.pre.mk>
+
+.if ${X_WINDOW_SYSTEM:L} == xfree86-3
+MTREE_FILE= /etc/mtree/BSD.x11.dist
+.else
+MTREE_FILE= /etc/mtree/BSD.x11-4.dist
+.endif
+
post-patch:
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
's|[(]LN_S[)] -f -n|(LN_S) -f|g'
@@ -61,4 +69,4 @@ post-patch:
@${REINPLACE_CMD} -e 's|%%LOCALBASE%%|${LOCALBASE}|g' \
${WRKSRC}/extract/dtds/Makefile.in
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/x11-fonts/bitstream-vera/Makefile b/x11-fonts/bitstream-vera/Makefile
index ca2970ad61ac..ebae796a0646 100644
--- a/x11-fonts/bitstream-vera/Makefile
+++ b/x11-fonts/bitstream-vera/Makefile
@@ -39,6 +39,12 @@ FONTSDIR?= ${PREFIX}/lib/X11/fonts/${FONTNAME}
.include <bsd.port.pre.mk>
+.if ${X_WINDOW_SYSTEM:L} == xfree86-3
+MTREE_FILE= /etc/mtree/BSD.x11.dist
+.else
+MTREE_FILE= /etc/mtree/BSD.x11-4.dist
+.endif
+
.SILENT:
post-patch:
diff --git a/x11-fonts/fontconfig/Makefile b/x11-fonts/fontconfig/Makefile
index 109c3d8d197b..3223d723ce42 100644
--- a/x11-fonts/fontconfig/Makefile
+++ b/x11-fonts/fontconfig/Makefile
@@ -51,6 +51,12 @@ PATCHFILES+= cjk-fontconfig-2.3.2-20051217.patch.gz
PATCH_DIST_STRIP+= -p1
.endif
+.if ${X_WINDOW_SYSTEM:L} == xfree86-3
+MTREE_FILE= /etc/mtree/BSD.x11.dist
+.else
+MTREE_FILE= /etc/mtree/BSD.x11-4.dist
+.endif
+
post-install:
.if !defined(NOPORTDOCS)
${MKDIR} ${DOCSDIR}
diff --git a/x11-toolkits/pango/Makefile b/x11-toolkits/pango/Makefile
index 55ae37e1de98..8171b26042b6 100644
--- a/x11-toolkits/pango/Makefile
+++ b/x11-toolkits/pango/Makefile
@@ -64,6 +64,14 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/freetype2 \
PLIST_SUB+= X11=""
.endif
+.include <bsd.port.pre.mk>
+
+.if ${X_WINDOW_SYSTEM:L} == xfree86-3
+MTREE_FILE= /etc/mtree/BSD.x11.dist
+.else
+MTREE_FILE= /etc/mtree/BSD.x11-4.dist
+.endif
+
post-install:
@${SED} -e 's|%%X11BASE%%|${X11BASE}|' < ${FILESDIR}/pkg-install.in \
> ${PKGINSTALL}
@@ -71,6 +79,6 @@ post-install:
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
.endif
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
.endif