aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorskv <skv@FreeBSD.org>2009-05-12 23:56:33 +0800
committerskv <skv@FreeBSD.org>2009-05-12 23:56:33 +0800
commitbae259d743ceb22d8a8832fc32655d16372eb76c (patch)
tree71a6c313d1665a83f0eb66cafd106859b1751c16
parent02b4390b0253c26083ff2e4941dbee5e56c736f1 (diff)
downloadfreebsd-ports-gnome-bae259d743ceb22d8a8832fc32655d16372eb76c.tar.gz
freebsd-ports-gnome-bae259d743ceb22d8a8832fc32655d16372eb76c.tar.zst
freebsd-ports-gnome-bae259d743ceb22d8a8832fc32655d16372eb76c.zip
Add p5-Scope-Upper 0.08, act on upper scopes.
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Scope-Upper/Makefile21
-rw-r--r--devel/p5-Scope-Upper/distinfo3
-rw-r--r--devel/p5-Scope-Upper/pkg-descr13
-rw-r--r--devel/p5-Scope-Upper/pkg-plist7
5 files changed, 45 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index d99f68a44be9..24a1b67c5f95 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1767,6 +1767,7 @@
SUBDIR += p5-Scalar-String
SUBDIR += p5-Scalar-Util-Clone
SUBDIR += p5-Scope-Guard
+ SUBDIR += p5-Scope-Upper
SUBDIR += p5-Search-Binary
SUBDIR += p5-Set-Array
SUBDIR += p5-Set-ConsistentHash
diff --git a/devel/p5-Scope-Upper/Makefile b/devel/p5-Scope-Upper/Makefile
new file mode 100644
index 000000000000..6610fcee9df1
--- /dev/null
+++ b/devel/p5-Scope-Upper/Makefile
@@ -0,0 +1,21 @@
+# New ports collection makefile for: Scope-Upper
+# Date created: 12 ΝΑΡ 2009
+# Whom: Sergey Skvortsov <skv@protey.ru>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Scope-Upper
+PORTVERSION= 0.08
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= skv@FreeBSD.org
+COMMENT= Act on upper scopes
+
+PERL_CONFIGURE= yes
+
+MAN3= Scope::Upper.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Scope-Upper/distinfo b/devel/p5-Scope-Upper/distinfo
new file mode 100644
index 000000000000..bc5d4f81248c
--- /dev/null
+++ b/devel/p5-Scope-Upper/distinfo
@@ -0,0 +1,3 @@
+MD5 (Scope-Upper-0.08.tar.gz) = f5515279b7c7cedc60565e50a4ffd990
+SHA256 (Scope-Upper-0.08.tar.gz) = 43bf3c6ce6c07a97a2a5cd112594db07b93214d2064c8478cc1723b3faccfe1b
+SIZE (Scope-Upper-0.08.tar.gz) = 25896
diff --git a/devel/p5-Scope-Upper/pkg-descr b/devel/p5-Scope-Upper/pkg-descr
new file mode 100644
index 000000000000..38c9ec720ade
--- /dev/null
+++ b/devel/p5-Scope-Upper/pkg-descr
@@ -0,0 +1,13 @@
+This module lets you defer actions at run-time that will take place when
+the control flow returns into an upper scope. Currently, you can:
+
+* hook an upper scope end with "reap" ;
+
+* localize variables, array/hash values or deletions of elements in
+higher contexts with respectively "localize", "localize_elem" and
+"localize_delete" ;
+
+* return values immediately to an upper level with "unwind", and know
+which context was in use then with "want_at".
+
+WWW: http://search.cpan.org/dist/Scope-Upper/
diff --git a/devel/p5-Scope-Upper/pkg-plist b/devel/p5-Scope-Upper/pkg-plist
new file mode 100644
index 000000000000..becaff309198
--- /dev/null
+++ b/devel/p5-Scope-Upper/pkg-plist
@@ -0,0 +1,7 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/Scope/Upper.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Scope/Upper/.packlist
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Scope/Upper/Upper.bs
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Scope/Upper/Upper.so
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Scope/Upper
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/Scope
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Scope