aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoralex <alex@FreeBSD.org>2001-05-09 17:37:08 +0800
committeralex <alex@FreeBSD.org>2001-05-09 17:37:08 +0800
commitbb5791434df4658be6b9d9ec2898e3c63d6186b6 (patch)
tree4e9e0dcfc9009952b0109e970da813fb8393e642
parenta5cd74462f5977b6d8b353b5d6bf9c7c504a0432 (diff)
downloadfreebsd-ports-gnome-bb5791434df4658be6b9d9ec2898e3c63d6186b6.tar.gz
freebsd-ports-gnome-bb5791434df4658be6b9d9ec2898e3c63d6186b6.tar.zst
freebsd-ports-gnome-bb5791434df4658be6b9d9ec2898e3c63d6186b6.zip
Use perl regex to set PTHREAD_CFLAGS in all Makefile.in's.
Use perl regex to acutally install GNOME helppages in proper locations. Remove files/patch-po::Makefile.in and replace with perl regex. Bump PORTREVISION due to these changes. PR: 26449 Submitted by: Jeremy Norris <ishmael27@home.com> (maintainer)
-rw-r--r--net/gtk+licq/Makefile12
-rw-r--r--net/gtk+licq/files/patch-po::Makefile.in11
2 files changed, 10 insertions, 13 deletions
diff --git a/net/gtk+licq/Makefile b/net/gtk+licq/Makefile
index 9cc7349b13c3..84ba3de7a125 100644
--- a/net/gtk+licq/Makefile
+++ b/net/gtk+licq/Makefile
@@ -7,7 +7,7 @@
PORTNAME= gtk+licq
PORTVERSION= 0.50.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net
MASTER_SITES= http://gtk.licq.org/download/
@@ -31,9 +31,17 @@ USE_GNOME= yes
CONFIGURE_ARGS= --enable-gnome
.else
CONFIGURE_ARGS= --disable-gnome
+.endif
+
post-patch:
+ @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL5} -pi -e \
+ 's|-D_REENTRANT|${PTHREAD_CFLAGS} -D_REENTRANT|g ; \
+ s|^localedir =.*|localedir = \$$(prefix)/share/locale| ; \
+ s|^gtklicq_helpdir =.*|gtklicq_helpdir = \
+ \$$(datadir)/help/gtk+licq/C|'
+.if !defined(HAVE_GNOME)
@${PERL5} -pi -e \
- 's|^SUBDIRS\ =.*|SUBDIRS\ =\ |' ${WRKSRC}/doc/Makefile.in
+ 's|^SUBDIRS =.*|SUBDIRS =|' ${WRKSRC}/doc/Makefile.in
.endif
post-configure:
diff --git a/net/gtk+licq/files/patch-po::Makefile.in b/net/gtk+licq/files/patch-po::Makefile.in
deleted file mode 100644
index d85f625d56ed..000000000000
--- a/net/gtk+licq/files/patch-po::Makefile.in
+++ /dev/null
@@ -1,11 +0,0 @@
---- po/Makefile.in.in.orig Wed Aug 23 20:00:23 2000
-+++ po/Makefile.in.in Sun Oct 15 11:11:11 2000
-@@ -19,7 +19,7 @@
- prefix = @prefix@
- exec_prefix = @exec_prefix@
- datadir = $(prefix)/@DATADIRNAME@
--localedir = $(datadir)/locale
-+localedir = $(prefix)/share/locale
- gnulocaledir = $(prefix)/share/locale
- gettextsrcdir = $(prefix)/share/gettext/po
- subdir = po