aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorshaun <shaun@FreeBSD.org>2006-11-23 00:48:45 +0800
committershaun <shaun@FreeBSD.org>2006-11-23 00:48:45 +0800
commitbb76a93cd168841c3d272a449be77cd1cd2543b5 (patch)
tree57479453394148c55dfd4a02d4b02fdc906fc396
parent317790d3afd8b5ac6eefeb066218911da7c4d3e4 (diff)
downloadfreebsd-ports-gnome-bb76a93cd168841c3d272a449be77cd1cd2543b5.tar.gz
freebsd-ports-gnome-bb76a93cd168841c3d272a449be77cd1cd2543b5.tar.zst
freebsd-ports-gnome-bb76a93cd168841c3d272a449be77cd1cd2543b5.zip
Fix build on sparc64.
-rw-r--r--devel/swig11/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/devel/swig11/Makefile b/devel/swig11/Makefile
index fe841fa87249..6a0dcf4bf42c 100644
--- a/devel/swig11/Makefile
+++ b/devel/swig11/Makefile
@@ -29,7 +29,7 @@ USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME:U}${PORTVERSION}
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CFLAGS="${CFLAGS} -fpic -DPIC" PYTHON_VERSION=${PYTHON_VERSION}
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -DPIC" PYTHON_VERSION=${PYTHON_VERSION}
CONFIGURE_ARGS= --with-tclincl=${LOCALBASE}/include/tcl8.4/ \
--with-tcllib=${LOCALBASE}/lib/tcl8.4/ \
--with-pyincl=${PYTHONPREFIX_INCLUDEDIR} \
@@ -43,8 +43,8 @@ NO_LATEST_LINK= yes
.include <bsd.port.pre.mk>
-.if ${ARCH} == "sparc64"
-BROKEN= "Does not compile on sparc64 (needs -fPIC)"
+.if ${ARCH} != "sparc64"
+CFLAGS+= -fpic
.endif
post-install: