aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2011-10-04 05:53:07 +0800
committerpawel <pawel@FreeBSD.org>2011-10-04 05:53:07 +0800
commitbcf5dd743c47764f4411e5d8783be13bc66fccce (patch)
treec0b6c344cce75bf9a527431c8c258beb925ba0ef
parentd23e9443604b3a1d279afbf849e3426c5822bef3 (diff)
downloadfreebsd-ports-gnome-bcf5dd743c47764f4411e5d8783be13bc66fccce.tar.gz
freebsd-ports-gnome-bcf5dd743c47764f4411e5d8783be13bc66fccce.tar.zst
freebsd-ports-gnome-bcf5dd743c47764f4411e5d8783be13bc66fccce.zip
- Add patch to recognize FreeBSD ATA CAM devices - ada(4) [1]
- Fix launching from desktop entry - now sudoing actually works PR: ports/161264 [1] Submitted by: olgeni@ [1] Approved by: miwi, wen (mentors implicit)
-rw-r--r--sysutils/gsmartcontrol/Makefile4
-rw-r--r--sysutils/gsmartcontrol/files/patch-data_gsmartcontrol-root.in17
-rw-r--r--sysutils/gsmartcontrol/files/patch-src_applib_storage__detector__other.cpp13
3 files changed, 29 insertions, 5 deletions
diff --git a/sysutils/gsmartcontrol/Makefile b/sysutils/gsmartcontrol/Makefile
index e5808d50f342..0072c35cb8d7 100644
--- a/sysutils/gsmartcontrol/Makefile
+++ b/sysutils/gsmartcontrol/Makefile
@@ -7,6 +7,7 @@
PORTNAME= gsmartcontrol
PORTVERSION= 0.8.6
+PORTREVISION= 1
CATEGORIES= sysutils
MASTER_SITES= ${MASTER_SITE_BERLIOS}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,7 +17,8 @@ COMMENT= Graphical user interface for smartmontools
LIB_DEPENDS= gtkmm-2.4:${PORTSDIR}/x11-toolkits/gtkmm24 \
pcre:${PORTSDIR}/devel/pcre
-RUN_DEPENDS= ${LOCALBASE}/sbin/smartctl:${PORTSDIR}/sysutils/smartmontools
+RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
+ smartctl:${PORTSDIR}/sysutils/smartmontools
USE_AUTOTOOLS= libtool
USE_BZIP2= yes
diff --git a/sysutils/gsmartcontrol/files/patch-data_gsmartcontrol-root.in b/sysutils/gsmartcontrol/files/patch-data_gsmartcontrol-root.in
index dc30ce42614a..764d4a4cc949 100644
--- a/sysutils/gsmartcontrol/files/patch-data_gsmartcontrol-root.in
+++ b/sysutils/gsmartcontrol/files/patch-data_gsmartcontrol-root.in
@@ -1,8 +1,17 @@
---- ./data/gsmartcontrol-root.in.orig 2009-03-26 18:58:31.000000000 +0100
-+++ data/gsmartcontrol-root.in 2009-03-26 18:58:44.000000000 +0100
+--- data/gsmartcontrol-root.in.orig 2011-04-30 20:39:54.000000000 +0200
++++ data/gsmartcontrol-root.in 2011-10-03 23:31:02.000000000 +0200
@@ -1,4 +1,4 @@
-#!/bin/bash
-+#!/bin/sh
++#!/usr/bin/env bash
############################################################################
# Copyright:
- # (C) 2008 Alexander Shaduri <ashaduri 'at' gmail.com>
+ # (C) 2008 - 2010 Alexander Shaduri <ashaduri 'at' gmail.com>
+@@ -88,7 +88,7 @@
+ # the user's env after all).
+ # Note that beesu won't show a GUI login box if /usr/sbin is before /usr/bin,
+ # so add it first as well.
+-EXTRA_PATHS="/usr/bin:/usr/sbin:/usr/local/sbin";
++EXTRA_PATHS="/usr/bin:/usr/sbin:@prefix@/sbin";
+ export PATH="$EXTRA_PATHS:$PATH"
+
+
diff --git a/sysutils/gsmartcontrol/files/patch-src_applib_storage__detector__other.cpp b/sysutils/gsmartcontrol/files/patch-src_applib_storage__detector__other.cpp
new file mode 100644
index 000000000000..ed373255886d
--- /dev/null
+++ b/sysutils/gsmartcontrol/files/patch-src_applib_storage__detector__other.cpp
@@ -0,0 +1,13 @@
+
+$FreeBSD$
+
+--- src/applib/storage_detector_other.cpp.orig
++++ src/applib/storage_detector_other.cpp
+@@ -75,6 +75,7 @@
+
+ whitelist.push_back("/^ad[0-9]+$/"); // adN without suffix - fbsd ide
+ whitelist.push_back("/^da[0-9]+$/"); // daN without suffix - fbsd scsi, usb
++ whitelist.push_back("/^ada[0-9]+$/"); // adaN without suffix - fbsd ata cam
+ // whitelist.push_back("/ ^sa[0-9]+$/"); // saN without suffix - fbsd scsi tape
+ // whitelist.push_back("/^ast[0-9]+$/"); // astN without suffix - fbsd ide tape
+ whitelist.push_back("/^aacd[0-9]+$/"); // fbsd adaptec raid