aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2016-01-19 06:01:53 +0800
committerpawel <pawel@FreeBSD.org>2016-01-19 06:01:53 +0800
commitbdc0b5b3e1b524a1fb1ead65be4bbff5ad822484 (patch)
tree228c65cc85ae782f79ff0755c81eb2af0144847e
parentcfc8dceb1f7dd9ea62de38560c26303ce07513c3 (diff)
downloadfreebsd-ports-gnome-bdc0b5b3e1b524a1fb1ead65be4bbff5ad822484.tar.gz
freebsd-ports-gnome-bdc0b5b3e1b524a1fb1ead65be4bbff5ad822484.tar.zst
freebsd-ports-gnome-bdc0b5b3e1b524a1fb1ead65be4bbff5ad822484.zip
Remove old plist generation script using deprecated @dirrm
PR: 206382 Submitted by: myself Approved by: maintainer
-rw-r--r--www/yabb/files/build_plist.sh54
1 files changed, 0 insertions, 54 deletions
diff --git a/www/yabb/files/build_plist.sh b/www/yabb/files/build_plist.sh
deleted file mode 100644
index 14755feb38ab..000000000000
--- a/www/yabb/files/build_plist.sh
+++ /dev/null
@@ -1,54 +0,0 @@
-# Yabb port maintener script
-# This script was designed to be executed by the port maintainer to generate
-# the yabb port pkg_plist and checksum.sha256 files when updating the port
-#######
-
-rm files/ checksum.sha256
-rm pkg-plist
-
-YABB_DIR="/usr/local/www/yabb/"
-
-for file in `cd ${YABB_DIR} ; find Members Messages Templates Variables -type f | egrep -v "(gif|png)" ; echo Paths.pl `
-do
- echo -n "@unexec i='" >> pkg-plist
- echo -n $file >> pkg-plist
- echo -n "'" >> pkg-plist
- echo -n '; cd %D/%%YABBDIR%% && if [ k`sha256 -q $i` = k`grep ' >> pkg-plist
- echo '"$i\$" checksum.sha256 | cut -c-64` ]; then rm -f $i; fi' >> pkg-plist
-
- (cd ${YABB_DIR} ; sha256 -r $file ) >> files/checksum.sha256
-done
-
-for file in `cd ${YABB_DIR} ; find Admin Attachments Backups Boards Buttons Help Languages ModImages Smilies Sources avatars googiespell greybox shjs -type f`
-do
- echo "%%YABBDIR%%/${file}" >> pkg-plist
-done
-
-for file in `cd ${YABB_DIR} ; find Members Messages Templates Variables -type f | egrep "(gif|png)" `
-do
- echo "%%YABBDIR%%/${file}" >> pkg-plist
-done
-
-for file in `cd ${YABB_DIR} ; find . -depth 1 -type f | grep -v Paths.pl | sed 's/^\.\///'`
-do
- echo "%%YABBDIR%%/${file}" >> pkg-plist
-done
-
-for file in `cd ${YABB_DIR} ; find . -type d | sed 's/^\.//' | sort -r`
-do
- echo "@dirrmtry %%YABBDIR%%${file}" >> pkg-plist
-done
-
-
-
-echo "@dirrmtry %%YABBDIR%%" >> pkg-plist
-
-
-echo '@unexec if [ -d %D/%%YABBDIR%% ]; then echo "================================================"; fi' >> pkg-plist
-echo '@unexec if [ -d %D/%%YABBDIR%% ]; then echo "Note: %D/%%YABBDIR%% was not deleted." ; fi' >> pkg-plist
-echo '@unexec if [ -d %D/%%YABBDIR%% ]; then echo "Backup your data and remove it yourself, please."; fi' >> pkg-plist
-echo '@unexec if [ -d %D/%%YABBDIR%% ]; then echo "================================================"; fi' >> pkg-plist
-
-
-
-