aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordinoex <dinoex@FreeBSD.org>2013-03-04 00:09:56 +0800
committerdinoex <dinoex@FreeBSD.org>2013-03-04 00:09:56 +0800
commitbe022c4a2d6686748ca81963777b5856832d0ef1 (patch)
treea870ff24247cbd421612c4210c892a66650d6e6b
parent78cbb40ef35dc9c861e5d75f8fd918693024b943 (diff)
downloadfreebsd-ports-gnome-be022c4a2d6686748ca81963777b5856832d0ef1.tar.gz
freebsd-ports-gnome-be022c4a2d6686748ca81963777b5856832d0ef1.tar.zst
freebsd-ports-gnome-be022c4a2d6686748ca81963777b5856832d0ef1.zip
Ruby-bdb1 is an interface to Berkeley DB revision 1.85 and 1.86.
This library includes support for the following access methods: * B+tree * Hashing * Fixed and Variable-Length Records And the following interfaces: * Hash like interface - BDB1::Btree and BDB1::Hash * Array like interface - BDB1::Recnum(Recno) WWW: https://github.com/knu/ruby-bdb1
-rw-r--r--databases/Makefile1
-rw-r--r--databases/rubygem-bdb1/Makefile17
-rw-r--r--databases/rubygem-bdb1/distinfo2
-rw-r--r--databases/rubygem-bdb1/pkg-descr14
4 files changed, 34 insertions, 0 deletions
diff --git a/databases/Makefile b/databases/Makefile
index a482b2968d35..556ebb88ef1d 100644
--- a/databases/Makefile
+++ b/databases/Makefile
@@ -812,6 +812,7 @@
SUBDIR += rubygem-activerecord-jdbcmysql-adapter
SUBDIR += rubygem-amalgalite
SUBDIR += rubygem-arel
+ SUBDIR += rubygem-bdb1
SUBDIR += rubygem-bigrecord
SUBDIR += rubygem-couchrest
SUBDIR += rubygem-data_objects
diff --git a/databases/rubygem-bdb1/Makefile b/databases/rubygem-bdb1/Makefile
new file mode 100644
index 000000000000..42fe9cc1e1c7
--- /dev/null
+++ b/databases/rubygem-bdb1/Makefile
@@ -0,0 +1,17 @@
+# $FreeBSD$
+
+PORTNAME= bdb1
+PORTVERSION= 0.2.5
+CATEGORIES= databases rubygems
+MASTER_SITES= RG
+
+MAINTAINER= ruby@FreeBSD.org
+COMMENT= Ruby interface to Berkeley DB revision 1.8x with full feature support
+
+LIB_DEPENDS= execinfo:${PORTSDIR}/devel/libexecinfo
+
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+RUBYGEM_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/databases/rubygem-bdb1/distinfo b/databases/rubygem-bdb1/distinfo
new file mode 100644
index 000000000000..78efe393643f
--- /dev/null
+++ b/databases/rubygem-bdb1/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rubygem/bdb1-0.2.5.gem) = b65c11ef56dadd45c458c0ff344fe34384ffad91a072168cd9ab460e10738de9
+SIZE (rubygem/bdb1-0.2.5.gem) = 67072
diff --git a/databases/rubygem-bdb1/pkg-descr b/databases/rubygem-bdb1/pkg-descr
new file mode 100644
index 000000000000..4be92c87d27a
--- /dev/null
+++ b/databases/rubygem-bdb1/pkg-descr
@@ -0,0 +1,14 @@
+Ruby-bdb1 is an interface to Berkeley DB revision 1.85 and 1.86.
+
+This library includes support for the following access methods:
+
+* B+tree
+* Hashing
+* Fixed and Variable-Length Records
+
+And the following interfaces:
+
+* Hash like interface - BDB1::Btree and BDB1::Hash
+* Array like interface - BDB1::Recnum(Recno)
+
+WWW: https://github.com/knu/ruby-bdb1