aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwill <will@FreeBSD.org>2003-06-03 12:25:13 +0800
committerwill <will@FreeBSD.org>2003-06-03 12:25:13 +0800
commitbe6e3a2022d907ffe16b464bc05ac2d48da8f5d0 (patch)
tree75bbe0e79b5c00f8ae900ae235c8184aea41d0b3
parentdf3614a0b7440e171e9ece20ef88fd645132c1e7 (diff)
downloadfreebsd-ports-gnome-be6e3a2022d907ffe16b464bc05ac2d48da8f5d0.tar.gz
freebsd-ports-gnome-be6e3a2022d907ffe16b464bc05ac2d48da8f5d0.tar.zst
freebsd-ports-gnome-be6e3a2022d907ffe16b464bc05ac2d48da8f5d0.zip
Add http_get 1.0, a program to dump http-contents to stdout.
PR: 52265 Submitted by: Aaron Zauner <az_mail@gmx.at>
-rw-r--r--www/Makefile1
-rw-r--r--www/http_get/Makefile22
-rw-r--r--www/http_get/distinfo1
-rw-r--r--www/http_get/pkg-descr8
-rw-r--r--www/http_get/pkg-plist1
5 files changed, 33 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index f437d513f536..45acbc42d1bb 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -118,6 +118,7 @@
SUBDIR += htmlobject
SUBDIR += htmlpp
SUBDIR += http-analyze
+ SUBDIR += http_get
SUBDIR += http_load
SUBDIR += httperf
SUBDIR += httpgrabber
diff --git a/www/http_get/Makefile b/www/http_get/Makefile
new file mode 100644
index 000000000000..25c3ca1074be
--- /dev/null
+++ b/www/http_get/Makefile
@@ -0,0 +1,22 @@
+# New ports collection makefile for: http_get
+# Date created: 15. May 2003
+# Whom: Aaron Zauner <az_mail@gmx.at>
+#
+# $FreeBSD$
+#
+
+PORTNAME= http_get
+PORTVERSION= 1.0
+CATEGORIES= www
+MASTER_SITES= http://www.acme.com/software/http_get/
+DISTNAME= ${PORTNAME}_18mar2002
+
+MAINTAINER= az_mail@gmx.at
+COMMENT= Dump http-contents to stdout
+
+WRKSRC= ${WRKDIR}/http_get
+
+MAN1= http_get.1
+MANCOMPRESSED= no
+
+.include <bsd.port.mk>
diff --git a/www/http_get/distinfo b/www/http_get/distinfo
new file mode 100644
index 000000000000..28efdee5eaf8
--- /dev/null
+++ b/www/http_get/distinfo
@@ -0,0 +1 @@
+MD5 (http_get_18mar2002.tar.gz) = 0b6f96a57db511bee3d959d4132fe3aa
diff --git a/www/http_get/pkg-descr b/www/http_get/pkg-descr
new file mode 100644
index 000000000000..b4fea9846d37
--- /dev/null
+++ b/www/http_get/pkg-descr
@@ -0,0 +1,8 @@
+Get the contents of an http url and dumps
+it to stdout. supports ipv6 and https (SSL).
+A useful tool. :)
+
+WWW: http://www.acme.com/softwarehttp_get/
+
+- Aaron Zauner
+az_mail@gmx.at
diff --git a/www/http_get/pkg-plist b/www/http_get/pkg-plist
new file mode 100644
index 000000000000..bef821527971
--- /dev/null
+++ b/www/http_get/pkg-plist
@@ -0,0 +1 @@
+bin/http_get