aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorobraun <obraun@FreeBSD.org>2003-06-18 03:59:06 +0800
committerobraun <obraun@FreeBSD.org>2003-06-18 03:59:06 +0800
commitbe88447c08bd9cb31b0226331d21239097b3bf66 (patch)
treebd8704f044bc58ac1519bc5cd5ca80faa4edbb76
parentc79850a0c714ac2437ab87d49a84d99576567da2 (diff)
downloadfreebsd-ports-gnome-be88447c08bd9cb31b0226331d21239097b3bf66.tar.gz
freebsd-ports-gnome-be88447c08bd9cb31b0226331d21239097b3bf66.tar.zst
freebsd-ports-gnome-be88447c08bd9cb31b0226331d21239097b3bf66.zip
* Fix QT dependency.
* s/files/${FILESDIR}/ * Set maintainer to submitter. Submitted by: Volker Stolz <stolz@i2.informatik.rwth-aachen.de>
-rw-r--r--graphics/hpoj/Makefile24
1 files changed, 12 insertions, 12 deletions
diff --git a/graphics/hpoj/Makefile b/graphics/hpoj/Makefile
index 9bda24e8ae40..4368b2921a28 100644
--- a/graphics/hpoj/Makefile
+++ b/graphics/hpoj/Makefile
@@ -13,7 +13,7 @@ MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= hpoj
EXTRACT_SUFX= .tgz
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= stolz@i2.informatik.rwth-aachen.de
COMMENT= "HP OfficeJet Linux driver; printing, scanning, and photo-card access"
LIB_DEPENDS= sane.1:${PORTSDIR}/graphics/sane-backends \
@@ -26,6 +26,14 @@ USE_REINPLACE= yes
USE_GMAKE= yes
USE_PERL5= yes
+.ifndef(WITHOUT_X11)
+USE_QT_VER= 3
+USE_XLIB= yes
+PLIST_SUB+= X11=""
+.else
+PLIST_SUB+= X11="@comment "
+.endif
+
.include <bsd.port.pre.mk>
.if ${ARCH} == "i386" && ${OSVERSION} > 500000
@@ -33,17 +41,9 @@ BROKEN= "ffs() clash, see i386/41930"
.endif
.if ${ARCH} == "alpha"
-EXTRA_PATCHES= files/extra-patch-mlcd-Makefile.in \
- files/extra-patch-mlcd-ParPort.cpp \
- files/extra-patch-mlcd-ParPort.h
-.endif
-
-.ifndef(WITHOUT_X11)
-USE_QT_VER= 3
-USE_XLIB= yes
-PLIST_SUB+= X11=""
-.else
-PLIST_SUB+= X11="@comment "
+EXTRA_PATCHES= ${FILESDIR}/extra-patch-mlcd-Makefile.in \
+ ${FILESDIR}/extra-patch-mlcd-ParPort.cpp \
+ ${FILESDIR}/extra-patch-mlcd-ParPort.h
.endif
GNU_CONFIGURE= yes