aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2008-03-25 03:04:54 +0800
committerstas <stas@FreeBSD.org>2008-03-25 03:04:54 +0800
commitbef3d3318be4564b66df26ff8431590f409dcad5 (patch)
tree657c19c2f11219eb939755f167328cfb45d7651e
parentfd2d4d71736b18e86720064f5c6ac37035a8a43c (diff)
downloadfreebsd-ports-gnome-bef3d3318be4564b66df26ff8431590f409dcad5.tar.gz
freebsd-ports-gnome-bef3d3318be4564b66df26ff8431590f409dcad5.tar.zst
freebsd-ports-gnome-bef3d3318be4564b66df26ff8431590f409dcad5.zip
- Add ruby-sexp, a ruby library for working with s-expressions.
WWW: http://sexp.rubyforge.org/
-rw-r--r--devel/Makefile1
-rw-r--r--devel/ruby-sexp/Makefile37
-rw-r--r--devel/ruby-sexp/distinfo3
-rw-r--r--devel/ruby-sexp/pkg-descr6
-rw-r--r--devel/ruby-sexp/pkg-plist3
5 files changed, 50 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 505fe6cd2257..34cea783e0a6 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -2213,6 +2213,7 @@
SUBDIR += ruby-rudl
SUBDIR += ruby-sdl
SUBDIR += ruby-setup.rb
+ SUBDIR += ruby-sexp
SUBDIR += ruby-slang
SUBDIR += ruby-strongtyping
SUBDIR += ruby-sysvipc
diff --git a/devel/ruby-sexp/Makefile b/devel/ruby-sexp/Makefile
new file mode 100644
index 000000000000..1697b0ee9d5b
--- /dev/null
+++ b/devel/ruby-sexp/Makefile
@@ -0,0 +1,37 @@
+# New ports collection makefile for: ruby-sexp
+# Date created: 24 Marth 2008
+# Whom: Stanislav Sedov <stas@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= sexp
+PORTVERSION= 0.1
+CATEGORIES= devel ruby
+MASTER_SITES= ${MASTER_SITE_RUBYFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ${RUBY_PKGNAMEPREFIX}
+DIST_SUBDIR= ruby
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= A ruby library to work with s-expressions
+
+RUN_DEPENDS= ${SADIR}/multi.rb:${PORTSDIR}/devel/ruby-multi
+
+USE_RUBY= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+NO_BUILD= yes
+
+SADIR= ${RUBY_SITELIBDIR}
+
+EXAMPLES= sexp_example.rb
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/sexp.rb ${RUBY_SITELIBDIR}/
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${RUBY_MODEXAMPLESDIR}
+ ${INSTALL_DATA} ${EXAMPLES:S,^,${WRKSRC}/,} ${RUBY_MODEXAMPLESDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/ruby-sexp/distinfo b/devel/ruby-sexp/distinfo
new file mode 100644
index 000000000000..ab445d8562a5
--- /dev/null
+++ b/devel/ruby-sexp/distinfo
@@ -0,0 +1,3 @@
+MD5 (ruby/sexp-0.1.tar.gz) = 45879d47e4964e773dfce2835a555529
+SHA256 (ruby/sexp-0.1.tar.gz) = fa3e600fe9056fd5263c7c91e32630b5634fa2db36af706bcb024354e9bf348f
+SIZE (ruby/sexp-0.1.tar.gz) = 1246
diff --git a/devel/ruby-sexp/pkg-descr b/devel/ruby-sexp/pkg-descr
new file mode 100644
index 000000000000..cabb12e235ad
--- /dev/null
+++ b/devel/ruby-sexp/pkg-descr
@@ -0,0 +1,6 @@
+S-Expression is a pure Ruby library to parse strings
+of Lisp style s-expressions into native Ruby style
+s-expressions and back again.
+
+Author: Topher Cyll <christophercyll@gmail.com>
+WWW: http://sexp.rubyforge.org/
diff --git a/devel/ruby-sexp/pkg-plist b/devel/ruby-sexp/pkg-plist
new file mode 100644
index 000000000000..363003b61a30
--- /dev/null
+++ b/devel/ruby-sexp/pkg-plist
@@ -0,0 +1,3 @@
+%%RUBY_SITELIBDIR%%/sexp.rb
+%%PORTDOCS%%%%RUBY_MODEXAMPLESDIR%%/sexp_example.rb
+%%PORTDOCS%%@dirrm %%RUBY_MODEXAMPLESDIR%%