aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2004-08-13 21:32:52 +0800
committerpav <pav@FreeBSD.org>2004-08-13 21:32:52 +0800
commitc0236775d5d9db39f9e38898b80ac938ce07cd00 (patch)
treebe7749f0d6cc1f8f88ebfad9ffafc8e493b9fde6
parentb597980f595d0fb9dcf3946794222ac1bc8399b4 (diff)
downloadfreebsd-ports-gnome-c0236775d5d9db39f9e38898b80ac938ce07cd00.tar.gz
freebsd-ports-gnome-c0236775d5d9db39f9e38898b80ac938ce07cd00.tar.zst
freebsd-ports-gnome-c0236775d5d9db39f9e38898b80ac938ce07cd00.zip
Add glflow, a DoS detection tool written with speed in mind.
It detects attacks on high speed links through real-time NetFlow aggregation and analysis. PR: ports/69011 Submitted by: David Thiel <lx@redundancy.redundancy.org>
-rw-r--r--net/Makefile1
-rw-r--r--net/glflow/Makefile28
-rw-r--r--net/glflow/distinfo2
-rw-r--r--net/glflow/files/patch-Makefile10
-rw-r--r--net/glflow/pkg-descr5
5 files changed, 46 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index dd81b5e35d1c..01a4a74a930a 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -158,6 +158,7 @@
SUBDIR += gkrellmqst
SUBDIR += gkrellmwireless
SUBDIR += gkrellmwireless2
+ SUBDIR += glflow
SUBDIR += gmdns
SUBDIR += gnet
SUBDIR += gnet-glib2
diff --git a/net/glflow/Makefile b/net/glflow/Makefile
new file mode 100644
index 000000000000..786b65c8779b
--- /dev/null
+++ b/net/glflow/Makefile
@@ -0,0 +1,28 @@
+# Ports collection makefile for: glflow
+# Date created: 2004-07-12
+# Whom: David Thiel (lx@redundancy.redundancy.org)
+#
+# $FreeBSD$
+#
+
+PORTNAME= glflow
+PORTVERSION= 0.0.4
+CATEGORIES= net security
+MASTER_SITES= http://night.rdslink.ro/dudu/glflow/
+DISTNAME= glFlow-${PORTVERSION}
+
+MAINTAINER= lx@redundancy.redundancy.org
+COMMENT= A NetFlow tool for detecting DoS attacks
+
+PLIST_FILES= bin/glflow
+PORTDOCS= README
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/glflow ${PREFIX}/bin
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/net/glflow/distinfo b/net/glflow/distinfo
new file mode 100644
index 000000000000..2fc1a8d330f0
--- /dev/null
+++ b/net/glflow/distinfo
@@ -0,0 +1,2 @@
+MD5 (glFlow-0.0.4.tar.gz) = 03f438f432d325440b17cb2dae94060c
+SIZE (glFlow-0.0.4.tar.gz) = 16874
diff --git a/net/glflow/files/patch-Makefile b/net/glflow/files/patch-Makefile
new file mode 100644
index 000000000000..5e6b4400081f
--- /dev/null
+++ b/net/glflow/files/patch-Makefile
@@ -0,0 +1,10 @@
+--- Makefile.orig Fri Aug 13 11:24:56 2004
++++ Makefile Fri Aug 13 14:57:56 2004
+@@ -1,5 +1,5 @@
+-CXX=c++
+-CXXFLAGS=-O3 -pipe -include defs.h -D_USE_MD5
++CXX?=c++
++CXXFLAGS+=-include defs.h -D_USE_MD5
+ #add -D_LINUX for compilation on Linux
+ LDFLAGS=-lpcap -lcrypto
+
diff --git a/net/glflow/pkg-descr b/net/glflow/pkg-descr
new file mode 100644
index 000000000000..9feecde18a83
--- /dev/null
+++ b/net/glflow/pkg-descr
@@ -0,0 +1,5 @@
+glFlow is a DoS detection tool written with speed in mind. It detects
+attacks on high speed links through real-time NetFlow aggregation and
+analysis.
+
+WWW: http://freshmeat.net/projects/glflow/