aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2011-10-06 07:47:21 +0800
committerstas <stas@FreeBSD.org>2011-10-06 07:47:21 +0800
commitc25970e886dc3c2e0f61143b41fb7ec7acf39e29 (patch)
tree4a2778a596a171ccf39e458875ab71b52cea9f97
parent6a9b839d156e60661d87e996752a74ccb2e8e3f0 (diff)
downloadfreebsd-ports-gnome-c25970e886dc3c2e0f61143b41fb7ec7acf39e29.tar.gz
freebsd-ports-gnome-c25970e886dc3c2e0f61143b41fb7ec7acf39e29.tar.zst
freebsd-ports-gnome-c25970e886dc3c2e0f61143b41fb7ec7acf39e29.zip
- Add port for devel/libtool-fixed, a fixed version of libtool package
that can generate proper configure scripts on 10.X and with support for 10.x WWW: http://www.gnu.org/software/libtool/
-rw-r--r--devel/Makefile1
-rw-r--r--devel/libtool-fixed/Makefile42
-rw-r--r--devel/libtool-fixed/distinfo2
-rw-r--r--devel/libtool-fixed/files/patch-libltdl-Makefile.in23
-rw-r--r--devel/libtool-fixed/files/patch-libltdl_config_ltmain.sh83
-rw-r--r--devel/libtool-fixed/pkg-descr11
-rw-r--r--devel/libtool-fixed/pkg-plist56
7 files changed, 218 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 259aa536d2bb..127cdb042d87 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -919,6 +919,7 @@
SUBDIR += libtifiles
SUBDIR += libtifiles2
SUBDIR += libtool
+ SUBDIR += libtool-fixed
SUBDIR += libtpl
SUBDIR += libublio
SUBDIR += libukcprog
diff --git a/devel/libtool-fixed/Makefile b/devel/libtool-fixed/Makefile
new file mode 100644
index 000000000000..82dac9138866
--- /dev/null
+++ b/devel/libtool-fixed/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: libtool
+# Date created: 6 May 1998
+# Whom: Motoyuki Kasahara <m-kasahr@sra.co.jp>
+#
+# $FreeBSD$
+#
+
+PORTNAME= libtool
+PORTVERSION= 2.4
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_GNU}
+MASTER_SITE_SUBDIR= libtool
+PKGNAMESUFFIX= -fixed
+
+MAINTAINER= stas@FreeBSD.org
+COMMENT= Generic shared library support script -- the fixed version
+
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+CONFLICTS= libtool-[0-9]*
+
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-ltdl-install
+CONFIGURE_ENV= MAKEINFO="makeinfo --no-split"
+INFO= libtool
+.if ${PORTNAME} != "libltdl"
+MAN1= libtool.1 libtoolize.1
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|sed gsed|sed|g' \
+ -e 's|CC=cc|CC=${CC}|g' \
+ ${WRKSRC}/configure ${WRKSRC}/libltdl/configure
+ @${REINPLACE_CMD} -e 's|freebsd1\*)|freebsd1.\*)|g' \
+ ${WRKSRC}/configure ${WRKSRC}/libltdl/configure \
+ ${WRKSRC}/libltdl/m4/libtool.m4
+
+post-configure:
+ @${FIND} ${WRKSRC} -type f | ${XARGS} ${TOUCH} -f
+
+.include <bsd.port.mk>
diff --git a/devel/libtool-fixed/distinfo b/devel/libtool-fixed/distinfo
new file mode 100644
index 000000000000..187e5840b97a
--- /dev/null
+++ b/devel/libtool-fixed/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libtool-2.4.tar.gz) = 13df57ab63a94e196c5d6e95d64e53262834fe780d5e82c28f177f9f71ddf62e
+SIZE (libtool-2.4.tar.gz) = 2580417
diff --git a/devel/libtool-fixed/files/patch-libltdl-Makefile.in b/devel/libtool-fixed/files/patch-libltdl-Makefile.in
new file mode 100644
index 000000000000..02f03e7099d6
--- /dev/null
+++ b/devel/libtool-fixed/files/patch-libltdl-Makefile.in
@@ -0,0 +1,23 @@
+--- libltdl/Makefile.in.orig 2009-11-19 14:55:46.000000000 +0100
++++ libltdl/Makefile.in 2009-11-19 14:56:35.000000000 +0100
+@@ -402,12 +402,6 @@
+ $(top_builddir)/config.status: $(top_srcdir)/configure $(CONFIG_STATUS_DEPENDENCIES)
+ $(SHELL) ./config.status --recheck
+
+-$(top_srcdir)/configure: $(am__configure_deps)
+- $(am__cd) $(srcdir) && $(AUTOCONF)
+-$(ACLOCAL_M4): $(am__aclocal_m4_deps)
+- $(am__cd) $(srcdir) && $(ACLOCAL) $(ACLOCAL_AMFLAGS)
+-$(am__aclocal_m4_deps):
+-
+ config.h: stamp-h1
+ @if test ! -f $@; then \
+ rm -f stamp-h1; \
+@@ -418,7 +412,6 @@
+ @rm -f stamp-h1
+ cd $(top_builddir) && $(SHELL) ./config.status config.h
+ $(srcdir)/config-h.in: $(am__configure_deps)
+- ($(am__cd) $(top_srcdir) && $(AUTOHEADER))
+ rm -f stamp-h1
+ touch $@
+
diff --git a/devel/libtool-fixed/files/patch-libltdl_config_ltmain.sh b/devel/libtool-fixed/files/patch-libltdl_config_ltmain.sh
new file mode 100644
index 000000000000..4bc3bf1c120a
--- /dev/null
+++ b/devel/libtool-fixed/files/patch-libltdl_config_ltmain.sh
@@ -0,0 +1,83 @@
+--- libltdl/config/ltmain.sh.orig 2010-09-22 09:45:43.000000000 -0500
++++ libltdl/config/ltmain.sh 2011-01-18 12:59:46.000000000 -0600
+@@ -1376,2 +1376,17 @@
+ $opt_debug
++
++ # FreeBSD-specific: where we install compilers with non-standard names
++ tag_compilers_CC="*cc cc* *gcc gcc* clang"
++ tag_compilers_CXX="*c++ c++* *g++ g++* clang++"
++ base_compiler=`set -- "$@"; echo $1`
++
++ # If $tagname isn't set, then try to infer if the default "CC" tag applies
++ if test -z "$tagname"; then
++ for zp in $tag_compilers_CC; do
++ case $base_compiler in
++ $zp) tagname="CC"; break;;
++ esac
++ done
++ fi
++
+ if test -n "$available_tags" && test -z "$tagname"; then
+@@ -1412,3 +1427,18 @@
+ esac
+- fi
++
++ # FreeBSD-specific: try compilers based on inferred tag
++ if test -z "$tagname"; then
++ eval "tag_compilers=\$tag_compilers_${z}"
++ if test -n "$tag_compilers"; then
++ for zp in $tag_compilers; do
++ case $base_compiler in
++ $zp) tagname=$z; break;;
++ esac
++ done
++ if test -n "$tagname"; then
++ break
++ fi
++ fi
++ fi
++ fi
+ done
+@@ -3516,2 +3546,5 @@
+ ;;
++ *-*-freebsd*)
++ # FreeBSD doesn't need this...
++ ;;
+ *)
+@@ -5585,2 +5618,3 @@
+ esac
++ deplibs="$deplibs $arg"
+ continue
+@@ -6155,9 +6189,26 @@
+ func_append compiler_flags " $deplib"
+- if test "$linkmode" = lib ; then
+- case "$new_inherited_linker_flags " in
+- *" $deplib "*) ;;
+- * ) func_append new_inherited_linker_flags " $deplib" ;;
+- esac
+- fi
+ fi
++
++ case $linkmode in
++ lib)
++ deplibs="$deplib $deplibs"
++ test "$pass" = conv && continue
++ newdependency_libs="$deplib $newdependency_libs"
++ ;;
++ prog)
++ if test "$pass" = conv; then
++ deplibs="$deplib $deplibs"
++ continue
++ fi
++ if test "$pass" = scan; then
++ deplibs="$deplib $deplibs"
++ else
++ compile_deplibs="$deplib $compile_deplibs"
++ finalize_deplibs="$deplib $finalize_deplibs"
++ fi
++ ;;
++ *)
++ ;;
++ esac # linkmode
++
+ continue
diff --git a/devel/libtool-fixed/pkg-descr b/devel/libtool-fixed/pkg-descr
new file mode 100644
index 000000000000..30c6b97676bf
--- /dev/null
+++ b/devel/libtool-fixed/pkg-descr
@@ -0,0 +1,11 @@
+This is GNU Libtool, a generic library support script. Libtool hides
+the complexity of using shared libraries behind a consistent, portable
+interface.
+
+To use libtool, add the new generic library building commands to your
+Makefile, Makefile.in, or Makefile.am.
+
+This package provides the fixed version of libtool that works on FreeBSD 10.0
+and allows building autoconfed packages with support for FreeBSD 10.0.
+
+WWW: http://www.gnu.org/software/libtool/
diff --git a/devel/libtool-fixed/pkg-plist b/devel/libtool-fixed/pkg-plist
new file mode 100644
index 000000000000..d4bbdd78ca36
--- /dev/null
+++ b/devel/libtool-fixed/pkg-plist
@@ -0,0 +1,56 @@
+bin/libtool
+bin/libtoolize
+share/aclocal/argz.m4
+share/aclocal/libtool.m4
+share/aclocal/ltdl.m4
+share/aclocal/ltoptions.m4
+share/aclocal/ltsugar.m4
+share/aclocal/ltversion.m4
+share/aclocal/lt~obsolete.m4
+share/libtool/config/compile
+share/libtool/config/config.guess
+share/libtool/config/config.sub
+share/libtool/config/depcomp
+share/libtool/config/install-sh
+share/libtool/config/ltmain.sh
+share/libtool/config/missing
+share/libtool/libltdl/COPYING.LIB
+share/libtool/libltdl/Makefile.am
+share/libtool/libltdl/Makefile.in
+share/libtool/libltdl/Makefile.inc
+share/libtool/libltdl/README
+share/libtool/libltdl/aclocal.m4
+share/libtool/libltdl/argz.c
+share/libtool/libltdl/argz_.h
+share/libtool/libltdl/config-h.in
+share/libtool/libltdl/configure
+share/libtool/libltdl/configure.ac
+share/libtool/libltdl/libltdl/lt__alloc.h
+share/libtool/libltdl/libltdl/lt__dirent.h
+share/libtool/libltdl/libltdl/lt__glibc.h
+share/libtool/libltdl/libltdl/lt__private.h
+share/libtool/libltdl/libltdl/lt__strl.h
+share/libtool/libltdl/libltdl/lt_dlloader.h
+share/libtool/libltdl/libltdl/lt_error.h
+share/libtool/libltdl/libltdl/lt_system.h
+share/libtool/libltdl/libltdl/slist.h
+share/libtool/libltdl/loaders/dld_link.c
+share/libtool/libltdl/loaders/dlopen.c
+share/libtool/libltdl/loaders/dyld.c
+share/libtool/libltdl/loaders/load_add_on.c
+share/libtool/libltdl/loaders/loadlibrary.c
+share/libtool/libltdl/loaders/preopen.c
+share/libtool/libltdl/loaders/shl_load.c
+share/libtool/libltdl/lt__alloc.c
+share/libtool/libltdl/lt__dirent.c
+share/libtool/libltdl/lt__strl.c
+share/libtool/libltdl/lt_dlloader.c
+share/libtool/libltdl/lt_error.c
+share/libtool/libltdl/ltdl.c
+share/libtool/libltdl/ltdl.h
+share/libtool/libltdl/slist.c
+@dirrm share/libtool/libltdl/loaders
+@dirrm share/libtool/libltdl/libltdl
+@dirrm share/libtool/libltdl
+@dirrm share/libtool/config
+@dirrm share/libtool