aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorthierry <thierry@FreeBSD.org>2010-09-06 13:28:51 +0800
committerthierry <thierry@FreeBSD.org>2010-09-06 13:28:51 +0800
commitc303902ad7a396ec3cd6240af1e555f7f0b638e4 (patch)
treec3450ac76dc0250b6e2b7e453255448cf6385ff4
parent117a62796951624bffae759881b5378e73695539 (diff)
downloadfreebsd-ports-gnome-c303902ad7a396ec3cd6240af1e555f7f0b638e4.tar.gz
freebsd-ports-gnome-c303902ad7a396ec3cd6240af1e555f7f0b638e4.tar.zst
freebsd-ports-gnome-c303902ad7a396ec3cd6240af1e555f7f0b638e4.zip
Fix installation when the external ffmeg is installed, and fix on amd64.
PR: ports/150083 Submitted by: David Naylor <naylor.b.david (at) gmail.com>
-rw-r--r--sysutils/xvidcap/Makefile8
-rw-r--r--sysutils/xvidcap/files/patch-configure175
-rw-r--r--sysutils/xvidcap/files/patch-ffmpeg_Makefile25
-rw-r--r--sysutils/xvidcap/files/patch-ffmpeg_configure22
-rw-r--r--sysutils/xvidcap/files/patch-ffmpeg_libavcodec_cabac.h12
-rw-r--r--sysutils/xvidcap/files/patch-ffmpeg_libavformat_grab-bktr.c16
-rw-r--r--sysutils/xvidcap/files/patch-src_Makefile.in22
-rw-r--r--sysutils/xvidcap/pkg-plist4
8 files changed, 270 insertions, 14 deletions
diff --git a/sysutils/xvidcap/Makefile b/sysutils/xvidcap/Makefile
index 06a3d5ab7a60..36d365770766 100644
--- a/sysutils/xvidcap/Makefile
+++ b/sysutils/xvidcap/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xvidcap
DISTVERSION= 1.1.4p1
-PORTREVISION= 8
+PORTREVISION= 9
PORTEPOCH= 1
CATEGORIES= sysutils multimedia
MASTER_SITES= SF/${PORTNAME}/OldFiles
@@ -25,10 +25,10 @@ RUN_DEPENDS= animate:${PORTSDIR}/graphics/ImageMagick
GNU_CONFIGURE= yes
# Remove MAKE="${GMAKE}" after ffmpeg-devel's upgrade
-CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
- LDFLAGS="-L${LOCALBASE}/lib" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LOCALBASE="${LOCALBASE}" \
MAKE="${GMAKE}"
-CONFIGURE_ARGS= -with-forced-embedded-ffmpeg # To be removed after ffmpeg-devel's upgrade
+CONFIGURE_ARGS= --with-forced-embedded-ffmpeg # To be removed after ffmpeg-devel's upgrade
USE_GMAKE= yes # To be removed after ffmpeg-devel's upgrade
USE_GNOME= glib20 libglade2
diff --git a/sysutils/xvidcap/files/patch-configure b/sysutils/xvidcap/files/patch-configure
index 46f5ffaa8512..4051e1ea181f 100644
--- a/sysutils/xvidcap/files/patch-configure
+++ b/sysutils/xvidcap/files/patch-configure
@@ -1,5 +1,5 @@
---- configure.orig Mon Oct 30 09:11:11 2006
-+++ configure Tue Oct 31 19:26:30 2006
+--- configure.orig 2006-11-16 18:50:24.000000000 +0100
++++ configure 2010-09-05 22:17:41.000000000 +0200
@@ -9078,7 +9078,7 @@
echo $ECHO_N "(cached) $ECHO_C" >&6
else
@@ -18,12 +18,179 @@
else
unset ac_cv_lib_Xmu_XmuClientWindow; echo "Couldn't find libXmu in LD_LIBRARY_PATH, checking X11 paths"; echo "$as_me:$LINENO: checking for XmuClientWindow in -lXmu" >&5
-@@ -9513,7 +9513,7 @@
+@@ -9513,11 +9513,11 @@
# if cache empty (not tested or failed) and want static avcodec (then it failed) ...
if ( `test \( \( x${ac_cv_lib_avutil_av_rescale+set} = x \) -a \( x$static_avutil = xyes \) \)` ) ; then
# build embedded ffmpeg
- echo "${MAKE-make}-ing prerequisite ffmpeg libraries" && ( cd ./ffmpeg/ && ./configure --cc=${CC} --enable-gpl ${ac_my_ffmpeg_cfg_lame_switch} --enable-pthreads --enable-swscaler --disable-ffserver --disable-ffplay && ln -s libavcodec/avcodec.h && ln -s libavformat/avformat.h && ln -s libavformat/avio.h && ln -s libavformat/rt*.h ./ && ln -s libavutil/common.h ./ && ln -s libavutil/avutil.h ./ && ln -s libavutil/mathematics.h ./ && ln -s libavutil/int*.h ./ && ln -s libavutil/rational.h ./ && ln -s libswscale/swscale.h ./ && ln -s libswscale/rgb2rgb.h . && ${MAKE-make} )
-+ echo "${MAKE-make}-ing prerequisite ffmpeg libraries" && ( cd ./ffmpeg/ && ./configure --cc=${CC} --extra-libs=-lm --disable-opts --enable-gpl ${ac_my_ffmpeg_cfg_lame_switch} --enable-pthreads --enable-swscaler --disable-ffserver --disable-ffplay && ln -s libavcodec/avcodec.h && ln -s libavformat/avformat.h && ln -s libavformat/avio.h && ln -s libavformat/rt*.h ./ && ln -s libavutil/common.h ./ && ln -s libavutil/avutil.h ./ && ln -s libavutil/mathematics.h ./ && ln -s libavutil/int*.h ./ && ln -s libavutil/rational.h ./ && ln -s libswscale/swscale.h ./ && ln -s libswscale/rgb2rgb.h . && ${MAKE-make} )
++ echo "${MAKE-make}-ing prerequisite ffmpeg libraries" && ( cd ./ffmpeg/ && ./configure --cc=${CC} --extra-cflags=${CPPFLAGS} --extra-libs=-lm --disable-opts --disable-muxer=v4l --disable-muxer=v4l2 --enable-gpl ${ac_my_ffmpeg_cfg_lame_switch} --enable-pthreads --enable-swscaler --disable-ffserver --disable-ffplay && ln -s libavcodec/avcodec.h && ln -s libavformat/avformat.h && ln -s libavformat/avio.h && ln -s libavformat/rt*.h ./ && ln -s libavutil/common.h ./ && ln -s libavutil/avutil.h ./ && ln -s libavutil/mathematics.h ./ && ln -s libavutil/int*.h ./ && ln -s libavutil/rational.h ./ && ln -s libswscale/swscale.h ./ && ln -s libswscale/rgb2rgb.h . && ${MAKE-make} )
#echo "${MAKE-make}-ing prerequisite ffmpeg libraries" && ( cd ./ffmpeg/ && ./configure --cc=${CC} ${ac_my_ffmpeg_cfg_lame_switch} --enable-pthreads --disable-ffserver --disable-ffplay && ln -s libavcodec/avcodec.h && ln -s libavformat/avformat.h && ln -s libavformat/avio.h && ln -s libavformat/rt*.h ./ && ln -s libavutil/common.h ./ && ln -s libavutil/avutil.h ./ && ln -s libavutil/mathematics.h ./ && ln -s libavutil/int*.h ./ && ln -s libavutil/rational.h ./ && ${MAKE-make} )
# try to link it statically, or reset cache, set static_avcodec=no
top_srcdir=`pwd`
+- ac_my_ldflags_save=${LDFLAGS} ; LDFLAGS="${LDFLAGS} -L$top_srcdir/ffmpeg/libavcodec -L$top_srcdir/ffmpeg/libavformat -L$top_srcdir/ffmpeg/libavutil -L$top_srcdir/ffmpeg/libswscale"
++ ac_my_ldflags_save=${LDFLAGS} ; LOCALLIBPATH="-L$top_srcdir/ffmpeg/libavcodec -L$top_srcdir/ffmpeg/libavformat -L$top_srcdir/ffmpeg/libavutil -L$top_srcdir/ffmpeg/libswscale"
+ ac_my_cflags_save=${CFLAGS} ; CFLAGS="${CFLAGS} -I $top_srcdir -I$top_srcdir/ffmpeg/libavcodec -I$top_srcdir/ffmpeg/libavformat -I$top_srcdir/ffmpeg/libavutil -I$top_srcdir/ffmpeg/libswscale"
+
+
+@@ -9532,7 +9532,7 @@
+
+ echo -n "(static?) ... "
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-Wl,-Bstatic -lavutil -Wl,-Bdynamic $LIBS"
++LIBS="-Wl,-Bstatic -L$top_srcdir/ffmpeg/libavutil -lavutil -Wl,-Bdynamic $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -9599,7 +9599,7 @@
+ #define HAVE_LIBAVUTIL 1
+ _ACEOF
+
+- LIBS="-Wl,-Bstatic -lavutil -Wl,-Bdynamic $LIBS"
++ LIBS="-Wl,-Bstatic -L$top_srcdir/ffmpeg/libavutil -lavutil -Wl,-Bdynamic $LIBS"
+
+ else
+ unset ac_cv_lib_avutil_av_rescale ; static_avcodec=no ; LDFLAGS=$ac_my_ldflags_save ; CFLAGS=$ac_my_cflags_save
+@@ -9618,7 +9618,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lavutil $LIBS"
++LIBS="-L$top_srcdir/ffmpeg/libavutil -lavutil $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -9680,7 +9680,7 @@
+ #define HAVE_LIBAVUTIL 1
+ _ACEOF
+
+- LIBS="-lavutil $LIBS"
++ LIBS="-L$top_srcdir/ffmpeg/libavutil -lavutil $LIBS"
+
+ fi
+
+@@ -9703,7 +9703,7 @@
+
+ echo -n "(static?) ... "
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-Wl,-Bstatic -lswscale -Wl,-Bdynamic $ac_my_swscale_libs $LIBS"
++LIBS="-Wl,-Bstatic -L$top_srcdir/ffmpeg/libswscale -lswscale -Wl,-Bdynamic $ac_my_swscale_libs $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -9770,7 +9770,7 @@
+ #define HAVE_LIBSWSCALE 1
+ _ACEOF
+
+- LIBS="-Wl,-Bstatic -lswscale -Wl,-Bdynamic $LIBS"
++ LIBS="-Wl,-Bstatic -L$top_srcdir/ffmpeg/libswscale -lswscale -Wl,-Bdynamic $LIBS"
+
+ else
+ unset ac_cv_lib_swscale_sws_scale ; static_swscale=no ;
+@@ -9780,7 +9780,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lswscale $ac_my_swscale_libs $LIBS"
++LIBS="-L$top_srcdir/ffmpeg/libswscale -lswscale $ac_my_swscale_libs $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -9842,7 +9842,7 @@
+ #define HAVE_LIBSWSCALE 1
+ _ACEOF
+
+- LIBS="-lswscale $LIBS"
++ LIBS="-L$top_srcdir/ffmpeg/libswscale -lswscale $LIBS"
+
+ fi
+
+@@ -9868,7 +9868,7 @@
+
+ echo -n "(static?) ... "
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-Wl,-Bstatic -lavcodec -Wl,-Bdynamic $ac_my_avcodec_libs $LIBS"
++LIBS="-Wl,-Bstatic -L$top_srcdir/ffmpeg/libavcodec -lavcodec -Wl,-Bdynamic $ac_my_avcodec_libs $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -9935,7 +9935,7 @@
+ #define HAVE_LIBAVCODEC 1
+ _ACEOF
+
+- LIBS="-Wl,-Bstatic -lavcodec -Wl,-Bdynamic $LIBS"
++ LIBS="-Wl,-Bstatic -L$top_srcdir/ffmpeg/libavcodec -lavcodec -Wl,-Bdynamic $LIBS"
+
+ else
+ unset ac_cv_lib_avcodec_avcodec_encode_video ; static_avcodec=no ;
+@@ -9945,7 +9945,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lavcodec $ac_my_avcodec_libs $LIBS"
++LIBS="-L$top_srcdir/ffmpeg/libavcodec -lavcodec $ac_my_avcodec_libs $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -10007,7 +10007,7 @@
+ #define HAVE_LIBAVCODEC 1
+ _ACEOF
+
+- LIBS="-lavcodec $LIBS"
++ LIBS="-L$top_srcdir/ffmpeg/libavcodec -lavcodec $LIBS"
+
+ fi
+
+@@ -10033,7 +10033,7 @@
+
+ echo -n "(static?) ... "
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-Wl,-Bstatic -lavformat -Wl,-Bdynamic $ac_my_avformat_libs $LIBS"
++LIBS="-Wl,-Bstatic -L$top_srcdir/ffmpeg/libavformat -lavformat -Wl,-Bdynamic $ac_my_avformat_libs $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -10100,7 +10100,7 @@
+ #define HAVE_LIBAVFORMAT 1
+ _ACEOF
+
+- LIBS="-Wl,-Bstatic -lavformat -Wl,-Bdynamic $LIBS"
++ LIBS="-Wl,-Bstatic -L$top_srcdir/ffmpeg/libavformat -lavformat -Wl,-Bdynamic $LIBS"
+
+ else
+ unset ac_cv_lib_avformat_av_write_header ; static_avformat=no ;
+@@ -10110,7 +10110,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lavformat $ac_my_avformat_libs $LIBS"
++LIBS="-L$top_srcdir/ffmpeg/libavformat -lavformat $ac_my_avformat_libs $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -10172,7 +10172,7 @@
+ #define HAVE_LIBAVFORMAT 1
+ _ACEOF
+
+- LIBS="-lavformat $LIBS"
++ LIBS="-L$top_srcdir/ffmpeg/libavformat -lavformat $LIBS"
+
+ fi
+
+@@ -10206,7 +10206,7 @@
+
+ echo -n "(static?) ... "
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-Wl,-Bstatic -lavcodec -Wl,-Bdynamic $ac_my_avcodec_libs $LIBS"
++LIBS="-Wl,-Bstatic -L$top_srcdir/ffmpeg/libavcodec -lavcodec -Wl,-Bdynamic $ac_my_avcodec_libs $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
+@@ -10277,7 +10277,7 @@
+ echo $ECHO_N "(cached) $ECHO_C" >&6
+ else
+ ac_check_lib_save_LIBS=$LIBS
+-LIBS="-lavcodec $ac_my_avcodec_libs $LIBS"
++LIBS="-L$top_srcdir/ffmpeg/libavcodec -lavcodec $ac_my_avcodec_libs $LIBS"
+ cat >conftest.$ac_ext <<_ACEOF
+ /* confdefs.h. */
+ _ACEOF
diff --git a/sysutils/xvidcap/files/patch-ffmpeg_Makefile b/sysutils/xvidcap/files/patch-ffmpeg_Makefile
new file mode 100644
index 000000000000..98cd3dc125f2
--- /dev/null
+++ b/sysutils/xvidcap/files/patch-ffmpeg_Makefile
@@ -0,0 +1,25 @@
+--- ffmpeg/Makefile.orig 2006-10-25 21:31:11.000000000 +0200
++++ ffmpeg/Makefile 2010-09-05 16:47:52.000000000 +0200
+@@ -6,7 +6,7 @@
+
+ VPATH=$(SRC_PATH)
+
+-CFLAGS=$(OPTFLAGS) -I$(BUILD_ROOT) -I$(SRC_PATH) -I$(SRC_PATH)/libavutil \
++CFLAGS=-I$(BUILD_ROOT) -I$(SRC_PATH) $(OPTFLAGS) -I$(SRC_PATH)/libavutil \
+ -I$(SRC_PATH)/libavcodec -I$(SRC_PATH)/libavformat -I$(SRC_PATH)/libswscale \
+ -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_ISOC9X_SOURCE
+ LDFLAGS+= -g
+@@ -55,11 +55,11 @@
+ OBJS = ffmpeg.o ffserver.o cmdutils.o ffplay.o
+ SRCS = $(OBJS:.o=.c) $(ASM_OBJS:.o=.s)
+ LDFLAGS := -L$(BUILD_ROOT)/libavformat -L$(BUILD_ROOT)/libavcodec -L$(BUILD_ROOT)/libavutil $(LDFLAGS)
+-EXTRALIBS := -lavformat$(BUILDSUF) -lavcodec$(BUILDSUF) -lavutil$(BUILDSUF) $(EXTRALIBS)
++EXTRALIBS := -L$(BUILD_ROOT)/libavformat -lavformat$(BUILDSUF) -L$(BUILD_ROOT)/libavcodec -lavcodec$(BUILDSUF) -L$(BUILD_ROOT)/libavutil -lavutil$(BUILDSUF) $(EXTRALIBS)
+
+ ifeq ($(CONFIG_SWSCALER),yes)
+ LDFLAGS+=-L./libswscale
+-EXTRALIBS+=-lswscale$(BUILDSUF)
++EXTRALIBS+=-L$(BUILD_ROOT)/libswscale -lswscale$(BUILDSUF)
+ endif
+
+ all: lib $(PROGS_G) $(PROGS) $(PROGTEST) $(VHOOK) $(QTFASTSTART) $(DOC)
diff --git a/sysutils/xvidcap/files/patch-ffmpeg_configure b/sysutils/xvidcap/files/patch-ffmpeg_configure
index f156b07c7258..b2e3ba0ee7b6 100644
--- a/sysutils/xvidcap/files/patch-ffmpeg_configure
+++ b/sysutils/xvidcap/files/patch-ffmpeg_configure
@@ -1,5 +1,5 @@
---- ffmpeg/configure.orig Wed Oct 25 21:31:11 2006
-+++ ffmpeg/configure Mon Oct 30 23:32:55 2006
+--- ffmpeg/configure.orig 2006-10-25 21:31:11.000000000 +0200
++++ ffmpeg/configure 2010-09-05 17:13:00.000000000 +0200
@@ -556,7 +556,7 @@
audio_oss="yes"
dv1394="no"
@@ -9,6 +9,24 @@
;;
GNU/kFreeBSD)
v4l="no"
+@@ -1001,7 +1001,7 @@
+
+ # compute MMX state
+ if test $mmx = "default"; then
+- if test $arch = "x86" -o $arch = "x86_64"; then
++ if test $arch = "x86"; then
+ mmx="yes"
+ else
+ mmx="no"
+@@ -1304,7 +1304,7 @@
+ # these are off by default, so fail if requested and not available
+ enabled dts && require libdts dts.h dts_init -ldts -lm
+ enabled libgsm && require libgsm gsm.h gsm_create -lgsm
+-enabled mp3lame && require LAME lame/lame.h lame_init -lmp3lame -lm
++enabled mp3lame && require LAME lame/lame.h lame_init -L${LOCALBASE}/lib -lmp3lame -lm
+ enabled vorbis && require libvorbis vorbis/vorbisenc.h vorbis_info_init -lvorbis -lvorbisenc -logg
+ enabled libogg && require libogg ogg/ogg.h ogg_sync_init -logg
+ enabled xvid && require XviD xvid.h xvid_global -lxvidcore
@@ -1514,9 +1514,6 @@
check_cflags -Wall
check_cflags -Wno-switch
diff --git a/sysutils/xvidcap/files/patch-ffmpeg_libavcodec_cabac.h b/sysutils/xvidcap/files/patch-ffmpeg_libavcodec_cabac.h
new file mode 100644
index 000000000000..30115fae388f
--- /dev/null
+++ b/sysutils/xvidcap/files/patch-ffmpeg_libavcodec_cabac.h
@@ -0,0 +1,12 @@
+--- ffmpeg/libavcodec/cabac.h.orig 2010-08-29 11:27:54.000000000 +0000
++++ ffmpeg/libavcodec/cabac.h 2010-08-29 11:28:07.000000000 +0000
+@@ -28,9 +28,6 @@
+
+ //#undef NDEBUG
+ #include <assert.h>
+-#ifdef ARCH_X86_64
+-#define ARCH_X86
+-#endif
+ #ifdef ARCH_X86
+ #include "x86_cpu.h"
+ #endif
diff --git a/sysutils/xvidcap/files/patch-ffmpeg_libavformat_grab-bktr.c b/sysutils/xvidcap/files/patch-ffmpeg_libavformat_grab-bktr.c
new file mode 100644
index 000000000000..f143bb51396e
--- /dev/null
+++ b/sysutils/xvidcap/files/patch-ffmpeg_libavformat_grab-bktr.c
@@ -0,0 +1,16 @@
+--- ffmpeg/libavformat/grab_bktr.c~ 2010-08-29 11:31:58.000000000 +0000
++++ ffmpeg/libavformat/grab_bktr.c 2010-08-29 11:32:13.000000000 +0000
+@@ -25,13 +25,8 @@
+ */
+ #include "avformat.h"
+ #if defined(__FreeBSD__)
+-# if __FreeBSD__ >= 502100
+ # include <dev/bktr/ioctl_meteor.h>
+ # include <dev/bktr/ioctl_bt848.h>
+-# else
+-# include <machine/ioctl_meteor.h>
+-# include <machine/ioctl_bt848.h>
+-# endif
+ #elif defined(__FreeBSD_kernel__)
+ # include <dev/bktr/ioctl_meteor.h>
+ # include <dev/bktr/ioctl_bt848.h>
diff --git a/sysutils/xvidcap/files/patch-src_Makefile.in b/sysutils/xvidcap/files/patch-src_Makefile.in
new file mode 100644
index 000000000000..a8d813d8b649
--- /dev/null
+++ b/sysutils/xvidcap/files/patch-src_Makefile.in
@@ -0,0 +1,22 @@
+--- src/Makefile.in.orig 2006-11-16 18:50:23.000000000 +0100
++++ src/Makefile.in 2010-09-05 22:20:46.000000000 +0200
+@@ -62,8 +62,8 @@
+ DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
+ depcomp = $(SHELL) $(top_srcdir)/depcomp
+ am__depfiles_maybe = depfiles
+-COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
+- $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
++COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(AM_CPPFLAGS) \
++ $(AM_CFLAGS) $(CFLAGS) $(INCLUDES) $(CPPFLAGS)
+ CCLD = $(CC)
+ LINK = $(CCLD) $(AM_CFLAGS) $(CFLAGS) $(AM_LDFLAGS) $(LDFLAGS) -o $@
+ SOURCES = $(xvidcap_SOURCES)
+@@ -347,7 +347,7 @@
+ -test -z "$(bin_PROGRAMS)" || rm -f $(bin_PROGRAMS)
+ xvidcap$(EXEEXT): $(xvidcap_OBJECTS) $(xvidcap_DEPENDENCIES)
+ @rm -f xvidcap$(EXEEXT)
+- $(LINK) $(xvidcap_LDFLAGS) $(xvidcap_OBJECTS) $(xvidcap_LDADD) $(LIBS)
++ $(LINK) $(xvidcap_LDFLAGS) $(xvidcap_OBJECTS) $(LIBS) $(xvidcap_LDADD)
+
+ mostlyclean-compile:
+ -rm -f *.$(OBJEXT)
diff --git a/sysutils/xvidcap/pkg-plist b/sysutils/xvidcap/pkg-plist
index 05dd6616af76..866a2ee89057 100644
--- a/sysutils/xvidcap/pkg-plist
+++ b/sysutils/xvidcap/pkg-plist
@@ -125,10 +125,6 @@ share/gnome/help/xvidcap/it/figures/xvidcap-ctrl.png
share/gnome/help/xvidcap/it/figures/xvidcap-main-ctrl.png
share/gnome/help/xvidcap/it/figures/xvidcap-warning.png
share/gnome/help/xvidcap/it/xvidcap.xml
-share/locale/de/LC_MESSAGES/xvidcap.mo
-share/locale/en/LC_MESSAGES/xvidcap.mo
-share/locale/es/LC_MESSAGES/xvidcap.mo
-share/locale/it/LC_MESSAGES/xvidcap.mo
share/omf/xvidcap/xvidcap-C.omf
share/omf/xvidcap/xvidcap-de.omf
share/omf/xvidcap/xvidcap-es.omf