aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoritetcu <itetcu@FreeBSD.org>2007-01-13 23:28:12 +0800
committeritetcu <itetcu@FreeBSD.org>2007-01-13 23:28:12 +0800
commitc3633c915cd2ead037d93d11d198c031513cc9a6 (patch)
treef5d1b1dcf19ae7310a4d65a104a1015c20d6502f
parentafda491e79486cf6e1cfbe8aefe8c265122699be (diff)
downloadfreebsd-ports-gnome-c3633c915cd2ead037d93d11d198c031513cc9a6.tar.gz
freebsd-ports-gnome-c3633c915cd2ead037d93d11d198c031513cc9a6.tar.zst
freebsd-ports-gnome-c3633c915cd2ead037d93d11d198c031513cc9a6.zip
Add a new patch/files dir to news/klibido port to enable support
for up to 20 simultaneous server connections instead of the default limit of 10. This will allow users with Giganews accounts to take full advantage of their max connections allowed. PR: ports/107851 Submitted by: Conrad J. Sabatier (maintainer)
-rw-r--r--news/klibido/Makefile3
-rw-r--r--news/klibido/files/patch-src_addserver.cpp20
2 files changed, 23 insertions, 0 deletions
diff --git a/news/klibido/Makefile b/news/klibido/Makefile
index 61a2d5f1bb6b..6d832891019e 100644
--- a/news/klibido/Makefile
+++ b/news/klibido/Makefile
@@ -7,6 +7,7 @@
PORTNAME= klibido
PORTVERSION= 0.2.5
+PORTREVISION= 1
CATEGORIES= news
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -21,6 +22,8 @@ USE_KDELIBS_VER= 3
USE_XLIB= yes
USE_GMAKE= yes
USE_AUTOTOOLS= libtool:15
+INSTALLS_ICONS= yes
+USE_GETTEXT= yes
CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include/db44 ${PTHREAD_CFLAGS}" \
CXXFLAGS="${CXXFLAGS} -I${LOCALBASE}/include/db44" \
diff --git a/news/klibido/files/patch-src_addserver.cpp b/news/klibido/files/patch-src_addserver.cpp
new file mode 100644
index 000000000000..c1c10197ae92
--- /dev/null
+++ b/news/klibido/files/patch-src_addserver.cpp
@@ -0,0 +1,20 @@
+--- src/addserver.cpp.orig Tue Dec 12 20:12:32 2006
++++ src/addserver.cpp Tue Dec 12 20:13:17 2006
+@@ -27,7 +27,7 @@
+ buttonOk->setIconSet(KGlobal::iconLoader()->loadIcon("button_ok", KIcon::Small, 0, false));
+ buttonCancel->setIconSet(KGlobal::iconLoader()->loadIcon("button_cancel", KIcon::Small, 0, false));
+ m_priorityInput->setRange(1,10,1,false);
+- m_threadInput->setRange(1,10,1,false);
++ m_threadInput->setRange(1,20,1,false);
+ m_timeoutInput->setRange(60,600,5,false);
+ m_threadTimeoutInput->setRange(1,30,1,false);
+ validator=new QIntValidator(1,65535,this);
+@@ -90,7 +90,7 @@
+ buttonOk->setIconSet(KGlobal::iconLoader()->loadIcon("button_ok", KIcon::Small, 0, false));
+ buttonCancel->setIconSet(KGlobal::iconLoader()->loadIcon("button_cancel", KIcon::Small, 0, false));
+ m_priorityInput->setRange(1,10,1,false);
+- m_threadInput->setRange(1,10,1,false);
++ m_threadInput->setRange(1,20,1,false);
+ m_timeoutInput->setRange(60,600,5,false);
+ m_threadTimeoutInput->setRange(1,30,1,false);
+ validator=new QIntValidator(1,65535,this);