aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2012-02-19 17:07:38 +0800
committerjohans <johans@FreeBSD.org>2012-02-19 17:07:38 +0800
commitc63df0ff0df08113ecfb95555998b2d2b6cce006 (patch)
tree27bbab5fad79f1a7e0bc98eb8790771c97d1b948
parentfbd93d54111135960d756ef5025aa248dc77b4d5 (diff)
downloadfreebsd-ports-gnome-c63df0ff0df08113ecfb95555998b2d2b6cce006.tar.gz
freebsd-ports-gnome-c63df0ff0df08113ecfb95555998b2d2b6cce006.tar.zst
freebsd-ports-gnome-c63df0ff0df08113ecfb95555998b2d2b6cce006.zip
- Add new port: x11-toolkits/libxaw3dxft
It is an alternative for libxaw3d, with support for UTF-8 and fancy fonts. This library is a requirement for newer versions of graphics/xpaint. libxaw3dxft is a Xaw (Athena Widget Set) replacement that looks three-dimensional. Xaw3dxft is an extended version of xaw3d with support for UTF8 input and UTF8 encoding of text, and rendering text with the Freetype library and Truetype fonts. It should be mostly compatible with the original xaw3d library, except for font management : everything using the old X11 core font routines should be replaced by their freetype equivalents. The main advantage of using libxaw3dxft over libxaw3d or libxaw is that all text will appear nicely antialiasedd when using truetype fonts in the menu widgets. Also, the use of UTF8 makes it easier to internationalize applications in arbitrary languages. WWW: http://sf-xpaint.sourceforge.net/
-rw-r--r--x11-toolkits/Makefile1
-rw-r--r--x11-toolkits/libxaw3dxft/Makefile29
-rw-r--r--x11-toolkits/libxaw3dxft/distinfo2
-rw-r--r--x11-toolkits/libxaw3dxft/pkg-descr17
-rw-r--r--x11-toolkits/libxaw3dxft/pkg-plist80
5 files changed, 129 insertions, 0 deletions
diff --git a/x11-toolkits/Makefile b/x11-toolkits/Makefile
index 90b32fa15084..1ea165296d34 100644
--- a/x11-toolkits/Makefile
+++ b/x11-toolkits/Makefile
@@ -116,6 +116,7 @@
SUBDIR += libsexymm
SUBDIR += libwnck
SUBDIR += libwnck-reference
+ SUBDIR += libxaw3dxft
SUBDIR += libxfce4gui
SUBDIR += libzvt
SUBDIR += linux-f10-blt
diff --git a/x11-toolkits/libxaw3dxft/Makefile b/x11-toolkits/libxaw3dxft/Makefile
new file mode 100644
index 000000000000..988e450ed767
--- /dev/null
+++ b/x11-toolkits/libxaw3dxft/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: libxaw3dxft
+# Date created: 18 Feb 2012
+# Whom: johans
+#
+# $FreeBSD$
+#
+
+PORTNAME= libxaw3dxft
+PORTVERSION= 1.3.3
+CATEGORIES= graphics
+MASTER_SITES= SF/sf-xpaint/${PORTNAME}
+
+MAINTAINER= johans@FreeBSD.org
+COMMENT= 3D Xaw (Athena Widget Set) replacement with extended fonts
+
+LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+USE_LDCONFIG= yes
+USE_XORG= xft xmu xpm
+
+CPPFLAGS+= -I${LOCALBASE}/include/freetype2
+
+post-patch:
+ @${REINPLACE_CMD} 's:/usr/lib/pkgconfig:${PREFIX}/libdata/pkgconfig:' \
+ ${WRKSRC}/Makefile.in
+
+.include <bsd.port.mk>
diff --git a/x11-toolkits/libxaw3dxft/distinfo b/x11-toolkits/libxaw3dxft/distinfo
new file mode 100644
index 000000000000..53060ceb424b
--- /dev/null
+++ b/x11-toolkits/libxaw3dxft/distinfo
@@ -0,0 +1,2 @@
+SHA256 (libxaw3dxft-1.3.3.tar.bz2) = 44c6349fdaf286999fe48330026d5214f1d4cf2bf204579bba1f7aff8856378f
+SIZE (libxaw3dxft-1.3.3.tar.bz2) = 480914
diff --git a/x11-toolkits/libxaw3dxft/pkg-descr b/x11-toolkits/libxaw3dxft/pkg-descr
new file mode 100644
index 000000000000..95e58b7bf8c6
--- /dev/null
+++ b/x11-toolkits/libxaw3dxft/pkg-descr
@@ -0,0 +1,17 @@
+Xaw3dxft is a Xaw (Athena Widget Set) replacement that looks
+three-dimensional.
+
+Xaw3dxft is an extended version of xaw3d with support for UTF8 input
+and UTF8 encoding of text, and rendering text with the Freetype
+library and Truetype fonts. It should be mostly compatible with the
+original xaw3d library, except for font management : everything
+using the old X11 core font routines should be replaced by their
+freetype equivalents.
+
+The main advantage of using libxaw3dxft over libxaw3d or libxaw is
+that all text will appear nicely antialiasedd when using truetype fonts
+in the menu widgets. Also, the use of UTF8 makes it easier to
+internationalize applications in arbitrary languages.
+
+
+WWW: http://sf-xpaint.sourceforge.net/
diff --git a/x11-toolkits/libxaw3dxft/pkg-plist b/x11-toolkits/libxaw3dxft/pkg-plist
new file mode 100644
index 000000000000..963393170265
--- /dev/null
+++ b/x11-toolkits/libxaw3dxft/pkg-plist
@@ -0,0 +1,80 @@
+lib/libXaw3dxft.a
+lib/libXaw3dxft.la
+lib/libXaw3dxft.so
+lib/libXaw3dxft.so.7
+include/X11/Xaw3dxft/AllWidgets.h
+include/X11/Xaw3dxft/AsciiSink.h
+include/X11/Xaw3dxft/AsciiSinkP.h
+include/X11/Xaw3dxft/AsciiSrc.h
+include/X11/Xaw3dxft/AsciiSrcP.h
+include/X11/Xaw3dxft/AsciiText.h
+include/X11/Xaw3dxft/AsciiTextP.h
+include/X11/Xaw3dxft/Box.h
+include/X11/Xaw3dxft/BoxP.h
+include/X11/Xaw3dxft/Cardinals.h
+include/X11/Xaw3dxft/Command.h
+include/X11/Xaw3dxft/CommandP.h
+include/X11/Xaw3dxft/Dialog.h
+include/X11/Xaw3dxft/DialogP.h
+include/X11/Xaw3dxft/Form.h
+include/X11/Xaw3dxft/FormP.h
+include/X11/Xaw3dxft/Grip.h
+include/X11/Xaw3dxft/GripP.h
+include/X11/Xaw3dxft/Label.h
+include/X11/Xaw3dxft/LabelP.h
+include/X11/Xaw3dxft/Layout.h
+include/X11/Xaw3dxft/LayoutP.h
+include/X11/Xaw3dxft/List.h
+include/X11/Xaw3dxft/ListP.h
+include/X11/Xaw3dxft/MenuButton.h
+include/X11/Xaw3dxft/MenuButtoP.h
+include/X11/Xaw3dxft/Paned.h
+include/X11/Xaw3dxft/PanedP.h
+include/X11/Xaw3dxft/Panner.h
+include/X11/Xaw3dxft/PannerP.h
+include/X11/Xaw3dxft/Porthole.h
+include/X11/Xaw3dxft/PortholeP.h
+include/X11/Xaw3dxft/Repeater.h
+include/X11/Xaw3dxft/RepeaterP.h
+include/X11/Xaw3dxft/Reports.h
+include/X11/Xaw3dxft/Scrollbar.h
+include/X11/Xaw3dxft/ScrollbarP.h
+include/X11/Xaw3dxft/Simple.h
+include/X11/Xaw3dxft/SimpleP.h
+include/X11/Xaw3dxft/SimpleMenu.h
+include/X11/Xaw3dxft/SimpleMenP.h
+include/X11/Xaw3dxft/Sme.h
+include/X11/Xaw3dxft/SmeP.h
+include/X11/Xaw3dxft/SmeBSB.h
+include/X11/Xaw3dxft/SmeBSBP.h
+include/X11/Xaw3dxft/SmeLine.h
+include/X11/Xaw3dxft/SmeLineP.h
+include/X11/Xaw3dxft/SmeThreeD.h
+include/X11/Xaw3dxft/SmeThreeDP.h
+include/X11/Xaw3dxft/StripChart.h
+include/X11/Xaw3dxft/StripCharP.h
+include/X11/Xaw3dxft/Text.h
+include/X11/Xaw3dxft/TextP.h
+include/X11/Xaw3dxft/TextSink.h
+include/X11/Xaw3dxft/TextSinkP.h
+include/X11/Xaw3dxft/TextSrc.h
+include/X11/Xaw3dxft/TextSrcP.h
+include/X11/Xaw3dxft/ThreeD.h
+include/X11/Xaw3dxft/ThreeDP.h
+include/X11/Xaw3dxft/Tip.h
+include/X11/Xaw3dxft/TipP.h
+include/X11/Xaw3dxft/Toggle.h
+include/X11/Xaw3dxft/ToggleP.h
+include/X11/Xaw3dxft/Tree.h
+include/X11/Xaw3dxft/TreeP.h
+include/X11/Xaw3dxft/Viewport.h
+include/X11/Xaw3dxft/ViewportP.h
+include/X11/Xaw3dxft/XawInit.h
+include/X11/Xaw3dxft/XawAlloc.h
+include/X11/Xaw3dxft/Template.c
+include/X11/Xaw3dxft/Template.h
+include/X11/Xaw3dxft/TemplateP.h
+include/X11/Xaw3dxft/Xaw3dP.h
+include/X11/Xaw3dxft/Xaw3dXft.h
+libdata/pkgconfig/libxaw3dxft.pc
+@dirrm include/X11/Xaw3dxft