aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2002-06-30 03:17:40 +0800
committerijliao <ijliao@FreeBSD.org>2002-06-30 03:17:40 +0800
commitc70e39eecea67288301ee79b067e2722d47eb8eb (patch)
tree7243990842369ab3faf09b1e2d3083b2de756553
parent7aff283f2c99b8adeb97b183c130b47e3b718b70 (diff)
downloadfreebsd-ports-gnome-c70e39eecea67288301ee79b067e2722d47eb8eb.tar.gz
freebsd-ports-gnome-c70e39eecea67288301ee79b067e2722d47eb8eb.tar.zst
freebsd-ports-gnome-c70e39eecea67288301ee79b067e2722d47eb8eb.zip
upgrade to 0.5.7
PR: 39987 Submitted by: Ports Fury
-rw-r--r--mail/althea/Makefile11
-rw-r--r--mail/althea/distinfo2
-rw-r--r--mail/althea/files/Makefile.bsd6
-rw-r--r--mail/althea/files/patch-SendMail.cpp10
4 files changed, 18 insertions, 11 deletions
diff --git a/mail/althea/Makefile b/mail/althea/Makefile
index 9831fe7cf5d0..ac0d0ac14451 100644
--- a/mail/althea/Makefile
+++ b/mail/althea/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= althea
-PORTVERSION= 0.5.5
+PORTVERSION= 0.5.7
CATEGORIES= mail
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,17 +15,14 @@ EXTRACT_SUFX= .tgz
MAINTAINER= ports@FreeBSD.org
USE_REINPLACE= yes
-REINPLACE_ARGS= -i ""
USE_GTK= yes
USE_OPENSSL= yes
MAKE_ENV= MKDIR="${MKDIR}"
MAKEFILE= ${FILESDIR}/Makefile.bsd
post-patch:
- @${REINPLACE_CMD} -e "s|/etc|${PREFIX}/etc|g" \
- ${WRKSRC}/Documentation/help.html \
- ${WRKSRC}/load_config.cpp \
- ${WRKSRC}/load_config.h \
- ${WRKSRC}/save_config.h
+.for file in Documentation/help.html load_config.h save_config.h
+ @${REINPLACE_CMD} -e 's|/etc|${PREFIX}/etc|g' ${WRKSRC}/${file}
+.endfor
.include <bsd.port.mk>
diff --git a/mail/althea/distinfo b/mail/althea/distinfo
index 4dffb2bd82a3..c5ddb2637647 100644
--- a/mail/althea/distinfo
+++ b/mail/althea/distinfo
@@ -1 +1 @@
-MD5 (althea-0.5.5.tgz) = 779b2acd2b9337069cedc69e0d517e0d
+MD5 (althea-0.5.7.tgz) = ef84300c1f8a9e0d5d688b564c724e0e
diff --git a/mail/althea/files/Makefile.bsd b/mail/althea/files/Makefile.bsd
index fa4d778cc8ae..6253a1cd651d 100644
--- a/mail/althea/files/Makefile.bsd
+++ b/mail/althea/files/Makefile.bsd
@@ -16,10 +16,10 @@ CXXFLAGS+=-DPACKAGE=\"${PROG}\" -DDOCDIR=\"${DOCDIR}\" -DPIXDIR=\"${PIXDIR}\" -D
CXXFLAGS+=-ftemplate-depth-30
# Use the GTK's CFLAGS:
-CXXFLAGS+=`${GTK_CONFIG} --cflags` -I${OPENSSLINC}
+CXXFLAGS+=`${GTK_CONFIG} --cflags gthread` -I${OPENSSLINC}
# Use the GTK's libraries:
-LDADD+=`${GTK_CONFIG} --libs` -L${OPENSSLLIB} -lssl -lcrypto
+LDADD+=`${GTK_CONFIG} --libs gthread` -L${OPENSSLLIB} -lssl -lcrypto
# A hack to ensure C++ is called to do the final linking:
CC:= ${CXX}
@@ -28,7 +28,7 @@ ${DOCDIR}/images ${PIXDIR}:
${MKDIR} $@
beforeinstall: ${DOCDIR}/images ${PIXDIR}
- ${BSD_INSTALL_DATA} ${.CURDIR}/Documentation/*.* ${DOCDIR}
+ ${BSD_INSTALL_DATA} ${.CURDIR}/Documentation/help.html ${DOCDIR}
${BSD_INSTALL_DATA} ${.CURDIR}/Documentation/images/*.* ${DOCDIR}/images
${BSD_INSTALL_DATA} ${.CURDIR}/pixmaps/*.* ${PIXDIR}
${BSD_INSTALL_DATA} ${.CURDIR}/althearc.example ${PREFIX}/etc/
diff --git a/mail/althea/files/patch-SendMail.cpp b/mail/althea/files/patch-SendMail.cpp
new file mode 100644
index 000000000000..f35706059a43
--- /dev/null
+++ b/mail/althea/files/patch-SendMail.cpp
@@ -0,0 +1,10 @@
+--- SendMail.cpp.orig Wed Jan 23 02:30:15 2002
++++ SendMail.cpp Mon Jun 24 21:01:22 2002
+@@ -3,6 +3,7 @@
+ // -- created 4/11/00 updated 4/11/00
+ /////////////////////////////////////////
+
++#include <pthread.h>
+ #include "SendMail.h"
+
+ extern Althea gAlthea;