aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbf <bf@FreeBSD.org>2012-06-15 13:30:33 +0800
committerbf <bf@FreeBSD.org>2012-06-15 13:30:33 +0800
commitc73c619a7ab4327e895d1decac502bd4942e96f7 (patch)
tree5d5a9b1ac69072ef365fb98192d35c197fe5558b
parent7a111c29653943286799ec23228963d5722c155c (diff)
downloadfreebsd-ports-gnome-c73c619a7ab4327e895d1decac502bd4942e96f7.tar.gz
freebsd-ports-gnome-c73c619a7ab4327e895d1decac502bd4942e96f7.tar.zst
freebsd-ports-gnome-c73c619a7ab4327e895d1decac502bd4942e96f7.zip
fix the build, before further updates
-rw-r--r--math/petsc-mpich/Makefile2
-rw-r--r--math/petsc/Makefile17
-rw-r--r--math/petsc/files/patch-bmake::common::rules.shared.basic7
-rw-r--r--math/petsc/files/patch-config_configure.py2
-rw-r--r--math/petsc/files/patch-makefile2
5 files changed, 10 insertions, 20 deletions
diff --git a/math/petsc-mpich/Makefile b/math/petsc-mpich/Makefile
index b83073ad7d08..8704f5b53d7e 100644
--- a/math/petsc-mpich/Makefile
+++ b/math/petsc-mpich/Makefile
@@ -10,7 +10,7 @@ MASTERDIR= ${.CURDIR}/../petsc
WITH_MPI= yes
DEPRECATED= BROKEN for more than 6 month
-EXPIRATION_DATE= 2012-06-14
+EXPIRATION_DATE= 2012-06-21
BROKEN= filesystem was touched prior to make install phase
diff --git a/math/petsc/Makefile b/math/petsc/Makefile
index 226f5b4301e6..bb8d89960d0d 100644
--- a/math/petsc/Makefile
+++ b/math/petsc/Makefile
@@ -18,11 +18,6 @@ COMMENT= Portable, Extensible Toolkit for Scientific computation
RUN_DEPENDS= ksh:${PORTSDIR}/shells/pdksh \
qsub:${PORTSDIR}/sysutils/torque
-DEPRECATED= BROKEN for more than 6 month
-EXPIRATION_DATE= 2012-06-14
-
-BROKEN= does not configure
-
SLAVEDIRS= math/petsc-mpich
HAS_CONFIGURE= yes
@@ -56,9 +51,11 @@ TARGET= ${OPSYS:L}
PLIST_SUB= PFX=${PFX} TARGET=${TARGET}
.if !defined(WITHOUT_UMFPACK)
+UMFPACK_LIBS= umfpack.so,cholmod.so,colamd.so,amd.so
+L=${LOCALBASE}/lib/lib
LIB_DEPENDS+= umfpack.1:${PORTSDIR}/math/suitesparse
CONFIGURE_ARGS+= --with-umfpack-include="${LOCALBASE}/include/suitesparse" \
- --with-umfpack-lib=[${LOCALBASE}/lib/libumfpack.so,${LOCALBASE}/lib/libamd.so]
+ --with-umfpack-lib="[${UMFPACK_LIBS:C/^/${L}/:C/,/, ${L}/g}]"
.endif
.if !defined(NOPORTDOCS)
@@ -271,14 +268,6 @@ pre-configure:
${REINPLACE_CMD} -e "s|libpmpich|libmpl|" \
${WRKSRC}/python/BuildSystem/config/packages/MPI.py
.endif
-.if defined(PACKAGE_BUILDING)
- ${REINPLACE_CMD} -e "s|%%PACKAGE%%exit 1; ||" \
- -e "s|%%PACKAGE%%sys.exit(3)||" \
- ${WRKSRC}/makefile ${WRKSRC}/config/configure.py
-.else
- ${REINPLACE_CMD} -e "s|%%PACKAGE%%||" \
- ${WRKSRC}/makefile ${WRKSRC}/config/configure.py
-.endif
post-install:
${PYTHON_CMD} ${PYTHON_LIBDIR}/compileall.py ${PREFIX}/${PFX}/bin
diff --git a/math/petsc/files/patch-bmake::common::rules.shared.basic b/math/petsc/files/patch-bmake::common::rules.shared.basic
index 21f20bdbceda..f64f611487b7 100644
--- a/math/petsc/files/patch-bmake::common::rules.shared.basic
+++ b/math/petsc/files/patch-bmake::common::rules.shared.basic
@@ -1,9 +1,10 @@
---- bmake/common/rules.shared.basic.orig 2007-05-24 01:30:02.000000000 +0200
-+++ bmake/common/rules.shared.basic 2009-12-16 23:57:27.000000000 +0100
-@@ -10,6 +10,9 @@
+--- bmake/common/rules.shared.basic.orig 2007-05-23 19:30:02.000000000 -0400
++++ bmake/common/rules.shared.basic 2012-06-15 00:43:31.000000000 -0400
+@@ -10,6 +10,10 @@
shared_solaris2: shared_solaris
shared_solaris2_gnu: shared_solaris_gnu
++shared_freebsd10: shared_freebsd
+shared_freebsd9: shared_freebsd
+shared_freebsd8: shared_freebsd
+shared_freebsd7: shared_freebsd
diff --git a/math/petsc/files/patch-config_configure.py b/math/petsc/files/patch-config_configure.py
index 401c406c11be..e5be99315905 100644
--- a/math/petsc/files/patch-config_configure.py
+++ b/math/petsc/files/patch-config_configure.py
@@ -5,7 +5,7 @@
print ' ***** That should be reserved for installation *****'
print '================================================================================='
- sys.exit(3)
-+ %%PACKAGE%%sys.exit(3)
++ #sys.exit(3)
# Check for broken cygwin
if chkcygwin():
diff --git a/math/petsc/files/patch-makefile b/math/petsc/files/patch-makefile
index 36db50c2fc1b..22d6f88e3d34 100644
--- a/math/petsc/files/patch-makefile
+++ b/math/petsc/files/patch-makefile
@@ -13,7 +13,7 @@
echo " That should be reserved for installation";\
echo "********************************************************************"; \
- exit 1; fi
-+ %%PACKAGE%%exit 1; fi
++ fi
@${OMAKE} PETSC_ARCH=${PETSC_ARCH} chkpetsc_dir
-@${OMAKE} all_build 2>&1 | tee make_log_${PETSC_ARCH}
-@egrep -i "( error | error:)" make_log_${PETSC_ARCH} > /dev/null; if [ "$$?" = "0" ]; then \