aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpawel <pawel@FreeBSD.org>2014-05-18 02:41:43 +0800
committerpawel <pawel@FreeBSD.org>2014-05-18 02:41:43 +0800
commitc812b3ad0d5bb1a9ea2b01bab07605080dac138b (patch)
treecbca8650a5c9a3646a8351a858c7346c04469ea0
parent5cad9f219bf06961ea27e5d4d31a82c2e7c7665f (diff)
downloadfreebsd-ports-gnome-c812b3ad0d5bb1a9ea2b01bab07605080dac138b.tar.gz
freebsd-ports-gnome-c812b3ad0d5bb1a9ea2b01bab07605080dac138b.tar.zst
freebsd-ports-gnome-c812b3ad0d5bb1a9ea2b01bab07605080dac138b.zip
- Add staging support
- Convert to new options framework
-rw-r--r--japanese/yasou-fpw/Makefile20
1 files changed, 10 insertions, 10 deletions
diff --git a/japanese/yasou-fpw/Makefile b/japanese/yasou-fpw/Makefile
index cd22ab249030..021e4772e6c3 100644
--- a/japanese/yasou-fpw/Makefile
+++ b/japanese/yasou-fpw/Makefile
@@ -17,16 +17,16 @@ NO_BUILD= yes
WRKSRC= ${WRKDIR}/yasou
EXTRACT_BEFORE_ARGS= -qL
-NO_STAGE= yes
+OPTIONS_DEFINE= DOCS
+
do-install:
- ${MKDIR} ${PREFIX}/share/dict/yasou-fpw/yasou/data
- ${INSTALL_DATA} ${WRKSRC}/yasou/data/honmon ${PREFIX}/share/dict/yasou-fpw/yasou/data
- ${INSTALL_DATA} ${WRKSRC}/catalogs ${PREFIX}/share/dict/yasou-fpw
-.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
-.for i in readme.fpw yasoufpw.txt
- ${INSTALL_DATA} ${WRKSRC}/$i ${DOCSDIR}
-.endfor
-.endif
+ @${MKDIR} ${STAGEDIR}${PREFIX}/share/dict/yasou-fpw/yasou/data
+ ${INSTALL_DATA} ${WRKSRC}/yasou/data/honmon \
+ ${STAGEDIR}${PREFIX}/share/dict/yasou-fpw/yasou/data
+ ${INSTALL_DATA} ${WRKSRC}/catalogs \
+ ${STAGEDIR}${PREFIX}/share/dict/yasou-fpw
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ (cd ${WRKSRC} && ${INSTALL_DATA} readme.fpw yasoufpw.txt \
+ ${STAGEDIR}${DOCSDIR})
.include <bsd.port.mk>