aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwen <wen@FreeBSD.org>2011-10-26 10:40:09 +0800
committerwen <wen@FreeBSD.org>2011-10-26 10:40:09 +0800
commitc922f9dbdf16c9a2cc15db4f98f83355b1b2664e (patch)
treeac5a06619d7345ea5c94281b51ee29d470baf319
parent9244a451eb7a3938eb1f093962f762b9ac9b1799 (diff)
downloadfreebsd-ports-gnome-c922f9dbdf16c9a2cc15db4f98f83355b1b2664e.tar.gz
freebsd-ports-gnome-c922f9dbdf16c9a2cc15db4f98f83355b1b2664e.tar.zst
freebsd-ports-gnome-c922f9dbdf16c9a2cc15db4f98f83355b1b2664e.zip
TinyOWS server implements latest WFS-T standard versions,
as well as related standards such as Filter Encoding (FE). WWW: http://www.tinyows.org/ PR: ports/161770 Submitted by: Joris Dedieu <joris.dedieu@gmail.com>
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/tinyows/Makefile36
-rw-r--r--graphics/tinyows/distinfo2
-rw-r--r--graphics/tinyows/pkg-descr4
-rw-r--r--graphics/tinyows/pkg-plist79
5 files changed, 122 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index dd8af197d5be..ef1ca7fd388d 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -949,6 +949,7 @@
SUBDIR += tifmerge
SUBDIR += timeless
SUBDIR += tintfu
+ SUBDIR += tinyows
SUBDIR += tkpng
SUBDIR += togl
SUBDIR += tonicpoint-viewer
diff --git a/graphics/tinyows/Makefile b/graphics/tinyows/Makefile
new file mode 100644
index 000000000000..8ceb1f47821a
--- /dev/null
+++ b/graphics/tinyows/Makefile
@@ -0,0 +1,36 @@
+# New ports collection Makefile for: tinows
+# Date created: 2011-10-18
+# Whom: Joris Dedieu <joris.dedieu@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tinyows
+PORTVERSION= 1.0.0
+CATEGORIES= graphics www geography
+MASTER_SITES= http://tinyows.org/tracdocs/release/
+
+MAINTAINER= joris.dedieu@nfrance.com
+COMMENT= High Performance WFS-T server
+
+LIB_DEPENDS= xml2:${PORTSDIR}/textproc/libxml2
+BUILD_DEPENDS= ${LOCALBASE}/lib/postgresql/postgis-1.5.so:${PORTSDIR}/databases/postgis
+
+USE_BZIP2= YES
+WRKSRC= ${WRKDIR}/${PORTNAME}
+GNU_CONFIGURE= YES
+
+OPTIONS= FASTCGI "Support FASTCGI" on \
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_FASTCGI)
+BUILD_DEPENDS+= ${LOCALBASE}/bin/cgi-fcgi:${PORTSDIR}/www/fcgi
+CONFIGURE_ARGS+= --with-fastcgi=${LOCALBASE}
+.endif
+
+post-install:
+ ${MKDIR} ${WWWDIR}/cgi-bin/
+ ${INSTALL_PROGRAM} ${WRKSRC}/tinyows ${WWWDIR}/cgi-bin/tinyows
+
+.include <bsd.port.post.mk>
diff --git a/graphics/tinyows/distinfo b/graphics/tinyows/distinfo
new file mode 100644
index 000000000000..55ba0bfd5611
--- /dev/null
+++ b/graphics/tinyows/distinfo
@@ -0,0 +1,2 @@
+SHA256 (tinyows-1.0.0.tar.bz2) = b80dbca8147ea0d31e92271eee6398caede055b7ef65a9d60f34e20172041f46
+SIZE (tinyows-1.0.0.tar.bz2) = 1180960
diff --git a/graphics/tinyows/pkg-descr b/graphics/tinyows/pkg-descr
new file mode 100644
index 000000000000..1c11ae224447
--- /dev/null
+++ b/graphics/tinyows/pkg-descr
@@ -0,0 +1,4 @@
+TinyOWS server implements latest WFS-T standard versions,
+as well as related standards such as Filter Encoding (FE).
+
+WWW: http://www.tinyows.org/
diff --git a/graphics/tinyows/pkg-plist b/graphics/tinyows/pkg-plist
new file mode 100644
index 000000000000..bc0e26a59ae3
--- /dev/null
+++ b/graphics/tinyows/pkg-plist
@@ -0,0 +1,79 @@
+%%DATADIR%%/schema/LICENSE
+%%DATADIR%%/schema/filter/1.0.0/expr.xsd
+%%DATADIR%%/schema/filter/1.0.0/filter.xsd
+%%DATADIR%%/schema/filter/1.0.0/filterCapabilities.xsd
+%%DATADIR%%/schema/filter/1.1.0/expr.xsd
+%%DATADIR%%/schema/filter/1.1.0/filter.xsd
+%%DATADIR%%/schema/filter/1.1.0/filterCapabilities.xsd
+%%DATADIR%%/schema/filter/1.1.0/sort.xsd
+%%DATADIR%%/schema/gml/2.1.2/feature.xsd
+%%DATADIR%%/schema/gml/2.1.2/geometry.xsd
+%%DATADIR%%/schema/gml/2.1.2/xlinks.xsd
+%%DATADIR%%/schema/gml/3.1.1/base/basicTypes.xsd
+%%DATADIR%%/schema/gml/3.1.1/base/coordinateOperations.xsd
+%%DATADIR%%/schema/gml/3.1.1/base/coordinateReferenceSystems.xsd
+%%DATADIR%%/schema/gml/3.1.1/base/coordinateSystems.xsd
+%%DATADIR%%/schema/gml/3.1.1/base/coverage.xsd
+%%DATADIR%%/schema/gml/3.1.1/base/dataQuality.xsd
+%%DATADIR%%/schema/gml/3.1.1/base/datums.xsd
+%%DATADIR%%/schema/gml/3.1.1/base/defaultStyle.xsd
+%%DATADIR%%/schema/gml/3.1.1/base/dictionary.xsd
+%%DATADIR%%/schema/gml/3.1.1/base/direction.xsd
+%%DATADIR%%/schema/gml/3.1.1/base/dynamicFeature.xsd
+%%DATADIR%%/schema/gml/3.1.1/base/feature.xsd
+%%DATADIR%%/schema/gml/3.1.1/base/geometryAggregates.xsd
+%%DATADIR%%/schema/gml/3.1.1/base/geometryBasic0d1d.xsd
+%%DATADIR%%/schema/gml/3.1.1/base/geometryBasic2d.xsd
+%%DATADIR%%/schema/gml/3.1.1/base/geometryComplexes.xsd
+%%DATADIR%%/schema/gml/3.1.1/base/geometryPrimitives.xsd
+%%DATADIR%%/schema/gml/3.1.1/base/gml.xsd
+%%DATADIR%%/schema/gml/3.1.1/base/gmlBase.xsd
+%%DATADIR%%/schema/gml/3.1.1/base/grids.xsd
+%%DATADIR%%/schema/gml/3.1.1/base/measures.xsd
+%%DATADIR%%/schema/gml/3.1.1/base/observation.xsd
+%%DATADIR%%/schema/gml/3.1.1/base/referenceSystems.xsd
+%%DATADIR%%/schema/gml/3.1.1/base/temporal.xsd
+%%DATADIR%%/schema/gml/3.1.1/base/temporalReferenceSystems.xsd
+%%DATADIR%%/schema/gml/3.1.1/base/temporalTopology.xsd
+%%DATADIR%%/schema/gml/3.1.1/base/topology.xsd
+%%DATADIR%%/schema/gml/3.1.1/base/units.xsd
+%%DATADIR%%/schema/gml/3.1.1/base/valueObjects.xsd
+%%DATADIR%%/schema/gml/3.1.1/smil/smil20-language.xsd
+%%DATADIR%%/schema/gml/3.1.1/smil/smil20.xsd
+%%DATADIR%%/schema/gml/3.1.1/smil/xml-mod.xsd
+%%DATADIR%%/schema/gml/3.1.1/xlink/xlinks.xsd
+%%DATADIR%%/schema/ows/1.0.0/ows19115subset.xsd
+%%DATADIR%%/schema/ows/1.0.0/owsAll.xsd
+%%DATADIR%%/schema/ows/1.0.0/owsCommon.xsd
+%%DATADIR%%/schema/ows/1.0.0/owsDataIdentification.xsd
+%%DATADIR%%/schema/ows/1.0.0/owsExceptionReport.xsd
+%%DATADIR%%/schema/ows/1.0.0/owsGetCapabilities.xsd
+%%DATADIR%%/schema/ows/1.0.0/owsOperationsMetadata.xsd
+%%DATADIR%%/schema/ows/1.0.0/owsServiceIdentification.xsd
+%%DATADIR%%/schema/ows/1.0.0/owsServiceProvider.xsd
+%%DATADIR%%/schema/wfs/1.0.0/WFS-basic.xsd
+%%DATADIR%%/schema/wfs/1.0.0/WFS-capabilities.xsd
+%%DATADIR%%/schema/wfs/1.0.0/WFS-transaction.xsd
+%%DATADIR%%/schema/wfs/1.1.0/wfs.xsd
+%%DATADIR%%/schema/xlink/1.0.0/xlinks.xsd
+%%WWWDIR%%/cgi-bin/tinyows
+@dirrmtry %%WWWDIR%%/cgi-bin
+@dirrmtry %%WWWDIR%%
+@dirrm %%DATADIR%%/schema/xlink/1.0.0
+@dirrm %%DATADIR%%/schema/xlink
+@dirrm %%DATADIR%%/schema/wfs/1.1.0
+@dirrm %%DATADIR%%/schema/wfs/1.0.0
+@dirrm %%DATADIR%%/schema/wfs
+@dirrm %%DATADIR%%/schema/ows/1.0.0
+@dirrm %%DATADIR%%/schema/ows
+@dirrm %%DATADIR%%/schema/gml/3.1.1/xlink
+@dirrm %%DATADIR%%/schema/gml/3.1.1/smil
+@dirrm %%DATADIR%%/schema/gml/3.1.1/base
+@dirrm %%DATADIR%%/schema/gml/3.1.1
+@dirrm %%DATADIR%%/schema/gml/2.1.2
+@dirrm %%DATADIR%%/schema/gml
+@dirrm %%DATADIR%%/schema/filter/1.1.0
+@dirrm %%DATADIR%%/schema/filter/1.0.0
+@dirrm %%DATADIR%%/schema/filter
+@dirrm %%DATADIR%%/schema
+@dirrm %%DATADIR%%