aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorglewis <glewis@FreeBSD.org>2010-10-03 14:23:58 +0800
committerglewis <glewis@FreeBSD.org>2010-10-03 14:23:58 +0800
commitc971f18cb790b3e2092f02d610be24700bda7bf5 (patch)
tree3f042197821c6724622cfc5b7a3c0aa8064d2a35
parentbe2963b7d10b6a69bb1c20423d44e7ed8aa3e55c (diff)
downloadfreebsd-ports-gnome-c971f18cb790b3e2092f02d610be24700bda7bf5.tar.gz
freebsd-ports-gnome-c971f18cb790b3e2092f02d610be24700bda7bf5.tar.zst
freebsd-ports-gnome-c971f18cb790b3e2092f02d610be24700bda7bf5.zip
. Fix overwriting of JUnit 4 during installation.
Submitted by: tg@
-rw-r--r--java/eclipse/Makefile11
-rw-r--r--java/eclipse/files/patch-eclipse-build2
2 files changed, 2 insertions, 11 deletions
diff --git a/java/eclipse/Makefile b/java/eclipse/Makefile
index 6adf8c107643..2fb386b11e99 100644
--- a/java/eclipse/Makefile
+++ b/java/eclipse/Makefile
@@ -183,6 +183,7 @@ post-patch:
.endfor
@${REINPLACE_CMD} -e "s+=/usr/share/java/junit.jar+=${BUILD_WRKSRC}/bundles/junit.jar+" ${BUILD_WRKSRC}/nonosgidependencies.properties
@${REINPLACE_CMD} -e "s+=/usr/share/java/junit4.jar+=${BUILD_WRKSRC}/bundles/junit4.jar+" ${BUILD_WRKSRC}/nonosgidependencies.properties
+ @${REINPLACE_CMD} -e "s+/usr/share/java/junit4.jar+${BUILD_WRKSRC}/bundles/junit4.jar+" ${BUILD_WRKSRC}/build.xml
.if defined(WITH_TESTS)
@(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${ANT} ${MAKE_ARGS} applyTestPatches)
.endif
@@ -208,16 +209,6 @@ do-install:
${BUILD_WRKSRC}/eclipse.tmp
.endif
@${INSTALL_SCRIPT} ${WRKSRC}/eclipse.tmp ${PREFIX}/bin/${PORTNAME}
- @for f in `ls ${BUILD_WRKSRC}/bundles/*.jar`; do \
- BASE=`basename $$f`; \
- FILES=`find ${PORTDESTDIR}/plugins/ -name "$$BASE"`; \
- if [ ! -z "$$FILES" ]; then \
- for s in $$FILES; do \
- ${RM} "$$s"; \
- ${INSTALL_DATA} "$$f" "$$s"; \
- done; \
- fi; \
- done
@${PREFIX}/bin/${PORTNAME} -initialize -consolelog
-@update-desktop-database
@(cd ${PREFIX}; ${FIND} -s lib/${PORTNAME} -not -type d) >> ${TMPPLIST}
diff --git a/java/eclipse/files/patch-eclipse-build b/java/eclipse/files/patch-eclipse-build
index 4b087e24034f..e93d292e46b9 100644
--- a/java/eclipse/files/patch-eclipse-build
+++ b/java/eclipse/files/patch-eclipse-build
@@ -122,7 +122,7 @@ $FreeBSD$
- <arg value="--no-target-directory" />
- <arg value="${buildDirectory}/installation" />
- <arg value="${destDir}${prefix}/${libDir}/eclipse" />
-+ <arg value="-R" />
++ <arg value="-RL" />
+ <arg value="${buildDirectory}/installation/" />
+ <arg value="${destDir}${prefix}/${libDir}/%%PORTNAME%%" />
</exec>