aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2013-08-28 22:25:14 +0800
committerbsam <bsam@FreeBSD.org>2013-08-28 22:25:14 +0800
commitc9cfe60d567b93b8cea29b2c1d4b416aaa04473c (patch)
tree481a2883fd6f22bc5d9b2abc7430153491ef11af
parent0736071b220afa53ab2b9d34a0bf779ed9090c75 (diff)
downloadfreebsd-ports-gnome-c9cfe60d567b93b8cea29b2c1d4b416aaa04473c.tar.gz
freebsd-ports-gnome-c9cfe60d567b93b8cea29b2c1d4b416aaa04473c.tar.zst
freebsd-ports-gnome-c9cfe60d567b93b8cea29b2c1d4b416aaa04473c.zip
. fix build with clang (CC=gcc -> CC?=gcc);
. add LICENSE (GPLv2); . bump PORTREVISIONr; . group build statements; . mute mkdir.
-rw-r--r--net/pptpclient/Makefile9
-rw-r--r--net/pptpclient/files/patch-aa17
2 files changed, 16 insertions, 10 deletions
diff --git a/net/pptpclient/Makefile b/net/pptpclient/Makefile
index 4db6850c44f4..728835d02bfc 100644
--- a/net/pptpclient/Makefile
+++ b/net/pptpclient/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pptpclient
PORTVERSION= 1.7.2
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= net
MASTER_SITES= SF/${PORTNAME}/pptp/pptp-${PORTVERSION}
DISTNAME= pptp-${PORTVERSION}
@@ -11,15 +11,16 @@ DISTNAME= pptp-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= PPTP client for establishing a VPN link with an NT server
+LICENSE= GPLv2
+
USES= perl5
+MAKE_ARGS= DEBUG=""
MAN8= pptp.8
-MAKE_ARGS= DEBUG=""
-
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/pptp ${PREFIX}/sbin
- ${MKDIR} ${PREFIX}/share/examples/pptpclient
+ @${MKDIR} ${PREFIX}/share/examples/pptpclient
${INSTALL_DATA} ${FILESDIR}/README ${PREFIX}/share/examples/pptpclient
${INSTALL_DATA} ${FILESDIR}/ppp.conf ${PREFIX}/share/examples/pptpclient
${INSTALL_MAN} ${WRKSRC}/pptp.8 ${PREFIX}/man/man8
diff --git a/net/pptpclient/files/patch-aa b/net/pptpclient/files/patch-aa
index 32fd59f74808..c993c6d254b2 100644
--- a/net/pptpclient/files/patch-aa
+++ b/net/pptpclient/files/patch-aa
@@ -1,6 +1,6 @@
---- Makefile.orig Thu Feb 17 23:42:45 2005
-+++ Makefile Wed Sep 28 19:51:25 2005
-@@ -4,7 +4,7 @@
+--- Makefile.orig 2008-05-14 11:33:55.000000000 +0500
++++ Makefile 2013-08-28 17:26:16.106297003 +0400
+@@ -4,19 +4,19 @@ RELEASE=
#################################################################
# CHANGE THIS LINE to point to the location of your pppd binary.
@@ -9,12 +9,17 @@
#################################################################
BINDIR=$(DESTDIR)/usr/sbin
-@@ -16,7 +16,7 @@
+ MANDIR=$(DESTDIR)/usr/share/man/man8
+ PPPDIR=$(DESTDIR)/etc/ppp
+
+-CC = gcc
++CC ?= gcc
+ RM = rm -f
OPTIMIZE= -O0
DEBUG = -g
INCLUDE =
-CFLAGS = -Wall $(OPTIMIZE) $(DEBUG) $(INCLUDE)
+CFLAGS += -Wall $(DEBUG) $(INCLUDE) -DUSER_PPP
LIBS = -lutil
- LDFLAGS =
-
+ # Solaris 10
+ # LIBS = -lnsl -lsocket -lresolv