aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorjylefort <jylefort@FreeBSD.org>2005-11-23 07:55:38 +0800
committerjylefort <jylefort@FreeBSD.org>2005-11-23 07:55:38 +0800
commitcaab158a975aaad9f608e7553a9e4de45ff0ceee (patch)
tree99c972d99649d262872bbf6ac12fa169b58a2803
parent1326c2989a34768eb89083086acd5432388a69b8 (diff)
downloadfreebsd-ports-gnome-caab158a975aaad9f608e7553a9e4de45ff0ceee.tar.gz
freebsd-ports-gnome-caab158a975aaad9f608e7553a9e4de45ff0ceee.tar.zst
freebsd-ports-gnome-caab158a975aaad9f608e7553a9e4de45ff0ceee.zip
OPTIONSify.
PR: ports/89117 Submitted by: Pawel Wieleba <P.Wieleba@iem.pw.edu.pl> Approved by: maintainer
-rw-r--r--audio/sox/Makefile27
1 files changed, 4 insertions, 23 deletions
diff --git a/audio/sox/Makefile b/audio/sox/Makefile
index d19d3d2480f9..8c7487b93a4e 100644
--- a/audio/sox/Makefile
+++ b/audio/sox/Makefile
@@ -21,19 +21,11 @@ MLINKS= play.1 rec.1 sox.1 soxmix.1
GNU_CONFIGURE= yes
MAKE_ENV= PLAY_SUPPORT=1
-.include <bsd.port.pre.mk>
-
-.if exists(${LOCALBASE}/lib/libmp3lame.so.0)
-WITH_LAME= YES
-.endif
+OPTIONS= LAME "Enable mp3 encoding with LAME" off \
+ MAD "Enable mp3 decoding with MAD" off \
+ VORBIS "Enable Ogg Vorbis support" off
-.if exists(${LOCALBASE}/lib/libmad.so.2)
-WITH_MAD= YES
-.endif
-
-.if exists(${LOCALBASE}/lib/libvorbis.so.3)
-WITH_VORBIS= YES
-.endif
+.include <bsd.port.pre.mk>
.if defined(WITH_VORBIS) || defined(WITH_LAME) || defined(WITH_MAD)
CFLAGS+= -I${LOCALBASE}/include
@@ -62,15 +54,4 @@ LIB_DEPENDS+= mad.2:${PORTSDIR}/audio/libmad
CONFIGURE_ARGS+= --disable-mad
.endif
-pre-fetch:
-.if !defined(WITH_LAME)
- @${ECHO_MSG} "You can enable mp3 encoding by defining WITH_LAME."
-.endif
-.if !defined(WITH_MAD)
- @${ECHO_MSG} "You can enable mp3 decoding by defining WITH_MAD."
-.endif
-.if !defined(WITH_VORBIS)
- @${ECHO_MSG} "You can enable Ogg Vorbis support by defining WITH_VORBIS."
-.endif
-
.include <bsd.port.post.mk>