aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorolgeni <olgeni@FreeBSD.org>2006-05-25 04:19:44 +0800
committerolgeni <olgeni@FreeBSD.org>2006-05-25 04:19:44 +0800
commitcb66eee51db1613d679a18fd4f4b22a762c71512 (patch)
tree445c765180a0d055a3ff7dff7832257e20a74b46
parent2855ed239dd89d41ae61cb474ba7ea913b505a07 (diff)
downloadfreebsd-ports-gnome-cb66eee51db1613d679a18fd4f4b22a762c71512.tar.gz
freebsd-ports-gnome-cb66eee51db1613d679a18fd4f4b22a762c71512.tar.zst
freebsd-ports-gnome-cb66eee51db1613d679a18fd4f4b22a762c71512.zip
Upgrade module ldap-useradmin-1.270-4.
Add proper handling of configuration file upgrades by running setup.sh when needed.
-rw-r--r--sysutils/webmin/Makefile9
-rw-r--r--sysutils/webmin/distinfo6
-rw-r--r--sysutils/webmin/files/patch-aa58
-rw-r--r--sysutils/webmin/pkg-plist1
4 files changed, 50 insertions, 24 deletions
diff --git a/sysutils/webmin/Makefile b/sysutils/webmin/Makefile
index 874607ed5119..6af11322ad3d 100644
--- a/sysutils/webmin/Makefile
+++ b/sysutils/webmin/Makefile
@@ -7,7 +7,7 @@
PORTNAME= webmin
PORTVERSION= 1.270
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= sysutils
MASTER_SITES= http://www.webmin.com/updates/:up \
${MASTER_SITE_SOURCEFORGE:S/$/:sf/} \
@@ -30,7 +30,7 @@ SUB_LIST= PERL5=${PERL}
WEBMIN_MODULES= apache-1.270-3.wbm.gz \
file-1.270-4.wbm.gz \
- ldap-useradmin-1.270-1.wbm.gz
+ ldap-useradmin-1.270-4.wbm.gz
post-extract:
@if [ "${WEBMIN_MODULES}" != "" ]; then \
@@ -53,7 +53,7 @@ post-patch:
spam/config-freebsd squid/config-freebsd \
stunnel/config usermin/config webalizer/config-freebsd \
wuftpd/config-freebsd xinetd/config-freebsd
- @${PERL} -pi -e "s|%%PREFIX%%|${PREFIX}|g" ${WRKSRC}/${file}
+ @${REINPLACE_CMD} -e "s=%%PREFIX%%=${PREFIX}=" ${WRKSRC}/${file}
.endfor
@${REINPLACE_CMD} -e "s=%%PREFIX%%=${PREFIX}=" ${WRKSRC}/setup.sh
@${FIND} ${WRKSRC} -name "*.cgi" -print \
@@ -83,6 +83,9 @@ post-install:
@${ECHO_CMD} "x!" >> ${WRKDIR}/ex.script
@${CP} -p ${TMPPLIST} ${TMPPLIST}.pre-lib-webmin
@cd ${WRKDIR} ; ex < ex.script
+ @if [ -d ${PREFIX}/etc/webmin ]; then \
+ ${PREFIX}/lib/webmin/setup.sh; \
+ fi
@${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>
diff --git a/sysutils/webmin/distinfo b/sysutils/webmin/distinfo
index 7ef74c514ab6..330cb0b5e7e3 100644
--- a/sysutils/webmin/distinfo
+++ b/sysutils/webmin/distinfo
@@ -7,6 +7,6 @@ SIZE (apache-1.270-3.wbm.gz) = 394187
MD5 (file-1.270-4.wbm.gz) = ca41d397fee3f73fc15df06a9d2c47c5
SHA256 (file-1.270-4.wbm.gz) = b2cde2f31395c943a1655bd8663051d551f4e9800ca251644d1611e8c5622486
SIZE (file-1.270-4.wbm.gz) = 493398
-MD5 (ldap-useradmin-1.270-1.wbm.gz) = cb000c6641567956d7755a963f52207c
-SHA256 (ldap-useradmin-1.270-1.wbm.gz) = 0ee370c9bb75461c162adecb4eca4f1c879bca515928fff3d6df6a89c9a55b73
-SIZE (ldap-useradmin-1.270-1.wbm.gz) = 49561
+MD5 (ldap-useradmin-1.270-4.wbm.gz) = 75f348ece2ded837f8ec35fa3e433571
+SHA256 (ldap-useradmin-1.270-4.wbm.gz) = 873f3382eb7eb64ea6abced42e8c933e967de362e374131195255ad227d5971d
+SIZE (ldap-useradmin-1.270-4.wbm.gz) = 49996
diff --git a/sysutils/webmin/files/patch-aa b/sysutils/webmin/files/patch-aa
index dfe464244370..eaf5c70836b2 100644
--- a/sysutils/webmin/files/patch-aa
+++ b/sysutils/webmin/files/patch-aa
@@ -1,24 +1,30 @@
$FreeBSD$
---- setup.sh.orig Fri Jun 4 01:15:55 2004
-+++ setup.sh Sat Jun 19 19:24:25 2004
-@@ -89,12 +89,12 @@
+--- setup.sh.orig
++++ setup.sh
+@@ -95,19 +95,7 @@
echo "Unless you want to run multiple versions of Webmin at the same time"
echo "you can just accept the defaults."
echo ""
-printf "Config file directory [/etc/webmin]: "
-+printf "Config file directory [%%PREFIX%%/etc/webmin]: "
- if [ "$config_dir" = "" ]; then
- read config_dir
- fi
- if [ "$config_dir" = "" ]; then
+-if [ "$config_dir" = "" ]; then
+- read config_dir
+-fi
+-if [ "$config_dir" = "" ]; then
- config_dir=/etc/webmin
-+ config_dir=%%PREFIX%%/etc/webmin
- fi
- abspath=`echo $config_dir | grep "^/"`
- if [ "$abspath" = "" ]; then
-@@ -199,12 +199,12 @@
+-fi
+-abspath=`echo $config_dir | grep "^/"`
+-if [ "$abspath" = "" ]; then
+- echo "Config directory must be an absolute path"
+- echo ""
+- exit 2
+-fi
++config_dir=%%PREFIX%%/etc/webmin
+ if [ ! -d $config_dir ]; then
+ mkdir $config_dir;
+ if [ $? != 0 ]; then
+@@ -206,12 +194,12 @@
fi
# Ask for log directory
@@ -33,7 +39,7 @@ $FreeBSD$
fi
abspath=`echo $var_dir | grep "^/"`
if [ "$abspath" = "" ]; then
-@@ -232,7 +232,9 @@
+@@ -239,7 +227,9 @@
echo "Webmin is written entirely in Perl. Please enter the full path to the"
echo "Perl 5 interpreter on your system."
echo ""
@@ -44,7 +50,7 @@ $FreeBSD$
perldef=/usr/bin/perl
elif [ -x /usr/local/bin/perl ]; then
perldef=/usr/local/bin/perl
-@@ -418,22 +420,6 @@
+@@ -438,22 +428,6 @@
fi
fi
@@ -67,7 +73,7 @@ $FreeBSD$
# Copy files to target directory
echo "***********************************************************************"
if [ "$wadir" != "$srcdir" ]; then
-@@ -535,6 +521,7 @@
+@@ -564,6 +538,7 @@
fi
fi
@@ -75,11 +81,27 @@ $FreeBSD$
if [ "$noperlpath" = "" ]; then
echo "Inserting path to perl into scripts.."
(find "$wadir" -name '*.cgi' -print ; find "$wadir" -name '*.pl' -print) | $perl "$wadir/perlpath.pl" $perl -
-@@ -545,7 +532,6 @@
+@@ -574,7 +549,6 @@
echo "Creating start and stop scripts.."
- rm -f $config_dir/stop $config_dir/start $config_dir/restart
+ rm -f $config_dir/stop $config_dir/start $config_dir/restart $config_dir/reload
echo "#!/bin/sh" >>$config_dir/start
-echo "echo Starting Webmin server in $wadir" >>$config_dir/start
echo "trap '' 1" >>$config_dir/start
echo "LANG=" >>$config_dir/start
echo "export LANG" >>$config_dir/start
+@@ -696,6 +670,7 @@
+ echo passdelay=1 >> $config_dir/miniserv.conf
+ fi
+
++nouninstall="yes"
+ if [ "$nouninstall" = "" ]; then
+ echo "Creating uninstall script $config_dir/uninstall.sh .."
+ cat >$config_dir/uninstall.sh <<EOF
+@@ -765,6 +740,7 @@
+ . "$srcdir/setup-post.sh"
+ fi
+
++nostart="yes"
+ if [ "$nostart" = "" ]; then
+ if [ "$inetd" != "1" ]; then
+ echo "Attempting to start Webmin mini web server.."
diff --git a/sysutils/webmin/pkg-plist b/sysutils/webmin/pkg-plist
index 065a38bb619d..dbba2e13d0b7 100644
--- a/sysutils/webmin/pkg-plist
+++ b/sysutils/webmin/pkg-plist
@@ -2,3 +2,4 @@
@comment -=[ begin PLIST.lib-webmin ]=-
@comment -=[ end PLIST.lib-webmin ]=-
@dirrmtry lib/webmin
+@exec [ -d %D/etc/webmin ] && %D/lib/webmin/setup.sh || true