aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormandree <mandree@FreeBSD.org>2013-03-27 05:33:33 +0800
committermandree <mandree@FreeBSD.org>2013-03-27 05:33:33 +0800
commitcbc7e614a4440b82bc4688768cd507b9dd015e6a (patch)
treee832d5a2d11ef37ff86bd6b911483a2b9f9687e8
parent3b3a50136a6ca72d169fb4ba4f96456f196802dc (diff)
downloadfreebsd-ports-gnome-cbc7e614a4440b82bc4688768cd507b9dd015e6a.tar.gz
freebsd-ports-gnome-cbc7e614a4440b82bc4688768cd507b9dd015e6a.tar.zst
freebsd-ports-gnome-cbc7e614a4440b82bc4688768cd507b9dd015e6a.zip
Add new port audio/lua51-mpd, a Lua client library for MPD,
the music player daemon. Note that the submission has been modified to set the submitter as the port maintainer, and to use UNIQUENAME in the DOCSDIR, to avoid clashes with mpd. PR: ports/177334 Submitted by: David Demelier <demelier.david@gmail.com>
-rw-r--r--audio/Makefile1
-rw-r--r--audio/lua51-mpd/Makefile41
-rw-r--r--audio/lua51-mpd/distinfo2
-rw-r--r--audio/lua51-mpd/pkg-descr3
-rw-r--r--audio/lua51-mpd/pkg-plist8
5 files changed, 55 insertions, 0 deletions
diff --git a/audio/Makefile b/audio/Makefile
index 611a61d0ad21..7f8023266ce4 100644
--- a/audio/Makefile
+++ b/audio/Makefile
@@ -453,6 +453,7 @@
SUBDIR += lmms
SUBDIR += lpac
SUBDIR += lplayer
+ SUBDIR += lua51-mpd
SUBDIR += lv2core
SUBDIR += lxmusic
SUBDIR += mac
diff --git a/audio/lua51-mpd/Makefile b/audio/lua51-mpd/Makefile
new file mode 100644
index 000000000000..bad32861e412
--- /dev/null
+++ b/audio/lua51-mpd/Makefile
@@ -0,0 +1,41 @@
+# $FreeBSD$
+
+PORTNAME= mpd
+PORTVERSION= 0.1
+CATEGORIES= audio
+PKGNAMEPREFIX= ${LUA_PKGNAMEPREFIX}
+
+MAINTAINER= demelier.david@gmail.com
+COMMENT= A Lua library for musicpd
+
+RUN_DEPENDS= ${LUA_MODLIBDIR}/socket/core.so:${PORTSDIR}/net/luasocket
+
+OPTIONS_DEFINE= DOCS
+DOCSDIR= ${PREFIX}/share/doc/${UNIQUENAME}
+
+.include <bsd.port.options.mk>
+
+GH_ACCOUNT= silentbicycle
+GH_PROJECT= lua-mpd
+GH_TAGNAME= v0.1
+
+USE_GITHUB= yes
+USE_LUA= 5.1
+
+WRKSRC= ${WRKDIR}/${GH_ACCOUNT}-lua-${PORTNAME}-ca32f43
+
+do-build:
+ @${DO_NADA}
+
+do-install:
+ @${MKDIR} ${LUA_MODSHAREDIR}
+ @${INSTALL_DATA} ${WRKSRC}/mpd.lua ${LUA_MODSHAREDIR}
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR} ${DOCSDIR}/modules ${DOCSDIR}/files
+ ${INSTALL_DATA} ${WRKSRC}/index.html ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/luadoc.css ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/files/mpd.html ${DOCSDIR}/files
+ ${INSTALL_DATA} ${WRKSRC}/modules/mpd.html ${DOCSDIR}/modules
+.endif
+
+.include <bsd.port.mk>
diff --git a/audio/lua51-mpd/distinfo b/audio/lua51-mpd/distinfo
new file mode 100644
index 000000000000..c0b4d1629792
--- /dev/null
+++ b/audio/lua51-mpd/distinfo
@@ -0,0 +1,2 @@
+SHA256 (mpd-0.1.tar.gz) = 51905ecf330537b55b18c8a6b24f973cc92cd365f8712a9a32e2a6d61a5ca964
+SIZE (mpd-0.1.tar.gz) = 16395
diff --git a/audio/lua51-mpd/pkg-descr b/audio/lua51-mpd/pkg-descr
new file mode 100644
index 000000000000..f0a6a49c5cdc
--- /dev/null
+++ b/audio/lua51-mpd/pkg-descr
@@ -0,0 +1,3 @@
+This is a Lua client for mpd.
+
+WWW: https://github.com/silentbicycle/lua-mpd
diff --git a/audio/lua51-mpd/pkg-plist b/audio/lua51-mpd/pkg-plist
new file mode 100644
index 000000000000..8c7891815d96
--- /dev/null
+++ b/audio/lua51-mpd/pkg-plist
@@ -0,0 +1,8 @@
+%%LUA_MODSHAREDIR%%/mpd.lua
+%%PORTDOCS%%%%DOCSDIR%%/files/mpd.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/luadoc.css
+%%PORTDOCS%%%%DOCSDIR%%/modules/mpd.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/modules
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/files
+%%PORTDOCS%%@dirrm %%DOCSDIR%%