aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlippe <lippe@FreeBSD.org>2009-09-01 07:40:56 +0800
committerlippe <lippe@FreeBSD.org>2009-09-01 07:40:56 +0800
commitcc44ddd150df388d88ca23dbf753e6039f20a283 (patch)
tree0cf3b7c417c793698511e9de29401baba7eb596e
parent59b8812fbabe15528c84020e872458adeeebc482 (diff)
downloadfreebsd-ports-gnome-cc44ddd150df388d88ca23dbf753e6039f20a283.tar.gz
freebsd-ports-gnome-cc44ddd150df388d88ca23dbf753e6039f20a283.tar.zst
freebsd-ports-gnome-cc44ddd150df388d88ca23dbf753e6039f20a283.zip
New port: Run code after the response has been sent.
WWW: http://search.cpan.org/dist/Catalyst-Plugin-RunAfterRequest/ PR: ports/138137, ports/138166 Submitted by: Andrey Kostenko <andrey@kostenko.name>
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Catalyst-Plugin-RunAfterRequest/Makefile28
-rw-r--r--www/p5-Catalyst-Plugin-RunAfterRequest/distinfo3
-rw-r--r--www/p5-Catalyst-Plugin-RunAfterRequest/pkg-descr3
-rw-r--r--www/p5-Catalyst-Plugin-RunAfterRequest/pkg-plist10
5 files changed, 45 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index aaf09671a4af..ed70971fb10a 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -789,6 +789,7 @@
SUBDIR += p5-Catalyst-Plugin-Params-Nested
SUBDIR += p5-Catalyst-Plugin-Pluggable
SUBDIR += p5-Catalyst-Plugin-Prototype
+ SUBDIR += p5-Catalyst-Plugin-RunAfterRequest
SUBDIR += p5-Catalyst-Plugin-Scheduler
SUBDIR += p5-Catalyst-Plugin-Server
SUBDIR += p5-Catalyst-Plugin-Session
diff --git a/www/p5-Catalyst-Plugin-RunAfterRequest/Makefile b/www/p5-Catalyst-Plugin-RunAfterRequest/Makefile
new file mode 100644
index 000000000000..6d1d6c30e5fe
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-RunAfterRequest/Makefile
@@ -0,0 +1,28 @@
+# New ports collection makefile for: p5-Catalyst-Plugin-RunAfterRequest
+# Date created: 2009-08-30
+# Whom: Andrey Kostenko <andrey@kostenko.name>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-RunAfterRequest
+PORTVERSION= 0.03
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= andrey@kostenko.name
+COMMENT= Run code after the response has been sent
+
+BUILD_DEPENDS= p5-Catalyst-Runtime>=5.8004:${PORTSDIR}/www/p5-Catalyst-Runtime \
+ p5-Catalyst-Component-InstancePerContext>=0:${PORTSDIR}/www/p5-Catalyst-Component-InstancePerContext \
+ p5-MooseX-AttributeHelpers>=0:${PORTSDIR}/devel/p5-MooseX-AttributeHelpers \
+ p5-parent>=0:${PORTSDIR}/devel/p5-parent
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Catalyst::Plugin::RunAfterRequest.3 \
+ Catalyst::Model::Role::RunAfterRequest.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Catalyst-Plugin-RunAfterRequest/distinfo b/www/p5-Catalyst-Plugin-RunAfterRequest/distinfo
new file mode 100644
index 000000000000..c934c0739aef
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-RunAfterRequest/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-Plugin-RunAfterRequest-0.03.tar.gz) = f26fee4fd87947663312fc3a54a0cfa6
+SHA256 (Catalyst-Plugin-RunAfterRequest-0.03.tar.gz) = 4403826e1d0c47c5397302f4f9e5ecbcea2e63e649408bb74cbd24fcec6be9af
+SIZE (Catalyst-Plugin-RunAfterRequest-0.03.tar.gz) = 16989
diff --git a/www/p5-Catalyst-Plugin-RunAfterRequest/pkg-descr b/www/p5-Catalyst-Plugin-RunAfterRequest/pkg-descr
new file mode 100644
index 000000000000..53ee5e8e2cc7
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-RunAfterRequest/pkg-descr
@@ -0,0 +1,3 @@
+Run code after the response has been sent.
+
+WWW: http://search.cpan.org/dist/Catalyst-Plugin-RunAfterRequest/
diff --git a/www/p5-Catalyst-Plugin-RunAfterRequest/pkg-plist b/www/p5-Catalyst-Plugin-RunAfterRequest/pkg-plist
new file mode 100644
index 000000000000..8c44274f3db1
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-RunAfterRequest/pkg-plist
@@ -0,0 +1,10 @@
+@comment $FreeBSD$
+%%SITE_PERL%%/Catalyst/Plugin/RunAfterRequest.pm
+%%SITE_PERL%%/Catalyst/Model/Role/RunAfterRequest.pm
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/RunAfterRequest/.packlist
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin/RunAfterRequest
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst/Plugin
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Catalyst
+@dirrmtry %%SITE_PERL%%/Catalyst/Model/Role
+@dirrmtry %%SITE_PERL%%/Catalyst/Model
+@dirrmtry %%SITE_PERL%%/Catalyst/Plugin