aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordanfe <danfe@FreeBSD.org>2016-11-14 19:26:59 +0800
committerdanfe <danfe@FreeBSD.org>2016-11-14 19:26:59 +0800
commitcd55e6e69506a0458c9132c892628ff8cba00803 (patch)
tree4c728ef23dfb9c2bf0c1eebc23ad8d7b2eea4181
parent208a873ea31126f1a11cbe1a3e80ecc599bbbb79 (diff)
downloadfreebsd-ports-gnome-cd55e6e69506a0458c9132c892628ff8cba00803.tar.gz
freebsd-ports-gnome-cd55e6e69506a0458c9132c892628ff8cba00803.tar.zst
freebsd-ports-gnome-cd55e6e69506a0458c9132c892628ff8cba00803.zip
Do not terminate BROKEN messages with period, it is added by the framework.
-rw-r--r--devel/llvm37/Makefile4
-rw-r--r--dns/dnsviz/Makefile2
-rw-r--r--editors/p5-Padre/Makefile2
-rw-r--r--emulators/qemu-sbruno/Makefile2
-rw-r--r--lang/icc/Makefile2
-rw-r--r--net-im/skype4/Makefile2
-rw-r--r--net/openldap24-server/Makefile2
-rw-r--r--security/maia/Makefile2
-rw-r--r--sysutils/e2fsprogs/Makefile2
-rw-r--r--sysutils/pftop/Makefile2
-rw-r--r--www/moinmoin/Makefile2
-rw-r--r--www/publicfile/Makefile11
12 files changed, 14 insertions, 21 deletions
diff --git a/devel/llvm37/Makefile b/devel/llvm37/Makefile
index b6663502fd71..5219f5e06e11 100644
--- a/devel/llvm37/Makefile
+++ b/devel/llvm37/Makefile
@@ -199,7 +199,7 @@ PLIST_FILES+= \
${SAN_LIBDIR}/libclang_rt.ubsan_standalone-i386.a \
${SAN_LIBDIR}/libclang_rt.ubsan_standalone_cxx-i386.a
.else
-BROKEN= no packaging data for sanitizers on ${ARCH}. Disable COMPILER_RT.
+BROKEN= no packaging data for sanitizers on ${ARCH}; disable COMPILER_RT
.endif
.endif
@@ -229,7 +229,7 @@ PLIST_SUB+= GOLD="@comment "
.if ! ${OPTIONS_DEFINE:MOPENMP}
# Hack to disable OPENMP in plist of unsupported architectures
-PLIST_SUB+= OPENMP="@comment "
+PLIST_SUB+= OPENMP="@comment "
.else
.endif
diff --git a/dns/dnsviz/Makefile b/dns/dnsviz/Makefile
index 8727ab72706b..eaba5aace659 100644
--- a/dns/dnsviz/Makefile
+++ b/dns/dnsviz/Makefile
@@ -19,7 +19,7 @@ USE_PYTHON= autoplist distutils
USE_GITHUB= yes
PYDISTUTILS_INSTALLNOSINGLE= yes
-BROKEN_FreeBSD_9= dependency py-m2crypto requires OpenSSL 1.0.1e+.
+BROKEN_FreeBSD_9= dependency py-m2crypto requires OpenSSL 1.0.1e+
post-patch:
@${REINPLACE_CMD} -e "s|share/man/man1|man/man1|" ${WRKSRC}/setup.py
diff --git a/editors/p5-Padre/Makefile b/editors/p5-Padre/Makefile
index ca971ccdd1ac..edb5f50bc071 100644
--- a/editors/p5-Padre/Makefile
+++ b/editors/p5-Padre/Makefile
@@ -74,7 +74,7 @@ MAKE_JOBS_UNSAFE= yes
DOS2UNIX_WRKSRC=${WRKDIR}/${WXSC_DISTNAME}
DOS2UNIX_FILES= wx-scintilla/src/scintilla/src/Editor.cxx
-BROKEN_FreeBSD_9= Does not build.
+BROKEN_FreeBSD_9= does not build
DESKTOP_ENTRIES="Padre" \
"The Perl IDE" \
diff --git a/emulators/qemu-sbruno/Makefile b/emulators/qemu-sbruno/Makefile
index fea0b705447f..c8ae23607d7f 100644
--- a/emulators/qemu-sbruno/Makefile
+++ b/emulators/qemu-sbruno/Makefile
@@ -29,7 +29,7 @@ USE_PERL5= build
PATCH_STRIP= -p1
MAKE_ENV+= BSD_MAKE="${MAKE}" V=1
ONLY_FOR_ARCHS= amd64 powerpc powerpc64 # XXX someone wants to debug sparc64 hosts?
-BROKEN_i386= aarch64 system target is currently broken for i386 hosts, disable for now while dealing with upstream.
+BROKEN_i386= aarch64 system target is currently broken for i386 hosts, disable for now while dealing with upstream
OPTIONS_DEFINE= SAMBA X11 GTK2 OPENGL GNUTLS SASL JPEG PNG CURL \
CDROM_DMA PCAP USBREDIR X86_TARGETS BSD_USER \
diff --git a/lang/icc/Makefile b/lang/icc/Makefile
index 4cdab4cdaeb7..c7567e46b3e8 100644
--- a/lang/icc/Makefile
+++ b/lang/icc/Makefile
@@ -71,7 +71,7 @@ IGNORE= go to Intel Premier Support \(https://premier.intel.com/\) to obtain ${D
.endfor
.if exists(${LINUXBASE}/boot/kernel.h)
-BROKEN= Cannot coexist with linux_devtools.
+BROKEN= cannot coexist with linux_devtools
.endif
post-extract:
diff --git a/net-im/skype4/Makefile b/net-im/skype4/Makefile
index 0eff39574b11..6f04bb5ed79f 100644
--- a/net-im/skype4/Makefile
+++ b/net-im/skype4/Makefile
@@ -35,7 +35,7 @@ SUB_LIST+= SKYPEDIR=${SKYPEDIR}
.include <bsd.port.options.mk>
.if ${OPSYS} == FreeBSD && (${OSVERSION} >= 1100000 && ${OSVERSION} < 1100075 || ${OSVERSION} >= 1000000 && ${OSVERSION} < 1002507)
-BROKEN= Skype 4.3 requires Linux 2.6.32 emulation.
+BROKEN= Skype 4.3 requires Linux 2.6.32 emulation
.endif
.if ${PORT_OPTIONS:MVIDEO}
diff --git a/net/openldap24-server/Makefile b/net/openldap24-server/Makefile
index 0918b8171c94..2a3b815adfaf 100644
--- a/net/openldap24-server/Makefile
+++ b/net/openldap24-server/Makefile
@@ -140,7 +140,7 @@ PORTDOCS= CHANGES drafts rfc
PORT_OPTIONS+= SASL
.endif
.if defined(USE_OPENLDAP)
-BROKEN= You have 'USE_OPENLDAP' variable defined either in environment or in make(1) arguments. Please undefine and try again.
+BROKEN= you have USE_OPENLDAP variable defined either in environment or in make(1) arguments; please undefine and try again
.endif
.else
USE_OPENLDAP= yes
diff --git a/security/maia/Makefile b/security/maia/Makefile
index b8ebb291fc7d..694e96f4ce29 100644
--- a/security/maia/Makefile
+++ b/security/maia/Makefile
@@ -169,7 +169,7 @@ WANT_PGSQL= server
.endif
.if ${PORT_OPTIONS:MDOVECOT} && ${PORT_OPTIONS:MDOVECOT2}
-BROKEN=Please run 'make config' again and choose only one version of Dovecot. Both version 1.x and 2.x cannot co-exist.
+BROKEN= please run 'make config' again and choose only one version of Dovecot (versions 1.x and 2.x cannot coexist)
.endif
.if ${PORT_OPTIONS:MDOVECOT}
diff --git a/sysutils/e2fsprogs/Makefile b/sysutils/e2fsprogs/Makefile
index d25bafe199b2..c08887cc00ae 100644
--- a/sysutils/e2fsprogs/Makefile
+++ b/sysutils/e2fsprogs/Makefile
@@ -137,7 +137,7 @@ post-patch::
# NOTE: The previous .if block goes all the way to the end of the file.
.if !empty(PORT_OPTIONS:MNOTESTS) && (${OPSYS} == FreeBSD) && (${OSVERSION} >= 1100000 || ((${ARCH} != i386) && (${ARCH} != amd64)))
-BROKEN=e2fsprogs has not been tested on your system by the maintainer. You must run self-tests.
+BROKEN= it was not tested on your system by the maintainer; you must run self-tests
.endif
pre-build:
diff --git a/sysutils/pftop/Makefile b/sysutils/pftop/Makefile
index 4eda2e310e34..b192fb52f503 100644
--- a/sysutils/pftop/Makefile
+++ b/sysutils/pftop/Makefile
@@ -10,7 +10,7 @@ MASTER_SITES= http://www.eee.metu.edu.tr/~canacar/
MAINTAINER= araujo@FreeBSD.org
COMMENT= Utility for real-time display of statistics for pf
-BROKEN_FreeBSD_9= Does not build.
+BROKEN_FreeBSD_9= does not build
.include <bsd.port.pre.mk>
diff --git a/www/moinmoin/Makefile b/www/moinmoin/Makefile
index 6d1e347640b2..31b756989d50 100644
--- a/www/moinmoin/Makefile
+++ b/www/moinmoin/Makefile
@@ -43,7 +43,7 @@ MOINSCRIPT= ${MOINDIR}/server/moin.cgi
.elif ${MOINTYPE} == "WSGI"
MOINSCRIPT= ${MOINDIR}/server/moin.wsgi
.else
-BROKEN= MOINTYPE must be a STANDALONE, FCGI, WSGI, MOD_PYTHON or CGI.
+BROKEN= MOINTYPE must be a STANDALONE, FCGI, WSGI, MOD_PYTHON, or CGI
.endif
pre-everything::
diff --git a/www/publicfile/Makefile b/www/publicfile/Makefile
index a9f087c1505a..01e74be49b83 100644
--- a/www/publicfile/Makefile
+++ b/www/publicfile/Makefile
@@ -25,19 +25,12 @@ LEGAL_TEXT= No license -- see http://cr.yp.to/softwarelaw.html
.include <bsd.port.options.mk>
-pre-everything::
.if ${PORT_OPTIONS:MBASICAUTH} && ${PORT_OPTIONS:MCOMMONLOG}
- @${ECHO_MSG}
- @${ECHO_MSG} "Currently the common log and auth patches conflict."
- @${ECHO_MSG}
-BROKEN= Currently the common log and auth patches conflict.
+BROKEN= common log and auth patches are currently in conflict
.endif
.if ${PORT_OPTIONS:MBASICAUTH} && ${PORT_OPTIONS:MREDIRECT_SLASH}
- @${ECHO_MSG}
- @${ECHO_MSG} "Currently the redirect slash and auth patches conflict."
- @${ECHO_MSG}
-BROKEN= Currently the redirect slash and auth patches conflict.
+BROKEN= redirect slash and auth patches are currently in conflict
.endif
.if ${PORT_OPTIONS:MREDIRECT_SLASH}