aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpgj <pgj@FreeBSD.org>2013-06-05 07:27:19 +0800
committerpgj <pgj@FreeBSD.org>2013-06-05 07:27:19 +0800
commitcdc95209d4eddf0db0466d03c5fcd514f6cb2396 (patch)
tree23069eedb4a36485709aca0d548d2938cb63f7ec
parent65c168bb397baa9102e54ddccf77a3d64e93a148 (diff)
downloadfreebsd-ports-gnome-cdc95209d4eddf0db0466d03c5fcd514f6cb2396.tar.gz
freebsd-ports-gnome-cdc95209d4eddf0db0466d03c5fcd514f6cb2396.tar.zst
freebsd-ports-gnome-cdc95209d4eddf0db0466d03c5fcd514f6cb2396.zip
- Chase GHC 7.6 update
- Fix COMMENT Obtained from: FreeBSD Haskell
-rw-r--r--deskutils/checkrdf/Makefile2
-rw-r--r--deskutils/checkrdf/files/patch-CheckRDF.hs22
2 files changed, 19 insertions, 5 deletions
diff --git a/deskutils/checkrdf/Makefile b/deskutils/checkrdf/Makefile
index ab4bbb7d15e7..b40e3ad33650 100644
--- a/deskutils/checkrdf/Makefile
+++ b/deskutils/checkrdf/Makefile
@@ -8,7 +8,7 @@ CATEGORIES= deskutils
MASTER_SITES= SF
MAINTAINER= haskell@FreeBSD.org
-COMMENT= A tool for RDF site summaries based news-check
+COMMENT= Tool for RDF site summaries based news-check
LICENSE= BSD
diff --git a/deskutils/checkrdf/files/patch-CheckRDF.hs b/deskutils/checkrdf/files/patch-CheckRDF.hs
index d60481a3afdd..1289a7b98793 100644
--- a/deskutils/checkrdf/files/patch-CheckRDF.hs
+++ b/deskutils/checkrdf/files/patch-CheckRDF.hs
@@ -1,6 +1,6 @@
--- ./CheckRDF.hs.orig 2007-03-02 19:13:07.000000000 +0100
-+++ ./CheckRDF.hs 2012-05-13 13:10:24.395459549 +0200
-@@ -18,15 +18,20 @@
++++ ./CheckRDF.hs 2013-05-01 00:09:20.000000000 +0200
+@@ -18,15 +18,21 @@
import RDFConfig
@@ -14,6 +14,7 @@
-import Directory ( doesFileExist, getPermissions, readable, removeFile )
-import List ( partition, intersperse, groupBy, sortBy)
-import Time (getClockTime,toCalendarTime,calendarTimeToString)
++import System.IO.Error ( catchIOError )
+import System.Directory ( doesFileExist, getPermissions, readable, removeFile )
+import Data.List ( partition, intersperse, groupBy, sortBy)
+import System.Time (getClockTime,toCalendarTime,calendarTimeToString)
@@ -26,7 +27,7 @@
import Text.XML.HaXml.Xtract.Parse (parseXtract)
import Text.PrettyPrint.HughesPJ (render, vcat)
import Text.XML.HaXml.Pretty (content)
-@@ -52,15 +57,15 @@
+@@ -52,15 +58,15 @@
mkNewRDF :: RDFConfig -> FilePath -> String -> RDF
mkNewRDF config filename contents =
let elem = getElem $ xmlParse filename contents
@@ -48,7 +49,7 @@
)
$ map show [0..len1-1])
else []
-@@ -69,7 +74,7 @@
+@@ -69,7 +75,7 @@
,clink = cl
,citems = rdfitems
}
@@ -57,3 +58,16 @@
dfilter f = \ x -> f x x
mkRDFItem (t,l) = RDFItem {title = substituteChar '\n' ' ' $ rmCDATA t
,link = filter (/='\n') $ rmCDATA l
+@@ -109,9 +115,9 @@
+ if iseof
+ then return []
+ else do line <- hGetLine h
+- mrdf <- catch (do rdf <- (readIO line :: IO RDF)
+- return $ Just rdf)
+- (const $ return Nothing)
++ mrdf <- catchIOError (do rdf <- (readIO line :: IO RDF)
++ return $ Just rdf)
++ (const $ return Nothing)
+ maybe (return [])
+ (\rdf -> do rdfs <- readRDFs h
+ return $! rdf : rdfs)