aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2005-05-20 23:13:16 +0800
committerpav <pav@FreeBSD.org>2005-05-20 23:13:16 +0800
commitcf0dfb8cdb0bfa75798429641dd6cfaca67c4fb4 (patch)
tree5c96c2980554463493303b239863007d9f55df32
parente0136345d5e3635b12332ec56fe4e8743502bfe8 (diff)
downloadfreebsd-ports-gnome-cf0dfb8cdb0bfa75798429641dd6cfaca67c4fb4.tar.gz
freebsd-ports-gnome-cf0dfb8cdb0bfa75798429641dd6cfaca67c4fb4.tar.zst
freebsd-ports-gnome-cf0dfb8cdb0bfa75798429641dd6cfaca67c4fb4.zip
New port: devel/pear-HTML_CSS PEAR class for generating CSS declarations
PEAR::HTML_CSS provides a simple interface for generating a stylesheet declaration. PR: ports/81132 Submitted by: Antonio Carlos Venancio Junior <antonio@php.net>
-rw-r--r--devel/Makefile1
-rw-r--r--devel/pear-HTML_CSS/Makefile24
-rw-r--r--devel/pear-HTML_CSS/distinfo2
-rw-r--r--devel/pear-HTML_CSS/pkg-descr15
4 files changed, 42 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index e0649044f8c0..7c7cbd12e5b7 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1164,6 +1164,7 @@
SUBDIR += pear-Event_Dispatcher
SUBDIR += pear-FSM
SUBDIR += pear-HTML_BBCodeParser
+ SUBDIR += pear-HTML_CSS
SUBDIR += pear-HTML_Common
SUBDIR += pear-HTML_Form
SUBDIR += pear-HTML_Javascript
diff --git a/devel/pear-HTML_CSS/Makefile b/devel/pear-HTML_CSS/Makefile
new file mode 100644
index 000000000000..3725b312a352
--- /dev/null
+++ b/devel/pear-HTML_CSS/Makefile
@@ -0,0 +1,24 @@
+# Ports collection makefile for: pear-HTML_CSS
+# Date created: 16 May 2005
+# Whom: Antonio Carlos Venancio Junior (<antonio@inf.ufsc.br>)
+#
+# $FreeBSD$
+#
+
+PORTNAME= HTML_CSS
+PORTVERSION= 0.2.0
+CATEGORIES= devel www pear
+
+MAINTAINER= antonio@php.net
+COMMENT= PEAR class for generating CSS declarations
+
+BUILD_DEPENDS= ${PEARDIR}/HTML/Common.php:${PORTSDIR}/devel/pear-HTML_Common
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+CATEGORY= HTML
+FILES= CSS.php
+EXAMPLES= CSS_InHeader.php CSS_Inline.php CSS_Stylesheet.php
+
+.include <bsd.port.pre.mk>
+.include "${PORTSDIR}/devel/pear-PEAR/Makefile.common"
+.include <bsd.port.post.mk>
diff --git a/devel/pear-HTML_CSS/distinfo b/devel/pear-HTML_CSS/distinfo
new file mode 100644
index 000000000000..0a77e8187516
--- /dev/null
+++ b/devel/pear-HTML_CSS/distinfo
@@ -0,0 +1,2 @@
+MD5 (PEAR/HTML_CSS-0.2.0.tgz) = 549eceff1562bd97b358a34e7abc0dfb
+SIZE (PEAR/HTML_CSS-0.2.0.tgz) = 4181
diff --git a/devel/pear-HTML_CSS/pkg-descr b/devel/pear-HTML_CSS/pkg-descr
new file mode 100644
index 000000000000..f0708dbb97dd
--- /dev/null
+++ b/devel/pear-HTML_CSS/pkg-descr
@@ -0,0 +1,15 @@
+PEAR::HTML_CSS provides a simple interface for generating
+a stylesheet declaration. It is completely standards compliant, and
+has some great features:
+* Simple OO interface to CSS definitions
+* Output to
+ - Inline stylesheet declarations
+ - Document internal stylesheet declarations
+ - Standalone stylesheet declarations
+ - Array of definitions
+
+In addition, it shares the following with HTML_Common based classes:
+* Indent style support
+* Line ending style
+
+WWW: http://pear.php.net/package/HTML_CSS/