aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authortota <tota@FreeBSD.org>2012-02-27 05:54:23 +0800
committertota <tota@FreeBSD.org>2012-02-27 05:54:23 +0800
commitd0ff63e23fe0615cba7f34b1d2cc07c6455707af (patch)
tree7eea88beecf507aeacd770fa74df9f9bd5b2178f
parent0a6a1d9582da412b67271c27fe220532bfbc80a8 (diff)
downloadfreebsd-ports-gnome-d0ff63e23fe0615cba7f34b1d2cc07c6455707af.tar.gz
freebsd-ports-gnome-d0ff63e23fe0615cba7f34b1d2cc07c6455707af.tar.zst
freebsd-ports-gnome-d0ff63e23fe0615cba7f34b1d2cc07c6455707af.zip
- Add a new port: graphics/R-cran-rtiff
This package will read and write TIFF format images and return them as a pixmap object. Because the resulting object can be very large for even modestly sized TIFF images, images can be reduced as they are read for improved performance. This package is a wrapper around libtiff (www.libtiff.org), on which it depends (i.e. the libtiff shared library must be on your PATH for the binary to work, and tiffio.h must be on your system to build the package from source). By using libtiff's highlevel TIFFReadRGBAImage function, this package inherently support a wide range of image formats and compression schemes. This package also provides an implementation of the Ridler Autothresholding algorithm for easy generation of binary masks. WWW: http://cran.r-project.org/web/packages/rtiff/
-rw-r--r--graphics/Makefile1
-rw-r--r--graphics/R-cran-rtiff/Makefile26
-rw-r--r--graphics/R-cran-rtiff/distinfo2
-rw-r--r--graphics/R-cran-rtiff/pkg-descr13
4 files changed, 42 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 2ab6fc782358..b29cc3f2c1fe 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -23,6 +23,7 @@
SUBDIR += R-cran-ggplot2
SUBDIR += R-cran-munsell
SUBDIR += R-cran-rgdal
+ SUBDIR += R-cran-rtiff
SUBDIR += R-cran-shape
SUBDIR += SciPlot
SUBDIR += a2png
diff --git a/graphics/R-cran-rtiff/Makefile b/graphics/R-cran-rtiff/Makefile
new file mode 100644
index 000000000000..85767c09adf3
--- /dev/null
+++ b/graphics/R-cran-rtiff/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: R-cran-rtiff
+# Date created: 2012-02-21
+# Whom: TAKATSU Tomonari <tota@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= rtiff
+PORTVERSION= 1.4.1
+CATEGORIES= graphics
+DISTNAME= ${PORTNAME}_${PORTVERSION}
+
+MAINTAINER= tota@FreeBSD.org
+COMMENT= A tiff reader for R
+
+LIB_DEPENDS= tiff:${PORTSDIR}/graphics/tiff
+RUN_DEPENDS= R-cran-pixmap>0:${PORTSDIR}/graphics/R-cran-pixmap
+
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+LDFLAGS+= -L${LOCALBASE}/lib
+
+USE_R_MOD= yes
+R_MOD_AUTOPLIST= yes
+
+.include <bsd.port.mk>
diff --git a/graphics/R-cran-rtiff/distinfo b/graphics/R-cran-rtiff/distinfo
new file mode 100644
index 000000000000..8ba832bf4287
--- /dev/null
+++ b/graphics/R-cran-rtiff/distinfo
@@ -0,0 +1,2 @@
+SHA256 (rtiff_1.4.1.tar.gz) = a8f11af2b617123294dddd61815327e31c67124c88b8f5145304d49cafa29dae
+SIZE (rtiff_1.4.1.tar.gz) = 102323
diff --git a/graphics/R-cran-rtiff/pkg-descr b/graphics/R-cran-rtiff/pkg-descr
new file mode 100644
index 000000000000..bde3709ee2d5
--- /dev/null
+++ b/graphics/R-cran-rtiff/pkg-descr
@@ -0,0 +1,13 @@
+This package will read and write TIFF format images and return them
+as a pixmap object. Because the resulting object can be very large
+for even modestly sized TIFF images, images can be reduced as they
+are read for improved performance. This package is a wrapper around
+libtiff (www.libtiff.org), on which it depends (i.e. the libtiff
+shared library must be on your PATH for the binary to work, and
+tiffio.h must be on your system to build the package from source).
+By using libtiff's highlevel TIFFReadRGBAImage function, this package
+inherently support a wide range of image formats and compression
+schemes. This package also provides an implementation of the Ridler
+Autothresholding algorithm for easy generation of binary masks.
+
+WWW: http://cran.r-project.org/web/packages/rtiff/