aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2004-02-19 17:59:50 +0800
committerkris <kris@FreeBSD.org>2004-02-19 17:59:50 +0800
commitd1ea108d493c1292209e40250919e9b950cd9df9 (patch)
tree1a4d7a0090fc565fe192dbc89c80e17de1b1878c
parent2a431c51da02bab41cd0e00e2b3f60c128a89b2d (diff)
downloadfreebsd-ports-gnome-d1ea108d493c1292209e40250919e9b950cd9df9.tar.gz
freebsd-ports-gnome-d1ea108d493c1292209e40250919e9b950cd9df9.tar.zst
freebsd-ports-gnome-d1ea108d493c1292209e40250919e9b950cd9df9.zip
BROKEN on 5.x: does not compile
-rw-r--r--devel/hs-buddha/Makefile8
-rw-r--r--graphics/hs-HOpenGL/Makefile8
-rw-r--r--lang/nhc98/Makefile4
3 files changed, 18 insertions, 2 deletions
diff --git a/devel/hs-buddha/Makefile b/devel/hs-buddha/Makefile
index e2ec95ec1630..5d517b876039 100644
--- a/devel/hs-buddha/Makefile
+++ b/devel/hs-buddha/Makefile
@@ -27,6 +27,12 @@ USE_GMAKE= yes
PLIST_SUB+= BUDDHA_VERSION=${PORTVERSION:S/.r/-rc/}
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502102
+BROKEN= "Does not compile"
+.endif
+
pre-everything::
@${ECHO_CMD} ""
@${ECHO_CMD} "You need the profiling versions of GHC's libraries to build buddha."
@@ -40,4 +46,4 @@ post-patch:
pre-build:
@(cd ${WRKSRC} && ${GMAKE} depend)
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/graphics/hs-HOpenGL/Makefile b/graphics/hs-HOpenGL/Makefile
index 7193e35adea4..30bb32b8d18b 100644
--- a/graphics/hs-HOpenGL/Makefile
+++ b/graphics/hs-HOpenGL/Makefile
@@ -58,6 +58,12 @@ GFXDIR= ${IMPORT_DIR}/Graphics
CEXAMPLES= aaindex aapoly aargb accanti accpersp alpha alpha3D anti bezcurve bezmesh bezsurf blendeqn checker clip colormat colormatrix cube depthcue dof double drawf feedback fog fogindex font hello image light lines list material mipmap model movelight multitex nurbs pickdepth picksquare plane planet polyoff polys robot sccolorlight scene scenebamb sceneflat select smooth stencil stroke surface surfpoints teaambient teapots tess tesswind texbind texgen texprox texsub texture3d texturesurf torus trim unproject varray wrap
HSEXAMPLES= AAIndex AAPoly AARGB AccAnti AccPersp Alpha Alpha3D Anti BezCurve BezMesh BezSurf BlendEqn Checker Clip ColorMat Cube DList DOF DepthCue Double DrawF Feedback Fog FogIndex Font Hello Image Light Lines Material Mipmap Model MoveLight PickDepth PickSquare Plane Planet PolyOff Polys Quadric Robot ScColorLight Scene SceneBAmb SceneFlat Select Smooth Stencil Stroke TeaAmbient Teapots Tess TexBind TexGen TexProx TexSub TextureSurf Torus Unproject Varray Wrap
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} >= 502102
+BROKEN= "Does not compile"
+.endif
+
post-install:
${MKDIR} ${DATADIR}
${INSTALL_DATA} ${WRKSRC}/lib/HOpenGL.conf ${DATADIR}
@@ -97,4 +103,4 @@ post-install:
@${RM} -f ${PREFIX}/lib/ghc-${GHC_VERSION}/package.conf.old
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/lang/nhc98/Makefile b/lang/nhc98/Makefile
index 9ca4dc6f906b..c42889dc7f5c 100644
--- a/lang/nhc98/Makefile
+++ b/lang/nhc98/Makefile
@@ -25,6 +25,10 @@ USE_REINPLACE= yes
.include <bsd.port.pre.mk>
+.if ${OSVERSION} >= 502102
+BROKEN= "Does not compile"
+.endif
+
.if ${OSVERSION} >= 500000
BUILD_DEPENDS+= ghc-5.04.3:${PORTSDIR}/lang/ghc5
.endif