aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorolivierd <olivierd@FreeBSD.org>2012-08-10 03:49:04 +0800
committerolivierd <olivierd@FreeBSD.org>2012-08-10 03:49:04 +0800
commitd30e56748009376a609a5611149b9141bf90793e (patch)
tree43008a90844072ce458dfe61f73f7fb053577175
parentaedb536fd8b9e8f88ab2b294c58ce55dea8c20b8 (diff)
downloadfreebsd-ports-gnome-d30e56748009376a609a5611149b9141bf90793e.tar.gz
freebsd-ports-gnome-d30e56748009376a609a5611149b9141bf90793e.tar.zst
freebsd-ports-gnome-d30e56748009376a609a5611149b9141bf90793e.zip
- Use USE_PKGCONFIG macro
- Add patch when NLS is unset - Remove USE_AUTOTOOLS (libtool) macro Submitted by: myself Approved by: miwi, rene (mentors)
-rw-r--r--deskutils/xfce4-tumbler/Makefile11
1 files changed, 8 insertions, 3 deletions
diff --git a/deskutils/xfce4-tumbler/Makefile b/deskutils/xfce4-tumbler/Makefile
index 8d50e3d9dc63..764ef926853a 100644
--- a/deskutils/xfce4-tumbler/Makefile
+++ b/deskutils/xfce4-tumbler/Makefile
@@ -7,7 +7,7 @@
PORTNAME= tumbler
PORTVERSION= 0.1.25
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= deskutils xfce
MASTER_SITES= ${MASTER_SITE_XFCE}
PKGNAMEPREFIX= xfce4-
@@ -23,10 +23,10 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
USE_BZIP2= yes
GNU_CONFIGURE= yes
USE_GMAKE= yes
-USE_AUTOTOOLS= libtool
-USE_GNOME= glib20 gnomehack intltool intlhack pkgconfig
+USE_GNOME= glib20 gnomehack intltool intlhack
USE_LDCONFIG= yes
USE_XFCE= configenv
+USE_PKGCONFIG= build
CONFIGURE_ARGS= --enable-xdg-cache \
--disable-gtk-doc-html
@@ -126,4 +126,9 @@ CONFIGURE_ARGS+=--disable-raw-thumbnailer
PLIST_SUB+= RAW="@comment "
.endif
+.if empty(PORT_OPTIONS:MNLS)
+post-patch:
+ @${REINPLACE_CMD} -e 's| po||' ${WRKSRC}/Makefile.in
+.endif
+
.include <bsd.port.mk>