aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorlioux <lioux@FreeBSD.org>2002-11-26 20:04:54 +0800
committerlioux <lioux@FreeBSD.org>2002-11-26 20:04:54 +0800
commitd59bc9d5443e064081fa52e2eef3f9e2bce69ee7 (patch)
treeae78f2481a78399cccce665bfe832102b90b1bc6
parent53041dafe99b9a3f4a29412ef7ba44ad9eb20970 (diff)
downloadfreebsd-ports-gnome-d59bc9d5443e064081fa52e2eef3f9e2bce69ee7.tar.gz
freebsd-ports-gnome-d59bc9d5443e064081fa52e2eef3f9e2bce69ee7.tar.zst
freebsd-ports-gnome-d59bc9d5443e064081fa52e2eef3f9e2bce69ee7.zip
Fix build by improving GNU auto* tools disabling patch
Submitted by: bento
-rw-r--r--net-p2p/dctc-gui/Makefile8
-rw-r--r--net/dctc-gui/Makefile8
2 files changed, 8 insertions, 8 deletions
diff --git a/net-p2p/dctc-gui/Makefile b/net-p2p/dctc-gui/Makefile
index 3a1e37304858..1bda70b75616 100644
--- a/net-p2p/dctc-gui/Makefile
+++ b/net-p2p/dctc-gui/Makefile
@@ -67,6 +67,10 @@ post-patch:
s|^(dc_gui_OBJECTS[^\\]+)(\\*)$$|\1 ${file:S/.c$/.o/} \2|' \
${WRKSRC}/src/Makefile.in
.endfor
+# disable GNU auto* tools
+ @${FIND} ${WRKSRC} -type f -name "Makefile.in" | ${XARGS} \
+ -x -n 10 ${REINPLACE_CMD} -E -e \
+ 's!^(ACLOCAL|AUTOCONF|AUTOMAKE|AUTOHEADER).+$$!\1=${TRUE}!'
post-configure:
@${ECHO_CMD} '#ifndef MSG_NOSIGNAL' >> ${CONFIGURE_WRKSRC}/config.h
@@ -76,10 +80,6 @@ post-configure:
@${ECHO_CMD} '#ifndef SEMVMX' >> ${WRKSRC}/config.h
@${ECHO_CMD} '#define SEMVMX 32767' >> ${WRKSRC}/config.h
@${ECHO_CMD} '#endif' >> ${WRKSRC}/config.h
-# disable GNU auto* tools
- @${FIND} ${WRKSRC} -type f -name "Makefile" | ${XARGS} \
- -n 10 ${REINPLACE_CMD} -E -e \
- 's! (autoconf|autoheader|automake|aclocal)$$! ${TRUE}!'
post-install:
.ifndef(NOPORTDOCS)
diff --git a/net/dctc-gui/Makefile b/net/dctc-gui/Makefile
index 3a1e37304858..1bda70b75616 100644
--- a/net/dctc-gui/Makefile
+++ b/net/dctc-gui/Makefile
@@ -67,6 +67,10 @@ post-patch:
s|^(dc_gui_OBJECTS[^\\]+)(\\*)$$|\1 ${file:S/.c$/.o/} \2|' \
${WRKSRC}/src/Makefile.in
.endfor
+# disable GNU auto* tools
+ @${FIND} ${WRKSRC} -type f -name "Makefile.in" | ${XARGS} \
+ -x -n 10 ${REINPLACE_CMD} -E -e \
+ 's!^(ACLOCAL|AUTOCONF|AUTOMAKE|AUTOHEADER).+$$!\1=${TRUE}!'
post-configure:
@${ECHO_CMD} '#ifndef MSG_NOSIGNAL' >> ${CONFIGURE_WRKSRC}/config.h
@@ -76,10 +80,6 @@ post-configure:
@${ECHO_CMD} '#ifndef SEMVMX' >> ${WRKSRC}/config.h
@${ECHO_CMD} '#define SEMVMX 32767' >> ${WRKSRC}/config.h
@${ECHO_CMD} '#endif' >> ${WRKSRC}/config.h
-# disable GNU auto* tools
- @${FIND} ${WRKSRC} -type f -name "Makefile" | ${XARGS} \
- -n 10 ${REINPLACE_CMD} -E -e \
- 's! (autoconf|autoheader|automake|aclocal)$$! ${TRUE}!'
post-install:
.ifndef(NOPORTDOCS)