aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2009-11-05 05:42:23 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2009-11-05 05:42:23 +0800
commitd5eec44f172458e0db29b9bf29fdacf63deb16b0 (patch)
treeefa77280fe33baf9b632aa18e9917cf8019e129e
parent4a6894a0c11a18246f3afdad3796de3110778323 (diff)
downloadfreebsd-ports-gnome-d5eec44f172458e0db29b9bf29fdacf63deb16b0.tar.gz
freebsd-ports-gnome-d5eec44f172458e0db29b9bf29fdacf63deb16b0.tar.zst
freebsd-ports-gnome-d5eec44f172458e0db29b9bf29fdacf63deb16b0.zip
- Unbreak on 9.0
-rw-r--r--graphics/yafaray/Makefile8
-rw-r--r--graphics/yafaray/files/patch-SConstruct7
-rw-r--r--graphics/yafray/Makefile8
-rw-r--r--graphics/yafray/files/patch-SConstruct7
-rw-r--r--security/pam_smb/files/patch-configure11
5 files changed, 21 insertions, 20 deletions
diff --git a/graphics/yafaray/Makefile b/graphics/yafaray/Makefile
index 2a3a7c484bc3..57f99c3dbeab 100644
--- a/graphics/yafaray/Makefile
+++ b/graphics/yafaray/Makefile
@@ -23,10 +23,4 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
pre-patch:
@${MV} ${WRKSRC}/linux-settings.py ${WRKSRC}/freebsd-settings.py
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 900000
-BROKEN= does not build
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/yafaray/files/patch-SConstruct b/graphics/yafaray/files/patch-SConstruct
index 0153782ec35e..fade40439216 100644
--- a/graphics/yafaray/files/patch-SConstruct
+++ b/graphics/yafaray/files/patch-SConstruct
@@ -1,6 +1,6 @@
---- SConstruct.orig 2006-06-20 13:24:00.000000000 -0400
-+++ SConstruct 2007-12-05 18:04:58.000000000 -0500
-@@ -8,6 +8,10 @@
+--- SConstruct.orig 2006-06-20 21:24:00.000000000 +0400
++++ SConstruct 2009-11-04 20:56:07.000000000 +0300
+@@ -8,6 +8,11 @@
ficheros = {
'darwin' : 'darwin-settings',
'linux2' : 'linux-settings',
@@ -8,6 +8,7 @@
+'freebsd6' : 'freebsd-settings',
+'freebsd7' : 'freebsd-settings',
+'freebsd8' : 'freebsd-settings',
++'freebsd9' : 'freebsd-settings',
'win32' : 'win32-settings',
'sunos5' : 'sunos5-settings'
}
diff --git a/graphics/yafray/Makefile b/graphics/yafray/Makefile
index 2a3a7c484bc3..57f99c3dbeab 100644
--- a/graphics/yafray/Makefile
+++ b/graphics/yafray/Makefile
@@ -23,10 +23,4 @@ WRKSRC= ${WRKDIR}/${PORTNAME}
pre-patch:
@${MV} ${WRKSRC}/linux-settings.py ${WRKSRC}/freebsd-settings.py
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 900000
-BROKEN= does not build
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/yafray/files/patch-SConstruct b/graphics/yafray/files/patch-SConstruct
index 0153782ec35e..fade40439216 100644
--- a/graphics/yafray/files/patch-SConstruct
+++ b/graphics/yafray/files/patch-SConstruct
@@ -1,6 +1,6 @@
---- SConstruct.orig 2006-06-20 13:24:00.000000000 -0400
-+++ SConstruct 2007-12-05 18:04:58.000000000 -0500
-@@ -8,6 +8,10 @@
+--- SConstruct.orig 2006-06-20 21:24:00.000000000 +0400
++++ SConstruct 2009-11-04 20:56:07.000000000 +0300
+@@ -8,6 +8,11 @@
ficheros = {
'darwin' : 'darwin-settings',
'linux2' : 'linux-settings',
@@ -8,6 +8,7 @@
+'freebsd6' : 'freebsd-settings',
+'freebsd7' : 'freebsd-settings',
+'freebsd8' : 'freebsd-settings',
++'freebsd9' : 'freebsd-settings',
'win32' : 'win32-settings',
'sunos5' : 'sunos5-settings'
}
diff --git a/security/pam_smb/files/patch-configure b/security/pam_smb/files/patch-configure
new file mode 100644
index 000000000000..5ba34c7f24f9
--- /dev/null
+++ b/security/pam_smb/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2009-11-04 20:41:16.000000000 +0300
++++ configure 2009-11-04 20:41:50.000000000 +0300
+@@ -1486,7 +1486,7 @@
+ # results, and the version is kept in special file).
+
+ if test -r /etc/.relid -a "X`uname -n`" = "X`uname -s`" ; then
+- system=MP-RAS-`awk '{print $3}' /etc/.relid'`
++ system=MP-RAS-`awk '{print $3}' /etc/.relid`
+ fi
+ if test "`uname -s`" = "AIX" ; then
+ system=AIX-`uname -v`.`uname -r`