aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2006-12-08 06:14:36 +0800
committerahze <ahze@FreeBSD.org>2006-12-08 06:14:36 +0800
commitd5f291f53a0169dc61362865f8a32525fb8a4623 (patch)
treee012a22d93cc872fbbb62b04e3a93f43ee523cf5
parent53e9698bd629b46e88d7c11d232d3d8d61e4d713 (diff)
downloadfreebsd-ports-gnome-d5f291f53a0169dc61362865f8a32525fb8a4623.tar.gz
freebsd-ports-gnome-d5f291f53a0169dc61362865f8a32525fb8a4623.tar.zst
freebsd-ports-gnome-d5f291f53a0169dc61362865f8a32525fb8a4623.zip
Fix a bug to only allow some geckos to build java xpcom when WITH_JAVA
is defined. PR: ports/105315 Reported by: Reed A. Cartwright <reed@scit.us>
-rw-r--r--www/mozilla/Makefile.common3
1 files changed, 2 insertions, 1 deletions
diff --git a/www/mozilla/Makefile.common b/www/mozilla/Makefile.common
index f01ad81cdfdd..7f691de36a54 100644
--- a/www/mozilla/Makefile.common
+++ b/www/mozilla/Makefile.common
@@ -134,6 +134,7 @@ optimized_cflags_OPTION= "Enable some additional optimizations" off
.for option in ${USE_GECKO_OPTIONS:L}
.if ${_USE_GECKO_OPTIONS_ALL:M${option}}!=""
OPTIONS+= ${option:U} ${${option}_OPTION}
+_${option}= ${TRUE}
.endif
.endfor
@@ -208,7 +209,7 @@ MOZ_OPTIONS+= --disable-debug \
--enable-strip
.endif
-.if defined(WITH_JAVA)
+.if defined(WITH_JAVA) && defined(_WITH_JAVA)
USE_JAVA= yes
JAVA_VERSION+= 1.4+
JAVA_OS+= native