aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordd <dd@FreeBSD.org>2001-06-25 07:45:35 +0800
committerdd <dd@FreeBSD.org>2001-06-25 07:45:35 +0800
commitd6f9730f124b696a9404e46c2851692bea9f851a (patch)
tree6d0e05badb456a82fe9e5489119cb0c9febea5e1
parent36435461f1fa87b60f3e86093f63c378eac2738b (diff)
downloadfreebsd-ports-gnome-d6f9730f124b696a9404e46c2851692bea9f851a.tar.gz
freebsd-ports-gnome-d6f9730f124b696a9404e46c2851692bea9f851a.tar.zst
freebsd-ports-gnome-d6f9730f124b696a9404e46c2851692bea9f851a.zip
Add solitaire, the reference implementation of the Solitaire
encryption algorithm.
-rw-r--r--math/Makefile1
-rw-r--r--math/solitaire/Makefile33
-rw-r--r--math/solitaire/distinfo2
-rw-r--r--math/solitaire/pkg-comment1
-rw-r--r--math/solitaire/pkg-descr9
-rw-r--r--math/solitaire/pkg-plist4
6 files changed, 50 insertions, 0 deletions
diff --git a/math/Makefile b/math/Makefile
index 2880db477da6..6f7979c4a919 100644
--- a/math/Makefile
+++ b/math/Makefile
@@ -102,6 +102,7 @@
SUBDIR += simpack
SUBDIR += slsc
SUBDIR += snns
+ SUBDIR += solitaire
SUBDIR += spar
SUBDIR += spin
SUBDIR += ss
diff --git a/math/solitaire/Makefile b/math/solitaire/Makefile
new file mode 100644
index 000000000000..7ff2dce21996
--- /dev/null
+++ b/math/solitaire/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: solitaire
+# Date created: 11 June 2001
+# Whom: dd
+#
+# $FreeBSD$
+#
+
+PORTNAME= solitaire
+PORTVERSION= 19980817
+CATEGORIES= math misc
+MASTER_SITES= http://www.counterpane.com/ \
+ ${MASTER_SITE_LOCAL} \
+ http://www.unixfreak.org/~dima/distfiles/
+MASTER_SITE_SUBDIR= dd
+DISTFILES= sol.pl sol-test.txt
+
+MAINTAINER= dd@FreeBSD.org
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+STRIP=
+
+do-extract:
+ @${MKDIR} ${WRKDIR}
+ @${CP} -r ${DISTDIR}/sol.pl ${DISTDIR}/sol-test.txt ${WRKDIR}
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/sol.pl ${PREFIX}/bin/solitaire
+ @${MKDIR} ${PREFIX}/share/doc/solitaire
+ @${INSTALL_DATA} ${WRKSRC}/sol.pl ${WRKSRC}/sol-test.txt \
+ ${PREFIX}/share/doc/solitaire
+
+.include <bsd.port.mk>
diff --git a/math/solitaire/distinfo b/math/solitaire/distinfo
new file mode 100644
index 000000000000..0c69215583bb
--- /dev/null
+++ b/math/solitaire/distinfo
@@ -0,0 +1,2 @@
+MD5 (sol.pl) = 9334ee5119b112fc51715be8a8c0ce45
+MD5 (sol-test.txt) = f3bddfb349ed8302568918b988f84786
diff --git a/math/solitaire/pkg-comment b/math/solitaire/pkg-comment
new file mode 100644
index 000000000000..a26a9ec2fbc5
--- /dev/null
+++ b/math/solitaire/pkg-comment
@@ -0,0 +1 @@
+The reference implementation of the Solitaire encryption algorithm
diff --git a/math/solitaire/pkg-descr b/math/solitaire/pkg-descr
new file mode 100644
index 000000000000..e3f998b9297a
--- /dev/null
+++ b/math/solitaire/pkg-descr
@@ -0,0 +1,9 @@
+Solitaire is an encryption system based on a deck of cards by Bruce
+Schneier. Although it is designed to be worked out by a human, it can
+work on computers. This is the reference implementation programmed in
+Perl. The program itself is installed as 'solitaire', and the source
+code and test vectors are installed in share/doc/solitaire.
+
+Please read the web site below before relying on this for real security.
+
+WWW: http://www.counterpane.com/solitaire.html
diff --git a/math/solitaire/pkg-plist b/math/solitaire/pkg-plist
new file mode 100644
index 000000000000..ca675ed145c8
--- /dev/null
+++ b/math/solitaire/pkg-plist
@@ -0,0 +1,4 @@
+bin/solitaire
+share/doc/solitaire/sol.pl
+share/doc/solitaire/sol-test.txt
+@dirrm share/doc/solitaire