aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorehaupt <ehaupt@FreeBSD.org>2013-05-06 23:09:53 +0800
committerehaupt <ehaupt@FreeBSD.org>2013-05-06 23:09:53 +0800
commitd7700830d846aa135f6cc2d27c2ad15d2c795b13 (patch)
tree4de5e5041b6f44afd9dbca5e64593568668b8372
parent26f9652bc14f63494ae31eb2421a493dff7b7179 (diff)
downloadfreebsd-ports-gnome-d7700830d846aa135f6cc2d27c2ad15d2c795b13.tar.gz
freebsd-ports-gnome-d7700830d846aa135f6cc2d27c2ad15d2c795b13.tar.zst
freebsd-ports-gnome-d7700830d846aa135f6cc2d27c2ad15d2c795b13.zip
- Rewrite to use new options framework
- Fix build with devel/bmake - WWW disappeared, use freecode page as an alternative - Remove mail/mixminion as an option since it requires an unsupported python version PR: 178303 Approved by: Thomas Sander <thomas.sander@gmx.de> (maintainer)
-rw-r--r--net-mgmt/tork/Makefile42
-rw-r--r--net-mgmt/tork/pkg-descr10
2 files changed, 19 insertions, 33 deletions
diff --git a/net-mgmt/tork/Makefile b/net-mgmt/tork/Makefile
index 8d70a885b222..6486fae7f0c7 100644
--- a/net-mgmt/tork/Makefile
+++ b/net-mgmt/tork/Makefile
@@ -3,7 +3,7 @@
PORTNAME= tork
PORTVERSION= 0.30
-PORTREVISION= 5
+PORTREVISION= 6
CATEGORIES= net-mgmt security
MASTER_SITES= SF/${PORTNAME}/TorK%20Source%20Tarball/TorK-${PORTVERSION}
@@ -26,42 +26,28 @@ MAN1= tork.1 torkarkollon.1 torkify.1 torksocks.1
MAN5= torksocks.conf.5
MAN8= torksocks.8
-HAVE_TOR!= if pkg_info -I tor-\* >/dev/null 2>&1 ; then ${ECHO} YES; fi
+OPTIONS_DEFINE= PRIVOXY
-.if (${HAVE_TOR} == "YES")
-HAVE_TOR_DEVEL!= if pkg_info -I tor-devel\* >/dev/null 2>&1 ; then ${ECHO} YES; fi
+PRIVOXY_DESC= Install privoxy
-.if (${HAVE_TOR_DEVEL} == "YES")
-OPTIONS= TOR_DEVEL "Depend on tor-devel (already installed)" On
-.else
-OPTIONS= TOR "Depend on tor (already installed)" On
-.endif
+OPTIONS_SINGLE= TOR
+OPTIONS_SINGLE_TOR= TOR_STD TOR_DEVEL
-.else
-OPTIONS= TOR_DEVEL "Depend on tor-devel" On \
- TOR "Depend on tor" Off
-.endif
+TOR_STD_DESC= Use stable security/tor port
+TOR_DEVEL_DESC= Use development security/tor-devel port
-OPTIONS+= PRIVOXY "Install privoxy" On \
- MIXMINION "Install mixminion" Off
+OPTIONS_DEFAULT= TOR_STD PRIVOXY
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_TOR_DEVEL)
-.if defined(WITH_TOR)
-IGNORE= cannot depend on tor and tor-devel at the same time
-.endif
-RUN_DEPENDS+= ${LOCALBASE}/bin/tor:${PORTSDIR}/security/tor-devel
-.elif defined(WITH_TOR)
+.if ${PORT_OPTIONS:MTOR_STD}
RUN_DEPENDS+= ${LOCALBASE}/bin/tor:${PORTSDIR}/security/tor
+.else
+RUN_DEPENDS+= ${LOCALBASE}/share/tor/geoip6:${PORTSDIR}/security/tor-devel
.endif
-.if defined(WITH_PRIVOXY)
+.if ${PORT_OPTIONS:MPRIVOXY}
RUN_DEPENDS+= ${LOCALBASE}/sbin/privoxy:${PORTSDIR}/www/privoxy
.endif
-.if defined(WITH_MIXMINION)
-RUN_DEPENDS+= ${LOCALBASE}/bin/mixminion:${PORTSDIR}/mail/mixminion
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-mgmt/tork/pkg-descr b/net-mgmt/tork/pkg-descr
index 4a6a27f214c5..d837f3a44a50 100644
--- a/net-mgmt/tork/pkg-descr
+++ b/net-mgmt/tork/pkg-descr
@@ -1,7 +1,7 @@
TorK is a powerful anonymity manager for the KDE Desktop on Linux and Unix
-systems. It first helps you to install, configure and use Tor. It then
-reduces the task of anonymizing most applications to a single-click, including
-Firefox, Opera, Konqueror, Pidgin, Kopete, SSH, and IRC. For advanced users
-TorK provides detailed network information, and more, in an accessible manner.
+systems. It first helps you to install, configure and use Tor. It then reduces
+the task of anonymizing most applications to a single-click, including Firefox,
+Opera, Konqueror, Pidgin, Kopete, SSH, and IRC. For advanced users TorK provides
+detailed network information, and more, in an accessible manner.
-WWW: http://www.anonymityanywhere.com/tork/
+WWW: http://freecode.com/projects/tork