aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authormaho <maho@FreeBSD.org>2007-07-12 15:39:20 +0800
committermaho <maho@FreeBSD.org>2007-07-12 15:39:20 +0800
commitd79dd446b4f798b3f3b865a20686bd6e52703fe1 (patch)
treef43dfdd62e78362cb2ba03d2d317e4d1e1099762
parent73479c6a710e779eaf28d1df4ae1fbe13f0dc013 (diff)
downloadfreebsd-ports-gnome-d79dd446b4f798b3f3b865a20686bd6e52703fe1.tar.gz
freebsd-ports-gnome-d79dd446b4f798b3f3b865a20686bd6e52703fe1.tar.zst
freebsd-ports-gnome-d79dd446b4f798b3f3b865a20686bd6e52703fe1.zip
Now we use USE_FORTRAN=yes to use FORTRAN compiler.
-rw-r--r--graphics/gplot/Makefile6
-rw-r--r--graphics/ruby-pgplot/Makefile5
-rw-r--r--science/hdf/Makefile7
3 files changed, 4 insertions, 14 deletions
diff --git a/graphics/gplot/Makefile b/graphics/gplot/Makefile
index f95d15d0849c..16afc40eed8f 100644
--- a/graphics/gplot/Makefile
+++ b/graphics/gplot/Makefile
@@ -20,11 +20,7 @@ NO_WRKSUBDIR= yes
ALL_TARGET= drawcgm gtex gplot
MAN1= gplot.1
DOCS= gplot.hlp gplot.txt gtex.doc
-WANT_FORTRAN=yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
-MAKE_ENV+= FC="${FC}" F77="${F77}"
+USE_FORTRAN= yes
.include <bsd.port.pre.mk>
diff --git a/graphics/ruby-pgplot/Makefile b/graphics/ruby-pgplot/Makefile
index 723cc6a61018..adc09502b3fe 100644
--- a/graphics/ruby-pgplot/Makefile
+++ b/graphics/ruby-pgplot/Makefile
@@ -22,10 +22,7 @@ LIB_DEPENDS= pgplot.5:${PORTSDIR}/graphics/pgplot
BUILD_DEPENDS= ${RUBY_SITEARCHLIBDIR}/narray.so:${PORTSDIR}/math/ruby-narray
RUN_DEPENDS= ${RUBY_SITEARCHLIBDIR}/narray.so:${PORTSDIR}/math/ruby-narray
-WANT_FORTRAN= yes #dummy but future use
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
+USE_FORTRAN= yes
USE_RUBY= yes
USE_RUBY_EXTCONF= yes
diff --git a/science/hdf/Makefile b/science/hdf/Makefile
index 85960f3ccf0f..1a49229b9b91 100644
--- a/science/hdf/Makefile
+++ b/science/hdf/Makefile
@@ -27,16 +27,13 @@ LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
CONFLICTS= netcdf-*
-WANT_FORTRAN= yes
-BUILD_DEPENDS+= gfortran42:${PORTSDIR}/lang/gcc42
-FC= gfortran42
-F77= gfortran42
+USE_FORTRAN= yes
USE_AUTOTOOLS= libtool:15
CONFIGURE_ARGS+=--with-jpeg="${LOCALBASE}" \
--with-szlib="${LOCALBASE}"
#wiredness of F77, FC in hdf/src/Makefile
-CONFIGURE_ENV+= F77="f77" FC="f77" FFLAGS="${FFLAGS}"
+CONFIGURE_ENV+= F77="f77" FC="f77"
MAKE_ENV+= PATH="${WRKSRC}/bin:${PATH}"
DOCFILES= HDF41r5_SpecDG.pdf \
HDF42r0_RefMan.pdf \