aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2011-07-26 06:03:16 +0800
committerpav <pav@FreeBSD.org>2011-07-26 06:03:16 +0800
commitd7a22a61af9d71fd9f6d9024e8582a0cbfaf5b7d (patch)
tree28fab98b1c690e5495e36c31d3ca32e0d53bf2e9
parentf42e74abd7b4b2293d4b7149d6076b7e32498c12 (diff)
downloadfreebsd-ports-gnome-d7a22a61af9d71fd9f6d9024e8582a0cbfaf5b7d.tar.gz
freebsd-ports-gnome-d7a22a61af9d71fd9f6d9024e8582a0cbfaf5b7d.tar.zst
freebsd-ports-gnome-d7a22a61af9d71fd9f6d9024e8582a0cbfaf5b7d.zip
- Fix build with new libgcrypt
- Provide avahi option PR: ports/159018 Submitted by: Grzegorz Blach <magik@roorback.net> (maintainer)
-rw-r--r--audio/ario/Makefile20
-rw-r--r--audio/ario/files/patch-src_ario-avahi.c14
2 files changed, 29 insertions, 5 deletions
diff --git a/audio/ario/Makefile b/audio/ario/Makefile
index dc28cea02fc0..d3657bac26bb 100644
--- a/audio/ario/Makefile
+++ b/audio/ario/Makefile
@@ -13,7 +13,10 @@ MASTER_SITES= SF/ario-player/ario-player/${PORTVERSION}
MAINTAINER= magik@roorback.net
COMMENT= Ario is a GTK2 client for MPD
+LICENSE= GPLv2
+
LIB_DEPENDS= gnutls:${PORTSDIR}/security/gnutls \
+ gcrypt:${PORTSDIR}/security/libgcrypt \
curl:${PORTSDIR}/ftp/curl \
notify:${PORTSDIR}/devel/libnotify \
soup:${PORTSDIR}/devel/libsoup22 \
@@ -22,21 +25,28 @@ LIB_DEPENDS= gnutls:${PORTSDIR}/security/gnutls \
mpdclient:${PORTSDIR}/audio/libmpdclient
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-avahi # without this ario don't build
USE_LDCONFIG= yes
USE_GMAKE= yes
USE_GNOME= gtk20 gnomehack gnometarget
INSTALLS_ICONS= yes
-OPTIONS= NLS "Use NLS" On
+OPTIONS= AVAHI "Zeroconf support (Avahi)" Off \
+ NLS "NLS support" On
.include <bsd.port.options.mk>
-.if defined(WITHOUT_NLS)
-CONFIGURE_ARGS+= --disable-nls
+.if defined(WITH_AVAHI)
+LIB_DEPENDS+= avahi-client:${PORTSDIR}/net/avahi-app
+CONFIGURE_ARGS+= --enable-avahi
.else
-CONFIGURE_ARGS+= --enable-nls
+CONFIGURE_ARGS+= --disable-avahi
+.endif
+
+.if ! defined(WITHOUT_NLS)
USE_GETTEXT= yes
+CONFIGURE_ARGS+= --enable-nls
+.else
+CONFIGURE_ARGS+= --disable-nls
.endif
.include <bsd.port.mk>
diff --git a/audio/ario/files/patch-src_ario-avahi.c b/audio/ario/files/patch-src_ario-avahi.c
new file mode 100644
index 000000000000..7e72c30dd214
--- /dev/null
+++ b/audio/ario/files/patch-src_ario-avahi.c
@@ -0,0 +1,14 @@
+--- src/ario-avahi.c.orig 2011-07-18 20:05:50.915461042 +0200
++++ src/ario-avahi.c 2011-07-18 20:08:56.334574365 +0200
+@@ -34,6 +34,11 @@
+ #include <avahi-common/simple-watch.h>
+ #include "ario-debug.h"
+
++#ifdef __FreeBSD__
++#include <sys/socket.h>
++#include <netinet/in.h>
++#endif
++
+ #define SERVICE_TYPE "_mpd._tcp"
+ #define DOMAIN "local"
+