aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorijliao <ijliao@FreeBSD.org>2003-06-22 11:14:35 +0800
committerijliao <ijliao@FreeBSD.org>2003-06-22 11:14:35 +0800
commitd8d0e62430bcf0c67daad5398ae6c006248326f1 (patch)
tree22d6547c21a92b60a530b4413efbf87c8d8c67ae
parentb1ae87b965d0363d41b043e3085e623d0a39677a (diff)
downloadfreebsd-ports-gnome-d8d0e62430bcf0c67daad5398ae6c006248326f1.tar.gz
freebsd-ports-gnome-d8d0e62430bcf0c67daad5398ae6c006248326f1.tar.zst
freebsd-ports-gnome-d8d0e62430bcf0c67daad5398ae6c006248326f1.zip
upgrade to 3.0.0
pass maintainership to submitter PR: 53586 Submitted by: Kirill Ponomarew <ponomarew@oberon.net>
-rw-r--r--security/beecrypt/Makefile10
-rw-r--r--security/beecrypt/distinfo2
-rw-r--r--security/beecrypt/files/patch-ltmain.sh15
-rw-r--r--security/beecrypt/pkg-plist26
4 files changed, 39 insertions, 14 deletions
diff --git a/security/beecrypt/Makefile b/security/beecrypt/Makefile
index 19cf386b6d91..2282ae28a011 100644
--- a/security/beecrypt/Makefile
+++ b/security/beecrypt/Makefile
@@ -7,17 +7,21 @@
#
PORTNAME= beecrypt
-PORTVERSION= 2.1.0
+PORTVERSION= 3.0.0
CATEGORIES= security
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE} \
http://www.virtualunlimited.com/download/
MASTER_SITE_SUBDIR= ${PORTNAME}
-MAINTAINER= ijliao@FreeBSD.org
+MAINTAINER= ponomarew@oberon.net
COMMENT= BeeCrypt is an open source cryptography library
+USE_REINPLACE= yes
GNU_CONFIGURE= yes
-
+USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
+post-patch:
+ @${REINPLACE_CMD} -e "s|-pthread|${PTHREAD_LIBS}|g" ${WRKSRC}/configure
+
.include <bsd.port.mk>
diff --git a/security/beecrypt/distinfo b/security/beecrypt/distinfo
index acb3e41c976e..872f9033e8de 100644
--- a/security/beecrypt/distinfo
+++ b/security/beecrypt/distinfo
@@ -1 +1 @@
-MD5 (beecrypt-2.1.0.tar.gz) = 64af60feb0bd6678af6042b409e1f925
+MD5 (beecrypt-3.0.0.tar.gz) = 18f20c22443f85bd4e285925b56198d9
diff --git a/security/beecrypt/files/patch-ltmain.sh b/security/beecrypt/files/patch-ltmain.sh
new file mode 100644
index 000000000000..d8b5bbd6a218
--- /dev/null
+++ b/security/beecrypt/files/patch-ltmain.sh
@@ -0,0 +1,15 @@
+--- ltmain.sh.orig Sun Jun 22 02:00:15 2003
++++ ltmain.sh Sun Jun 22 02:00:28 2003
+@@ -4302,10 +4302,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false ; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
diff --git a/security/beecrypt/pkg-plist b/security/beecrypt/pkg-plist
index 76d975418506..afb8d827faf1 100644
--- a/security/beecrypt/pkg-plist
+++ b/security/beecrypt/pkg-plist
@@ -1,5 +1,10 @@
+include/beecrypt/aes.h
+include/beecrypt/aesopt.h
include/beecrypt/base64.h
+include/beecrypt/beecrypt.api.h
+include/beecrypt/beecrypt.gnu.h
include/beecrypt/beecrypt.h
+include/beecrypt/beecrypt.win.h
include/beecrypt/blockmode.h
include/beecrypt/blockpad.h
include/beecrypt/blowfish.h
@@ -9,11 +14,10 @@ include/beecrypt/dldp.h
include/beecrypt/dlkp.h
include/beecrypt/dlpk.h
include/beecrypt/dlsvdp-dh.h
+include/beecrypt/dsa.h
include/beecrypt/elgamal.h
include/beecrypt/endianness.h
include/beecrypt/entropy.h
-include/beecrypt/fips180.h
-include/beecrypt/fips180opt.h
include/beecrypt/fips186.h
include/beecrypt/hmac.h
include/beecrypt/hmacmd5.h
@@ -21,18 +25,20 @@ include/beecrypt/hmacsha1.h
include/beecrypt/hmacsha256.h
include/beecrypt/md5.h
include/beecrypt/memchunk.h
-include/beecrypt/mp32.h
-include/beecrypt/mp32barrett.h
-include/beecrypt/mp32number.h
-include/beecrypt/mp32opt.h
-include/beecrypt/mp32prime.h
+include/beecrypt/mp.h
+include/beecrypt/mpbarrett.h
+include/beecrypt/mpnumber.h
+include/beecrypt/mpopt.h
+include/beecrypt/mpprime.h
include/beecrypt/mtprng.h
include/beecrypt/rsa.h
include/beecrypt/rsakp.h
include/beecrypt/rsapk.h
+include/beecrypt/sha1.h
+include/beecrypt/sha1opt.h
include/beecrypt/sha256.h
include/beecrypt/timestamp.h
-@dirrm include/beecrypt
-lib/libbeecrypt.la
+lib/libbeecrypt.a
lib/libbeecrypt.so
-lib/libbeecrypt.so.3
+lib/libbeecrypt.so.6
+@dirrm include/beecrypt