aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorchinsan <chinsan@FreeBSD.org>2008-09-07 10:08:31 +0800
committerchinsan <chinsan@FreeBSD.org>2008-09-07 10:08:31 +0800
commitd90d180ef2db5348ac0ecabfcb8ce153fc1f8a10 (patch)
tree00ff928301feb606037599b9c6c424c0a9ca1e31
parent4f5895359d2c5008b5c120ca007bc5749ef9cdb7 (diff)
downloadfreebsd-ports-gnome-d90d180ef2db5348ac0ecabfcb8ce153fc1f8a10.tar.gz
freebsd-ports-gnome-d90d180ef2db5348ac0ecabfcb8ce153fc1f8a10.tar.zst
freebsd-ports-gnome-d90d180ef2db5348ac0ecabfcb8ce153fc1f8a10.zip
Add p5-Test-TempDir, provides temporary directory creation with testing in mind.
WWW: http://search.cpan.org/dist/Test-TempDir/
-rw-r--r--devel/Makefile1
-rw-r--r--devel/p5-Test-TempDir/Makefile31
-rw-r--r--devel/p5-Test-TempDir/distinfo3
-rw-r--r--devel/p5-Test-TempDir/pkg-descr3
-rw-r--r--devel/p5-Test-TempDir/pkg-plist8
5 files changed, 46 insertions, 0 deletions
diff --git a/devel/Makefile b/devel/Makefile
index 54bd060445ae..4e118c1a38bc 100644
--- a/devel/Makefile
+++ b/devel/Makefile
@@ -1761,6 +1761,7 @@
SUBDIR += p5-Test-SubCalls
SUBDIR += p5-Test-TAP-HTMLMatrix
SUBDIR += p5-Test-TAP-Model
+ SUBDIR += p5-Test-TempDir
SUBDIR += p5-Test-Tester
SUBDIR += p5-Test-Unit
SUBDIR += p5-Test-UseAllModules
diff --git a/devel/p5-Test-TempDir/Makefile b/devel/p5-Test-TempDir/Makefile
new file mode 100644
index 000000000000..864f7cba4b1f
--- /dev/null
+++ b/devel/p5-Test-TempDir/Makefile
@@ -0,0 +1,31 @@
+# New ports collection makefile for: devel/p5-Test-TempDir
+# Date created: 2008/09/06
+# Whom: chinsan
+#
+# $FreeBSD$
+#
+
+PORTNAME= Test-TempDir
+PORTVERSION= 0.04
+CATEGORIES= devel perl5
+MASTER_SITES= CPAN
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= chinsan@FreeBSD.org
+COMMENT= Temporary files support for testing
+
+RUN_DEPENDS= p5-Test-use-ok>=0:${PORTSDIR}/devel/p5-Test-use-ok \
+ p5-File-Path>=0:${PORTSDIR}/devel/p5-File-Path \
+ p5-File-Temp>=0:${PORTSDIR}/devel/p5-File-Temp \
+ p5-File-NFSLock>=0:${PORTSDIR}/devel/p5-File-NFSLock \
+ p5-Moose>=0:${PORTSDIR}/devel/p5-Moose \
+ p5-MooseX-Types-Path-Class>=0:${PORTSDIR}/devel/p5-MooseX-Types-Path-Class \
+ p5-Sub-Exporter>=0:${PORTSDIR}/devel/p5-Sub-Exporter \
+ p5-namespace-clean>=0:${PORTSDIR}/devel/p5-namespace-clean
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Test::TempDir.3 Test::TempDir::Factory.3 Test::TempDir::Handle.3
+
+.include <bsd.port.mk>
diff --git a/devel/p5-Test-TempDir/distinfo b/devel/p5-Test-TempDir/distinfo
new file mode 100644
index 000000000000..0e5d2ef35ffd
--- /dev/null
+++ b/devel/p5-Test-TempDir/distinfo
@@ -0,0 +1,3 @@
+MD5 (Test-TempDir-0.04.tar.gz) = 66d60bd4463bd01b71144cc7cb6585a8
+SHA256 (Test-TempDir-0.04.tar.gz) = 2d0e2fbb5ebecfc41941f3acb8d81dece6e6ede059d284c6c2ce51e8600f2ff6
+SIZE (Test-TempDir-0.04.tar.gz) = 7034
diff --git a/devel/p5-Test-TempDir/pkg-descr b/devel/p5-Test-TempDir/pkg-descr
new file mode 100644
index 000000000000..e326ada571fa
--- /dev/null
+++ b/devel/p5-Test-TempDir/pkg-descr
@@ -0,0 +1,3 @@
+Test::TempDir provides temporary directory creation with testing in mind.
+
+WWW: http://search.cpan.org/dist/Test-TempDir/
diff --git a/devel/p5-Test-TempDir/pkg-plist b/devel/p5-Test-TempDir/pkg-plist
new file mode 100644
index 000000000000..3c560afbaa06
--- /dev/null
+++ b/devel/p5-Test-TempDir/pkg-plist
@@ -0,0 +1,8 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/TempDir/.packlist
+%%SITE_PERL%%/Test/TempDir.pm
+%%SITE_PERL%%/Test/TempDir/Factory.pm
+%%SITE_PERL%%/Test/TempDir/Handle.pm
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test/TempDir
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Test
+@dirrmtry %%SITE_PERL%%/Test/TempDir
+@dirrmtry %%SITE_PERL%%/Test