aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorknu <knu@FreeBSD.org>2001-01-06 18:48:02 +0800
committerknu <knu@FreeBSD.org>2001-01-06 18:48:02 +0800
commitdabe5b651cb3fcddc6c2449a390f12c4caf5bb49 (patch)
treed37a5bdc36483addfbfec1b494ec577cfbcd37ab
parent5537d20c216d70de70173eb529011d5384cbe5df (diff)
downloadfreebsd-ports-gnome-dabe5b651cb3fcddc6c2449a390f12c4caf5bb49.tar.gz
freebsd-ports-gnome-dabe5b651cb3fcddc6c2449a390f12c4caf5bb49.tar.zst
freebsd-ports-gnome-dabe5b651cb3fcddc6c2449a390f12c4caf5bb49.zip
Fix configure script to properly detect FreeBSD's dlopen() facility.
This get libslang built with the dynamic linking feature (import() etc.). PORTREVISION bumped. Approved by: MAINTAINER
-rw-r--r--devel/libslang/Makefile1
-rw-r--r--devel/libslang/files/patch-aa34
2 files changed, 31 insertions, 4 deletions
diff --git a/devel/libslang/Makefile b/devel/libslang/Makefile
index 5a3c8abc08f0..d6ff2057c73e 100644
--- a/devel/libslang/Makefile
+++ b/devel/libslang/Makefile
@@ -7,6 +7,7 @@
PORTNAME= libslang
PORTVERSION= 1.4.2
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= ftp://space.mit.edu/pub/davis/slang/v1.4/
DISTNAME= slang-${PORTVERSION}
diff --git a/devel/libslang/files/patch-aa b/devel/libslang/files/patch-aa
index 86e1247ba835..6527bcf36932 100644
--- a/devel/libslang/files/patch-aa
+++ b/devel/libslang/files/patch-aa
@@ -1,6 +1,32 @@
---- configure.orig Sun Aug 20 04:20:18 2000
-+++ configure Sun Aug 20 22:21:40 2000
-@@ -1906,6 +1906,19 @@
+--- configure.orig Sun Aug 20 11:20:18 2000
++++ configure Sat Jan 6 09:57:40 2001
+@@ -1753,14 +1753,13 @@
+ fi
+
+
+-echo $ac_n "checking for dlopen in -ldl""... $ac_c" 1>&6
+-echo "configure:1758: checking for dlopen in -ldl" >&5
++echo $ac_n "checking for dlopen""... $ac_c" 1>&6
++echo "configure:1758: checking for dlopen" >&5
+ ac_lib_var=`echo dl'_'dlopen | sed 'y%./+-%__p_%'`
+ if eval "test \"`echo '$''{'ac_cv_lib_$ac_lib_var'+set}'`\" = set"; then
+ echo $ac_n "(cached) $ac_c" 1>&6
+ else
+ ac_save_LIBS="$LIBS"
+-LIBS="-ldl $LIBS"
+ cat > conftest.$ac_ext <<EOF
+ #line 1766 "configure"
+ #include "confdefs.h"
+@@ -1818,7 +1817,7 @@
+ if eval "test \"`echo '$ac_cv_header_'$ac_safe`\" = yes"; then
+ echo "$ac_t""yes" 1>&6
+
+- DYNAMIC_LINK_LIB="-ldl"
++ DYNAMIC_LINK_LIB=""
+ cat >> confdefs.h <<\EOF
+ #define HAVE_DLFCN_H 1
+ EOF
+@@ -1906,6 +1905,19 @@
IEEE_CFLAGS="-ieee_with_no_inexact"
fi
;;
@@ -20,7 +46,7 @@
* )
IEEE_CFLAGS=""
esac
-@@ -2231,16 +2244,8 @@
+@@ -2231,16 +2243,8 @@
echo $ac_n "checking SLANG_VERSION""... $ac_c" 1>&6
echo "configure:2234: checking SLANG_VERSION" >&5