aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorwxs <wxs@FreeBSD.org>2009-08-15 21:33:54 +0800
committerwxs <wxs@FreeBSD.org>2009-08-15 21:33:54 +0800
commitde84dc83f8d476755d3b236fa178924a271c2c95 (patch)
tree916a56893b39bcdd12fc984e93c6599a8c246c66
parentf064b3decd02afe9c0d24c04001417e8e79b40c3 (diff)
downloadfreebsd-ports-gnome-de84dc83f8d476755d3b236fa178924a271c2c95.tar.gz
freebsd-ports-gnome-de84dc83f8d476755d3b236fa178924a271c2c95.tar.zst
freebsd-ports-gnome-de84dc83f8d476755d3b236fa178924a271c2c95.zip
- Add RC script
- No need to use pre-build target - Fix up plist PR: ports/136903 Submitted by: Antonio Querubin <tony@lava.net> Approved by: maintainer timeout
-rw-r--r--net/beacon/Makefile8
-rw-r--r--net/beacon/files/beacon.in30
-rw-r--r--net/beacon/pkg-plist1
3 files changed, 33 insertions, 6 deletions
diff --git a/net/beacon/Makefile b/net/beacon/Makefile
index e90028ff48b7..318785fae0a4 100644
--- a/net/beacon/Makefile
+++ b/net/beacon/Makefile
@@ -7,7 +7,7 @@
PORTNAME= beacon
PORTVERSION= 1.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= net perl5 mbone ipv6
MASTER_SITES= http://dast.nlanr.net/Projects/Beacon/releases/
DISTNAME= ${PORTNAME}-${PORTVERSION}
@@ -22,6 +22,7 @@ WWW_DIR?= ${PREFIX}/www/
PLIST_SUB+= VERSION=${PORTVERSION}
USE_PERL5= yes
USE_AUTOTOOLS= autoconf:262
+USE_RC_SUBR= beacon
.ifdef(WITHOUT_IPV6)
CONFIGURE_ARGS=
@@ -38,11 +39,6 @@ CONFIGURE_ARGS+= --enable-ipv6
BROKEN= Does not compile on !i386
.endif
-pre-build:
- cd ${WRKSRC}/Net-Multicast-Beacon && \
- make Makefile.perl && \
- ${REINPLACE_CMD} -E 's,doc_\$$\(INSTALLDIRS\)_install$$,,g' Makefile.perl
-
post-install:
@${ECHO} "Sample config installed at \
${PREFIX}/etc/beacon.conf.sample"
diff --git a/net/beacon/files/beacon.in b/net/beacon/files/beacon.in
new file mode 100644
index 000000000000..be2a8fffd651
--- /dev/null
+++ b/net/beacon/files/beacon.in
@@ -0,0 +1,30 @@
+#!/bin/sh
+#
+# $FreeBSD$
+#
+# PROVIDE: beacon
+# REQUIRE: DAEMON
+# KEYWORD: shutdown
+#
+# Add the following lines to /etc/rc.conf to enable beacon.
+#
+# beacon_enable="YES"
+
+beacon_enable=${beacon_enable-"NO"}
+
+. %%RC_SUBR%%
+
+name="beacon"
+rcvar=`set_rcvar`
+
+command="%%PREFIX%%/bin/${name}"
+
+conffile=%%PREFIX%%/etc/beacon.conf
+if [ -f $conffile ]; then
+ piddir=`grep OUTPUTDIR $conffile | awk '{print $3}'`
+fi
+pidfile=${piddir}/multicastbeacon.PID
+
+load_rc_config $name
+
+run_rc_command "$1"
diff --git a/net/beacon/pkg-plist b/net/beacon/pkg-plist
index b734cbba0e3a..2ea49efb5e87 100644
--- a/net/beacon/pkg-plist
+++ b/net/beacon/pkg-plist
@@ -2,6 +2,7 @@
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Multicast/Beacon/Beacon.bs
%%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Multicast/Beacon/.packlist
%%SITE_PERL%%/%%PERL_ARCH%%/Net/Multicast/Beacon.pm
+lib/perl5/%%PERL_VER%%/%%PERL_ARCH%%/perllocal.pod
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Multicast/Beacon
@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net/Multicast/
@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Net