aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2006-12-20 06:29:34 +0800
committeredwin <edwin@FreeBSD.org>2006-12-20 06:29:34 +0800
commite18055da54ac8639b15f44351eb0d4f6eb04478c (patch)
treee46c0d23a0ca82e2b3e5067538176de6196e76f3
parentd99439ab103f2082ec9f9574b7c2bd523e57da69 (diff)
downloadfreebsd-ports-gnome-e18055da54ac8639b15f44351eb0d4f6eb04478c.tar.gz
freebsd-ports-gnome-e18055da54ac8639b15f44351eb0d4f6eb04478c.tar.zst
freebsd-ports-gnome-e18055da54ac8639b15f44351eb0d4f6eb04478c.zip
Remove USE_GCC
Add patch proudly supplied by Max Khon <fjoe@samodelkin.net> Submitted by: Max Khon <fjoe@samodelkin.net>
-rw-r--r--games/groundhog/Makefile3
-rw-r--r--games/groundhog/files/patch-src-options_dialog.h35
2 files changed, 36 insertions, 2 deletions
diff --git a/games/groundhog/Makefile b/games/groundhog/Makefile
index f4c9ea3c1b0f..5f7a7054093a 100644
--- a/games/groundhog/Makefile
+++ b/games/groundhog/Makefile
@@ -7,7 +7,7 @@
PORTNAME= groundhog
PORTVERSION= 1.4
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= games
MASTER_SITES= http://home-2.tiscali.nl/~cb007736/
@@ -16,7 +16,6 @@ COMMENT= Groundhog, a simple logic game
USE_GMAKE= yes
USE_GNOME= gtk20
-USE_GCC= 3.4
GNU_CONFIGURE= yes
.include <bsd.port.mk>
diff --git a/games/groundhog/files/patch-src-options_dialog.h b/games/groundhog/files/patch-src-options_dialog.h
new file mode 100644
index 000000000000..b0c64880a5a1
--- /dev/null
+++ b/games/groundhog/files/patch-src-options_dialog.h
@@ -0,0 +1,35 @@
+Index: files/patch-src-element.h
+===================================================================
+RCS file: files/patch-src-element.h
+diff -N files/patch-src-element.h
+--- /dev/null 1 Jan 1970 00:00:00 -0000
++++ files/patch-src-element.h 16 Dec 2006 13:15:54 -0000
+@@ -0,0 +1,10 @@
++--- src/element.h.orig Sat Dec 16 18:57:18 2006
+++++ src/element.h Sat Dec 16 18:57:31 2006
++@@ -24,6 +24,7 @@
++ class Element {
++ public:
++ Element() {}
+++ virtual ~Element() {}
++ virtual void PutBall(Ball* ball);
++ virtual void MoveBall(Ball* ball) = 0;
++ virtual void ConnectLeft(Element* element) = 0;
+Index: files/patch-src-options_dialog.h
+===================================================================
+RCS file: files/patch-src-options_dialog.h
+diff -N files/patch-src-options_dialog.h
+--- /dev/null 1 Jan 1970 00:00:00 -0000
++++ files/patch-src-options_dialog.h 16 Dec 2006 13:16:14 -0000
+@@ -0,0 +1,11 @@
++--- src/options_dialog.h.orig Sat Dec 16 18:57:43 2006
+++++ src/options_dialog.h Sat Dec 16 18:57:50 2006
++@@ -28,7 +28,7 @@
++ Game* _game;
++ GtkWidget* _tooltips;
++
++- void OptionsDialog::OnOk();
+++ void OnOk();
++ public:
++ OptionsDialog(Game* game);
++ };